HELP oil light blinks n idle - evolutionm.net
evolutionm.net - Home of the Lancer Evolution  

Go Back   > >
Log In 


Evo Engine / Turbo / Drivetrain Everything from engine management to the best clutch and flywheel.

HELP oil light blinks n idle

Reply
 
 
 
Thread Tools Search this Thread
Old Mar 17, 2009, 09:41 PM   #1
Account Disabled
Thread Starter
iTrader: ( 100 )
 
Join Date: Oct 2008
Location: Indiana
Posts: 1,179
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: a Evo 8

HELP oil light blinks n idle

Alright guys well i just have a quick question.

Currently i bought an 05 evo 8 w/ 22k miles. The car itself runs great and is a blast to drive. Well since ive got it i noticed that when im in idle the oil light blinks. But when im driving the car it never comes on. THe light blinks on and off only in idle.
View video to see what i mean




Mods

Ams Uicp
Ams Licp
Ams Fuel Rail
Ams small battery
Megan 02
Megan dp
helix test pipe
Invidia N1 cbe
(**FP4R CAMS**)
arp head studs
Exedy Twin Disc
Turbo xs Dv

Tuned to 23psi

The car is on an unknow tune but im getting it retuned this saturday.
I just did an oil change to the car and shes running great.

Well just from thinking, could it be caused just because of the cam idle?
The car idles at 1k and holds that rev very well.

Should i be worried about it?


Plz let mek now what u think it could be thanks

Last edited by Evokid03; Mar 17, 2009 at 09:45 PM.
Offline
 
Reply With Quote
Old Mar 17, 2009, 10:02 PM   #2
Evolved Member
iTrader: ( 27 )
 
abazaba410's Avatar
 
Join Date: Sep 2007
Location: Michigan
Posts: 593
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: EVO IX MR SE

I have the same problem but it only startted happening since i installed cams and am untuned. I also have a tune sat. So oddd r it will fix it
Offline
 
Reply With Quote
Old Mar 17, 2009, 10:06 PM   #3
Evolved Member
iTrader: ( 12 )
 
SRT-TO-EVO's Avatar
 
Join Date: Jul 2005
Location: Westchester, NY
Posts: 1,404
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: WW IX MR

Mine does it slightly (stays dim) when the fan kicks on.
Offline
 
Reply With Quote
Old Mar 17, 2009, 10:10 PM   #4
Account Disabled
Thread Starter
iTrader: ( 100 )
 
Join Date: Oct 2008
Location: Indiana
Posts: 1,179
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: a Evo 8

Ya so my guess its because of the cam


Idk some times it blinks alot and then sumtimes its very dim..


I just wanted to c if it was a major issue or not.

Im assuming its not
Offline
 
Reply With Quote
Old Apr 11, 2009, 10:44 AM   #5
Evolving Member
 
silver_evo's Avatar
 
Join Date: Dec 2005
Location: Silverdale,WA
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 03 Evo VIII

If your idle is low/choppy then the oil pump will have a low discharge pressure. If your idle is ~950 and smooth and your getting the light, id bet that your bearings have excessive clearance and need to be replaced / and have your crank machined. But since you say you just got cams, i bet your idle is pretty rough.
Offline
 
Reply With Quote
Old Apr 11, 2009, 10:47 AM   #6
Evolved Member
iTrader: ( 14 )
 
justa4banger's Avatar
 
Join Date: Mar 2008
Location: underground
Posts: 1,340
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: evo 8

i have the same problem.... ive read tons of posts that its the oil pressure sending unit./....
Offline
 
Reply With Quote
Old Apr 23, 2009, 05:23 PM   #7
Account Disabled
Thread Starter
iTrader: ( 100 )
 
Join Date: Oct 2008
Location: Indiana
Posts: 1,179
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: a Evo 8

Oil light fixed


My new thread

http://forums.evolutionm.net/evo-gen...d-problem.html
Offline
 
Reply With Quote
 
 
Reply


Tags
03, 2005, blinking, blinks, car, clearance, evo, flashing, idle, lancer, light, oil, pressure, srt, turbo, viii

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -7. The time now is 05:02 PM.