evolutionm.net - Home of the Lancer Evolution
Home Features Community Marketplace Registry Garage Store

Go Back   evolutionm.net > EvoM Forums > EvoM Newbie / FAQs Forum
Sign in using an external account
Register Forgot Password?
Search


EvoM Newbie / FAQs Forum New member? Come on in, introduce yourself, and get acquainted with the evolutionm.net posse :) FAQs will also be answered in here.

Welcome to EvolutionM.net!
Welcome to EvolutionM.net.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old Nov 1, 2009, 01:22 PM   #1
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Oct 2009
Location: Schaumburg IL
Posts: 11

Drives: 05 Evo VIII

ACD problems

Just got my car less then a week ago and had time on friday to read through the owners manual. Anyway its an 05 evo VIII and before I start the car I set the ACD switch to the road conditions, obviously. After I selected the mode, I start the car and after five minutes or so of driving all three lights come on and stay on, Tarmac, Gravel, and Snow. The owners manual states this could be a problem cause its supposed to stay just on the one u selected. Guess I have to bring it in to the dealer tommorow or so but was just wondering if anyones had this problem???
Offline
 
Reply With Quote
Old Nov 3, 2009, 04:39 PM   #2
Newbie
Personal Sales Rating: (1)
Garage is empty, add now
 
vjz225's Avatar
 
Join Date: Mar 2006
Location: orland park IL
Posts: 16

Drives: evo 8

acd lights

You have to bleed the system if that doesnt work you will need a new acd pump.
Offline
 
Reply With Quote
Old Nov 3, 2009, 04:47 PM   #3
Evolving Member
Personal Sales Rating: (31)
Garage is empty, add now
 
evoix16's Avatar
 
Join Date: Sep 2008
Location: NW IN
Posts: 167

Drives: EB Evo IX

It should stay on gravel once you set it you shouldnt have to change it but it may be low on fluid as well gl
Offline
 
Reply With Quote
Old Nov 3, 2009, 09:31 PM   #4
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Oct 2009
Location: Schaumburg IL
Posts: 11

Drives: 05 Evo VIII

Its at the dealer now. They said its the acd pump so it will be ready by friday. Good thing the warrantys gunna cover it!!
Offline
 
Reply With Quote
Old Nov 3, 2009, 09:35 PM   #5
Evolved Member
Personal Sales Rating: (19)
2006 Mitsubishi Lancer Evolution
 
buchnerj's Avatar
 
Join Date: Jul 2007
Location: the burgh, pa
Posts: 1,497

Drives: 2006 Evolution IX MR, 1998 Honda Prelude

You can say that again, those pumps are ridiculously expensive new.
__________________
BuschurRacing 2.1L w/Stage 3 Head
Shep 5-speed w/ Exedy Twin HD

Injector Dynamics 2000cc
Full Blown Double Pumper
Robispec/ / / KW3 Custom Clubsports
E-85 Ethanol
Offline
 
Reply With Quote
Old Nov 3, 2009, 09:53 PM   #6
Newbie
Personal Sales Rating: (1)
Garage is empty, add now
 
MajorGunHo's Avatar
 
Join Date: Apr 2008
Location: Black Hills, South Dakota
Posts: 25

Drives: 2006 Evo IX MR

As far as that goes, have an extra one laying around if anyone needs it. lol.

Wish I would've known about bleeding it first, got talked into buying one from a mitsu "guru" guy I know, cause of a similar problem... Shoulda read on here first... -.- oh well!
__________________
06 Evo IX
04 Evo VIII
05 F350 Diesel Puller.
Offline
 
Reply With Quote
Old Nov 3, 2009, 09:53 PM
EvolutionM
Mitsubishi Lancer




Paid Advertisement
 
 
 
Reply

Tags
2006, 25, accd, acd, code, evo, evolution, issues, ix, lancer, lights, net, problem, problems, stay

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 









All times are GMT -7. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All Passwords