Dome Light Wont Turn on When I open Door. - evolutionm.net
evolutionm.net - Home of the Lancer Evolution
Home Features Community Marketplace Registry Garage Store

Go Back   evolutionm.net > Lancer Forums > Lancer General
Sign in using an external account
Register Forgot Password?
Search


Lancer General Come on in and discuss the US Lancer.

Welcome to EvolutionM.net!
Welcome to EvolutionM.net.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old Apr 4, 2009, 10:26 PM   #1
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Apr 2009
Location: Aurora
Posts: 7

Drives: Mitsubishi Lancer ES 2003

Dome Light Wont Turn on When I open Door.

I have a MIT Lancer ES 03. When I open the door, my dome light wont turn on. I can turn it on myself by moving the switch to ON. But when I leave it in the middle and open the door it won't turn on.

I tried opening all the doors at the same time and one by one and nothing. I checked all fuses everything is ok.

Anyone know what's going on??
Offline
 
Reply With Quote
Old Apr 6, 2009, 04:23 AM   #2
Evolving Member
Personal Sales Rating: (3)
Garage is empty, add now
 
Fuze49's Avatar
 
Join Date: Aug 2007
Location: Las Vegas
Posts: 317

Drives: 06 OZ Rally

Check the wiring in the light itself to the door open switch. The light should screw out or pop out. I haven't looked in our cars yet but I've done it on a friends and the connection had gone bad.
__________________
Mods:
RRM Front Strut
RRM Rear Strut
OBX Header
OBX Test Pipe
Custom Catback Exhaust
K&N SRI
Tinted Tails
Perrin Shorty Antenna
Painted Gloss Black Stock Rims
Rexpeed Type C Carbon Fiber Trunk Lip
JDM Halo Projector Head Lights
Offline
 
Reply With Quote
Old Apr 7, 2009, 03:34 AM   #3
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Apr 2009
Location: Aurora
Posts: 7

Drives: Mitsubishi Lancer ES 2003

Quote:
Originally Posted by Fuze49 View Post
Check the wiring in the light itself to the door open switch. The light should screw out or pop out. I haven't looked in our cars yet but I've done it on a friends and the connection had gone bad.
Yeah I probably broke it when I was puttting more LED'S on the car. But It's weird how it only works when I turn it on. And not when I leave in the middle. IDK it's going to be hard to know what's wrong.

But I'll have a look at the wires. Thanks!
Offline
 
Reply With Quote
Old Apr 7, 2009, 03:48 PM   #4
Evolving Member
Personal Sales Rating: (3)
Garage is empty, add now
 
Fuze49's Avatar
 
Join Date: Aug 2007
Location: Las Vegas
Posts: 317

Drives: 06 OZ Rally

I had a similar issue with my headlights. Every light worked except the bright and the running light on my new JDM's but turned out it was just a bad connection.
__________________
Mods:
RRM Front Strut
RRM Rear Strut
OBX Header
OBX Test Pipe
Custom Catback Exhaust
K&N SRI
Tinted Tails
Perrin Shorty Antenna
Painted Gloss Black Stock Rims
Rexpeed Type C Carbon Fiber Trunk Lip
JDM Halo Projector Head Lights
Offline
 
Reply With Quote
Old Apr 8, 2009, 01:07 AM   #5
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Apr 2009
Location: Aurora
Posts: 7

Drives: Mitsubishi Lancer ES 2003

Quote:
Originally Posted by Fuze49 View Post
I had a similar issue with my headlights. Every light worked except the bright and the running light on my new JDM's but turned out it was just a bad connection.
Ah i see! Well hopefully I get it figured out! It's the only thing wrong with the car!

I'm just glad it's not an engine failure! Because I can live without the Dome light.
Offline
 
Reply With Quote
Old Apr 8, 2009, 01:22 PM   #6
Newbie
Personal Sales Rating: (2)
Garage is empty, add now
 
nicdeloach's Avatar
 
Join Date: Feb 2009
Location: with urmom
Posts: 34

Drives: 2002 lancer oz rally

Send a message via MSN to nicdeloach
mine too that metal piece on it is flimsy but check the ground screw that holds it up there...make sure its making solid and clean contact on that part of the unit and roof.
also check ur doors pin switches in the door jam.
i'll up a pic of the piece when wifey gets home.
__________________
[x] RRM PULLEY & SS Piggyback v.2
[X] K&N FIPK SRI
[X] Magnaflow CAT
[X] Custom Dynomax Catback
[X] Progress Springs & Rear Anti Sway Bar
[X] KYB GR2 Struts And Shocks
[X] Light-Glow L.E.D. Color Change Underbody
[X] Premium Video/Audio/NAV
[X] Blacked Windows...due to medical condition :P
[X] Hello Kitty Exhaust Tip..Hello Kitty Everywhere!
[ ] RRM Stage 1 Turbo Kit W/ Intercooler
[ ] Magniflow/Greedy Catback
[ ] EVO Style Hood
[ ] Projector Head Light, OE Fog, H.I.D. Dual

Last edited by nicdeloach; Apr 8, 2009 at 01:24 PM.
Offline
 
Reply With Quote
Old Apr 8, 2009, 01:22 PM
EvolutionM
Mitsubishi Lancer




Paid Advertisement
 
 
 
Reply


Tags
07, car, cars, dome, door, doors, lancer, light, lights, mitsubishi, open, opened, switch, turn, turned, turns, wont, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 









All times are GMT -7. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All Passwords