CrAnSwIcK's 4G69 Build: Phase 2 - Page 33 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



04-06 Ralliart Aftermarket Forced Induction Tech (aftermarket turbo/supercharger related topics)

CrAnSwIcK's 4G69 Build: Phase 2

Reply
 
 
 
Thread Tools Search this Thread
Old Mar 29, 2016, 08:28 AM   #481
Evolved Member
iTrader: (1)
 
RalliartN's Avatar
 
Join Date: Mar 2007
Location: Ontario
Posts: 975
Thanks: 0
Thanked 9 Times in 8 Posts

Drives: Lancer Ralliart '06; Mitsu RVR '11

Thats way more room than I've got. Now you guys do the right thing and build your pits using the plans I posted previously
Offline
 
Reply With Quote
Old Mar 29, 2016, 12:43 PM   #482
Evolved Member
Thread Starter
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,376
Thanks: 0
Thanked 72 Times in 71 Posts

Drives: 2006 Lancer Ralliart, 2008 Mazda 5 GT

I think mine had a pit, but it's all gilled in with sand, wasn't very big is it was one...
Offline
 
Reply With Quote
Old Jun 21, 2016, 02:24 AM   #483
Evolved Member
Thread Starter
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,376
Thanks: 0
Thanked 72 Times in 71 Posts

Drives: 2006 Lancer Ralliart, 2008 Mazda 5 GT

well, well, well....

So after about 8 months of running wastegate pressure with a tune intentionally flooded with fuel as a fail safe, I recently hooked up a new wideband harness so I could start over tuning the car, and bringing the boost back up, and I may have found out why my motor exploded...When the motor blew, my wideband was not working, but the tune was solid, and I continued to run it with water/alcohol injection...since installing the new motor, I have been running wastegate pressure ~7psi, and with no alcohol injection.

So, yesterday, I filled up my reservoir with a 50/50 mix of methyl hydrate and deionized water, and made a startling discovery. My meth pump doesn't work...I tripped the pressure switch, and nothing happens...so it stands to reason, that the pump failed while running 18psi of boost on pump gas causing catastrophic detonation of the number 4 cylinder...more to follow as I investigate why the pump won't kick on.
Offline
 
Reply With Quote
Old Jun 21, 2016, 07:00 AM   #484
Evolved Member
iTrader: (5)
 
bakuro117's Avatar
 
Join Date: May 2011
Location: Cynthiana, KY
Posts: 1,762
Thanked 19 Times in 19 Posts

Drives: on curvy roads

bad switch you think? or bad pump?

glad to see your turning the boost back up though. You gunna go for 18 again or find a safe balance somewhere?
Offline
 
Reply With Quote
Old Jun 21, 2016, 03:24 PM   #485
Evolved Member
Thread Starter
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,376
Thanks: 0
Thanked 72 Times in 71 Posts

Drives: 2006 Lancer Ralliart, 2008 Mazda 5 GT

Time will tell...I'll probably bring it back up around 14psi and enjoy it until I make the switch to an Evo...now that Evo 7's are being imported into Canada, I'll probably pick one up when the Mazda's paid off and swap it in a rolling Evo 8 chassis...the LHD RS2 is far too rare to be cost effective...swapping and registering a usdm vin will cost much less.
Offline
 
Reply With Quote
Old Sep 27, 2017, 02:56 PM   #486
Evolved Member
iTrader: (5)
 
bakuro117's Avatar
 
Join Date: May 2011
Location: Cynthiana, KY
Posts: 1,762
Thanked 19 Times in 19 Posts

Drives: on curvy roads

I just sifted through this thread again. So much good info here. Makes me wish I wouldve finished turbo'ing my RA. Im still kicking myself for selling that thing... Just makes it worse having to see it around town still and it getting riced out... :/
Offline
 
Reply With Quote
Old Sep 29, 2017, 01:36 PM   #487
Evolved Member
iTrader: (1)
 
rzrxn's Avatar
 
Join Date: Mar 2012
Location: Toronto, Ontario
Posts: 600
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2004 Lancer Ralliart

Quote:
Originally Posted by bakuro117 View Post
I just sifted through this thread again. So much good info here. Makes me wish I wouldve finished turbo'ing my RA. Im still kicking myself for selling that thing... Just makes it worse having to see it around town still and it getting riced out... :/
LOL! funny how i literally just finished reading through the whole thread again too haha! cheers man! mine has been dead for more than a year but i still have it sitting on my driveway. reading through our adventures here together, im so motivated to get back at it and revive my RA!!!
Offline
 
Reply With Quote
Old Sep 30, 2017, 09:42 PM   #488
Evolved Member
Thread Starter
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,376
Thanks: 0
Thanked 72 Times in 71 Posts

Drives: 2006 Lancer Ralliart, 2008 Mazda 5 GT

thanks for the bump guys, I actually just noticed that photobucket canned all my images...I looked into it, and they want $400 annually for 3rd party hosting...that just made a lot of my posts pointless, lol
Offline
 
Reply With Quote
Old Oct 2, 2017, 06:40 AM   #489
Evolved Member
iTrader: (5)
 
bakuro117's Avatar
 
Join Date: May 2011
Location: Cynthiana, KY
Posts: 1,762
Thanked 19 Times in 19 Posts

Drives: on curvy roads

Yea... Photobucket is off their rocker. I need to find a new image hosting site, or just start uploading pics to forums I guess. But there are plugins for Firefox and Chrome that let them work again. That's what I've been using.
Here is the Chrome fix

So any news on the car? You done anything to it lately?
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
"Tramp" - Rzrxn's 2004 Lancer Ralliart rzrxn 04-06 Lancer Ralliart Show & Shine 97 Oct 15, 2017 03:02 AM
CS6A Complete AWD swap | FWD OZ Rally converted to AWD via Outlander/EVO 9 doncarbone Project Cars and Build Threads 106 Aug 22, 2017 12:06 AM
doncarbone's '03 OZ Rally -> '06 Ralliart engine swap doncarbone Project Cars and Build Threads 293 Jul 10, 2017 03:52 AM
AlchEm1st's Evo IV Coupe conversion project Alchem1st Evo Show & Shine 393 Mar 23, 2017 01:22 AM
FS[SouthEast]: OEM EVO 8 Crank hutch959 For Sale/WTB - Engine / Drivetrain / Power 11 Dec 28, 2015 05:23 PM


Tags
42, 4g69, bar, bearings, bosch, dsm, kit, lsu, map, master, oil, pressure, rebuild, sending, sensor, subaru, unit, wideband

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:57 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: