2004 Lancer Sportback Ralliart AT Build - Page 135 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



04-06 Ralliart Aftermarket Forced Induction Tech (aftermarket turbo/supercharger related topics)

2004 Lancer Sportback Ralliart AT Build

Reply
 
 
 
Thread Tools Search this Thread
Old Apr 10, 2017, 08:02 PM   #2011
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Quote:
Originally Posted by slc-ralliart View Post
Yeah that is really strange. You almost have to assume something was messed up during the install since it didn't happen before the valves were done. I was just saying it is strange for valve float to just start happening out of nowhere.
Or something else was damaged or messed up during the timing belt insult. Meanwhile, my car sits in his yard without having been touched going on the second week.
Offline
 
Reply With Quote
Old May 23, 2017, 06:26 PM   #2012
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

An AEM High Flow In-Tank Fuel Pump was installed with no change in symptoms...

I need my car back...I can't do this any longer, smh.
Offline
 
Reply With Quote
Old May 24, 2017, 06:22 AM   #2013
Evolved Member
iTrader: (5)
 
bakuro117's Avatar
 
Join Date: May 2011
Location: Cynthiana, KY
Posts: 1,750
Thanked 19 Times in 19 Posts

Drives: on curvy roads

Man this sucks... I wish I could come up and help you figure this thing out... :/
Offline
 
Reply With Quote
The Following User Says Thank You to bakuro117 For This Useful Post:
truthdweller (Jun 12, 2017)
Old May 30, 2017, 06:58 PM   #2014
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Quote:
Originally Posted by bakuro117 View Post
Man this sucks... I wish I could come up and help you figure this thing out... :/
Just picked it up from the shop today. Timing belt re-tightened, and AEM fuel pump installed. Nothing has changed...still with loss of power WOT @ 5000 rpm. Can't dump any more money into it like this so put it back in my garage.

Pulled out of the driveway to go fishing and car dies. I'm throwing a P0335 Crankshaft Position Sensor again. Was able to restart it and put it back in the garage. This is a recurring issue so I'm going to replace it once and for all...hope it solves the big picture as well.
Offline
 
Reply With Quote
Old Jun 4, 2017, 02:02 PM   #2015
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart



Picking up the crankshaft sensor tomorrow...towing the car to another shop to have them install it.
Offline
 
Reply With Quote
Old Jun 7, 2017, 08:12 PM   #2016
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Quote:
Originally Posted by truthdweller View Post


Picking up the crankshaft sensor tomorrow...towing the car to another shop to have them install it.
Decided to take the risk of driving it to the shop and made it without incident. Picked up the car today, crankshaft sensor replaced...but no change, "darn it Jim!"...
Offline
 
Reply With Quote
Old Jun 7, 2017, 08:20 PM   #2017
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Something is going on mechanically...again, I'm pushing the dipstick out when I boost. I can't rev past 5500 rpms PERIOD! Whether I'm WOT or not, I can't get past 5500 rpms. It's as if it hits a limiter and won't progress. Wth happened? If I'm WOT, and it hits that "limit", the transmission won't upshift either... UNLESS I back off the throttle a bit, and THEN it'll shift, but I still can't get past 5500 rpms in the next higher gear.
Offline
 
Reply With Quote
Old Jun 8, 2017, 07:24 AM   #2018
Evolved Member
iTrader: (3)
 
RacerX-Ralliart's Avatar
 
Join Date: Nov 2011
Location: San Francisco, CA
Posts: 629
Thanks: 0
Thanked 2 Times in 1 Post

Drives: 04 mitsu lancer RA

Quote:
Originally Posted by truthdweller View Post
Something is going on mechanically...again, I'm pushing the dipstick out when I boost. I can't rev past 5500 rpms PERIOD! Whether I'm WOT or not, I can't get past 5500 rpms. It's as if it hits a limiter and won't progress. Wth happened? If I'm WOT, and it hits that "limit", the transmission won't upshift either... UNLESS I back off the throttle a bit, and THEN it'll shift, but I still can't get past 5500 rpms in the next higher gear.
hey not sure if you've tried it or checked yet but what if your pcv valve is stuck closed thus you're pressurizing the crank case putting stress on the internals? Not sure if it would cause the problem you're having, it sounds like something happened when they rebuilt your head... if you google search cheap cylinder heads there's a company based in Texas that sells rebuilt heads you just have to send them your head as a core. I got my replacement head from them and it looks badass. I've been slowly putting my car back together trying to remember where everything goes after two years. Hope you get this all figured out you're the original sport back AT turbo ralliart a role model for all
Offline
 
Reply With Quote
The Following 2 Users Say Thank You to RacerX-Ralliart For This Useful Post:
Resurrected RA (Jun 8, 2017), truthdweller (Jun 12, 2017)
Old Jun 8, 2017, 08:24 AM   #2019
Evolving Member
 
Resurrected RA's Avatar
 
Join Date: Jul 2010
Location: Pursuance Motor Works - Calgary, Alberta
Posts: 325
Thanked 2 Times in 2 Posts

Drives: 2006 RalliArt Sportback / 2004 RalliArt Sportback "Christine" / 1988 Pontiac Fiero Formula (3.8L SC in the works) "White Lightning"

Quote:
Originally Posted by RacerX-Ralliart View Post
I got my replacement head from them and it looks badass. I've been slowly putting my car back together trying to remember where everything goes after two years.
Same here, it's amazing what I've forgotten in the year and half since my timing belt went and I pulled the head... Somehow, after taking great care to not lose any bolts, I can't find certain bolts...
Offline
 
Reply With Quote
Old Jun 8, 2017, 10:32 AM   #2020
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Quote:
Originally Posted by RacerX-Ralliart View Post
hey not sure if you've tried it or checked yet but what if your pcv valve is stuck closed thus you're pressurizing the crank case putting stress on the internals?

https://www.evolutionm.net/forums/04...l#post11721352
Offline
 
Reply With Quote
Old Jun 9, 2017, 06:53 AM   #2021
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Quote:
Originally Posted by slc-ralliart View Post
Does your car have excessive oil consumption? Also does your crankcase/oil smell like gas? I had excessive blowby in my BMW that would push the dipstick out of the hole.
What was the cause of this blowby?

Last edited by truthdweller; Jun 11, 2017 at 02:18 AM.
Offline
 
Reply With Quote
Old Jun 11, 2017, 02:23 AM   #2022
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Meanwhile, the P0133 O2 Sensor (B1 S1) popped back up. Going to replace this too, since it is reoccurring as well. Maybe this is the cause of my HORRIBLE gas mileage, and rich status when boosting.

Btw, I'm just made of money so, I'm good, no problem...
Offline
 
Reply With Quote
Old Jun 12, 2017, 12:20 PM   #2023
Evolving Member
 
SilentCool's Avatar
 
Join Date: Aug 2013
Location: Brooklyn, NY
Posts: 328
Thanked 10 Times in 9 Posts

Drives: 2003 Mitsubishi Lancer ES

This must be quite frustrating "Truth." Hopefully you make some head way soon and everything works out. As always keep us posted.
Offline
 
Reply With Quote
The Following User Says Thank You to SilentCool For This Useful Post:
truthdweller (Jun 12, 2017)
Old Jun 21, 2017, 07:21 AM   #2024
Evolved Member
iTrader: (2)
 
slc-ralliart's Avatar
 
Join Date: Dec 2006
Location: Centerville, UT
Posts: 638
Thanks: 0
Thanked 3 Times in 3 Posts

Drives: 1999 Miata, 2006 TSX, Kia Minivan

Quote:
Originally Posted by truthdweller View Post
What was the cause of this blowby?


I bored the engine my BMW .90 over from a 1.8 to 2.1 liter. The early BMW's (mine was an 82) did not have strong cylinder walls. My cylinder walls went egg shaped a few thousand miles after the engine rebuild causing excessive blow-by which created a lot of crank case pressure.
Offline
 
Reply With Quote
The Following User Says Thank You to slc-ralliart For This Useful Post:
truthdweller (Jun 21, 2017)
Old Jun 21, 2017, 07:54 PM   #2025
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,708
Thanked 5 Times in 5 Posts

Drives: 2004 Mitsubishi Lancer Sportback TURBO Ralliart

Angel at Technica Motorworks has agreed to reopen my motor and recheck his work. He agrees that something may have been missed / reassembled incorrectly. I'll be bringing it in in about two weeks. Thank God.
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Video of reflashed car. hackish 04-06 Ralliart Aftermarket Forced Induction Tech 28 Mar 7, 2017 09:32 PM
Custom Turbo setup need opinions 06RAJK 04-06 Ralliart Aftermarket Forced Induction Tech 7 Nov 30, 2016 11:02 PM
Hackish ECU Reflash Review Ralliartize It 04-06 Ralliart Engine/Drivetrain 393 Jul 29, 2016 09:29 PM
Any turbo RA's in the Orlando area? hackish 04-06 Ralliart Aftermarket Forced Induction Tech 6 Dec 17, 2009 05:00 PM
How does the HighOctane/LowOctane stuff work? hackish EcuFlash 11 Apr 11, 2009 12:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:44 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: