2004 Lancer Sportback Ralliart AT Build - Page 2 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
04-06 Ralliart Aftermarket Forced Induction Tech (aftermarket turbo/supercharger related topics)

2004 Lancer Sportback Ralliart AT Build

Reply

 
 
 
Old Aug 10, 2012, 08:59 AM
  #16  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
I was able to access my ECU via Hackish's new file, that he sent me, and I just forwarded the info that he requested off of it;



...standing by...
truthdweller is offline  
Reply With Quote
Old Aug 10, 2012, 09:18 AM
  #17  
Evolved Member
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,377
Thanks: 0
Thanked 72 Times in 71 Posts
Originally Posted by truthdweller View Post
omnipowerusa Mitsubishi 3 bar MAP.
I have the same MAP sensor, and it doesn't have a logo on it

Originally Posted by blaire View Post
The digital aem uego wideband might have the analog output that my analog aem wideband did not? I know it sounds stupid but thats just how it went... I didn't look into it before I bought it, just assumed the analog version would have it as well. To me the sweep of a needle is easier to read then flickering digital numbers. Anyways, the analog aem wideband only has serial outputs of lamba readings, but not analog output as can be proven by the following:

http://www.aemelectronics.com/Images...%2030-5130.pdf

and in this thread:
https://www.evolutionm.net/forums/ec...0-evoscan.html
I'm not sure, mine is an older one, it has a serial output, not sure if it's digital or analog...i would assume digital
CrAnSwIcK is offline  
Reply With Quote
Old Aug 10, 2012, 09:26 AM
  #18  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
Originally Posted by CrAnSwIcK View Post
I have the same MAP sensor, and it doesn't have a logo on it

That means mine is better than yours

Last edited by truthdweller; Aug 11, 2012 at 10:58 PM.
truthdweller is offline  
Reply With Quote
Old Aug 11, 2012, 02:49 PM
  #19  
Newbie
 
Join Date: May 2012
Location: washington
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by truthdweller View Post
omnipowerusa Mitsubishi 3 bar MAP.
Thanks for the info!!!
ShadowRalli is offline  
Reply With Quote
Old Aug 13, 2012, 08:26 PM
  #20  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
These arrived today from Turbokits...


Last edited by truthdweller; Aug 14, 2012 at 03:18 PM.
truthdweller is offline  
Reply With Quote
Old Aug 13, 2012, 08:28 PM
  #21  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
Originally Posted by truthdweller View Post
I was able to access my ECU via Hackish's new file, that he sent me, and I just forwarded the info that he requested off of it;



...standing by...


But, there's a problem Houston, continuing to standby...
truthdweller is offline  
Reply With Quote
Old Aug 14, 2012, 01:03 PM
  #22  
EvoM Super Moderator
iTrader: (15)
 
Join Date: Apr 2006
Location: South USA
Posts: 3,346
Thanks: 0
Thanked 1 Time in 1 Post
Good to hear about the injectors , but what's the hiccup?
lanzerralliart is offline  
Reply With Quote
Old Aug 14, 2012, 02:09 PM
  #23  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
My ROM file is in Hackish's hands now so he can build it to my car's current (NA) and future (Turbo) mods...finally. It was a bit of "operator error" on both our parts but worth mentioning is my forgetting to use the Reflash Connector tethered to the Open Port connector. A bit silly you might say, just don't forget like I did. The reflash connector plugs in to the back of the Open Port connector, and they both get plugged in, side-by-side, under the dash.

Reflash Connector:


Open Port Connector:

Last edited by truthdweller; Aug 14, 2012 at 02:14 PM.
truthdweller is offline  
Reply With Quote
Old Aug 14, 2012, 03:06 PM
  #24  
Evolved Member
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,377
Thanks: 0
Thanked 72 Times in 71 Posts
lol, yeah, you can't write without the reflash wire...

funny story, when hackish was writing turbo ROMs for me over skype we couldn't figure out why it was idling so lean, but AFR was perfect while driving...turns out i forgot to plug the O2 bung in the O2 housing, so basically it was a massive exhaust leak, obviously it would read lean with atmosphere just around the corner from the stock O2 sensor...lol, i'm sure hackish buried his face in his palms when we figured it out...funny thing it wasn't any louder than when i was NA...the turbo actually made the car more quiet...

i think i posted this story somewhere, but it goes to show, little things get missed and and it makes it hard for the tuner to sort it out if he's not actually there...
CrAnSwIcK is offline  
Reply With Quote
Old Aug 14, 2012, 03:12 PM
  #25  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
I just (last night) watched your Youtube video and you say the same thing about it being quieter after the turbo...too funny.




Note: Look up to the "Injector" photo, post #20, and tell me what's wrong with this picture...

Last edited by truthdweller; Aug 14, 2012 at 03:18 PM.
truthdweller is offline  
Reply With Quote
Old Aug 14, 2012, 03:31 PM
  #26  
Evolved Member
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,377
Thanks: 0
Thanked 72 Times in 71 Posts
Originally Posted by truthdweller View Post
I just (last night) watched your Youtube video and you say the same thing about it being quieter after the turbo...too funny.

Note: Look up to the "Injector" photo, post #20, and tell me what's wrong with this picture...
one has an o-ring on the harness connector, and the others don't...other than that i see nothing wrong lol..

but Gary, could you measure those injectors with a digital caliper if possible? I posted pictures of the measurments for stock 4g69, 4g94 and subaru EJ20 injectors, and those ones from turbo kits look exactly like the subaru injectors, and i would be interested in the spacers, as i'm still using ghetto rubber spacers...
CrAnSwIcK is offline  
Reply With Quote
Old Aug 14, 2012, 04:08 PM
  #27  
Evolved Member
iTrader: (1)
 
Join Date: Mar 2007
Location: Ottawa
Posts: 1,031
Thanks: 0
Thanked 3 Times in 3 Posts
Yeah it does sound good and yes we can hear the blow off valve.
2006_RA is offline  
Reply With Quote
Old Aug 14, 2012, 10:41 PM
  #28  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
I emailed Turbokits regarding the harness connector seals:

"Hmmm, weird, I’ll contact my supplier and see what they say… Thanks"

I can't do anything until I get the reflash from Hackish, so, back to the "hurry up and wait" status.



I'll get those measurements for you Crans ASAP.

Last edited by truthdweller; Aug 14, 2012 at 10:47 PM.
truthdweller is offline  
Reply With Quote
Old Aug 15, 2012, 10:48 AM
  #29  
Evolved Member
Thread Starter
iTrader: (1)
 
truthdweller's Avatar
 
Join Date: May 2011
Location: So. Jersey (San Diego native)
Posts: 1,724
Thanked 5 Times in 5 Posts
Response from Turbokits:

"They are dust shields, not a big issue, they should definitely be there, but will slip right on into place. They are going out in the mail today / tomorrow, you’ll have them in a few days. Thanks"
truthdweller is offline  
Reply With Quote
Old Aug 15, 2012, 04:03 PM
  #30  
Evolved Member
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,377
Thanks: 0
Thanked 72 Times in 71 Posts
yeah, i don't even think mine have those...not a big deal, but if they're supposed to be there, why not get what you paid for, regardless of significance

now for the measurements
CrAnSwIcK is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: 2004 Lancer Sportback Ralliart AT Build


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.