***Welcome New Ralliart Owners*** - Page 23 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



09+ Lancer Ralliart General Discuss any generalized technical factory turbocharged Ralliart related topics that may not fit into the other forums.

***Welcome New Ralliart Owners***

Reply
 
 
 
Thread Tools Search this Thread
Old Sep 19, 2016, 06:28 AM   #331
Newbie
 
Join Date: Sep 2016
Location: Wroclaw
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Lancer Ralliart '09

Hello guys, one month ago I bought a stock white '09 Lancer Ralliart here in Poland where I actually work.
I'm very happy with it also if it has something that need to be fixed (like some yellow lights -ABS ASC- that sometimes turns on).
I'll bring it to the dealer very soon but thanks to your forum I read a lot about that
Offline
 
Reply With Quote
Old Oct 21, 2016, 09:27 PM   #332
Newbie
 
Videodrome's Avatar
 
Join Date: Oct 2016
Location: Canada
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2009 Lancer Ralliart Sportbac

Hi guys and gals.
I just bought a 09 Ralliart Sportbac off a friend. His wife wanted a new vehicle for their two kids and the sportbac wasn't in the picture. hahaha! I bought the car. It's black has around 170Kms
Its bone stock which is fine because I don't think I'll mod it. I'm super happy with the car. It's sick! From Canada.

I've been a bike freak for years. I have a 2013 S1000RR in the garage and thinking of buying an RSV4RR or 1299S.

I have other accounts in different forums so I know how to use the search button. Just saying hi!
Cheers,
VD
Offline
 
Reply With Quote
Old Oct 29, 2016, 06:18 PM   #333
Newbie
 
Join Date: Aug 2015
Location: Los Angeles
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2004 Mitsubishi Lancer Ralliart

Sup everyone. I'm kind of new to this great forum. I currently have a 2004 lancer ralliart 2.4. I bought it almost a year ago. I haven't really done much to it for the reason that I'm trying to get it up and running like it use to.

A couple months ago my brother crashed my car, everyone was fine, but he decided to put it back together. Unfortunately he didn't fix it right and problems started arrising. I am hoping that I can get some great insight and tips to get my car up and running soon.. In the future I really do want to turbo it and add all the gadgets but first things first is to get it running.

As of right now I'm looking for any threads or anyone who can help with my front axle. A week ago I was driving it and my axle gave out. When I lifted the car the bolts holding into place were missing and one of them broke the housing were it bolted into. Any help, questions, or advise as to what I should check on or do would help.



Last edited by esanabria32; Feb 8, 2017 at 07:08 PM.
Offline
 
Reply With Quote
Old Dec 7, 2016, 04:34 PM   #334
Newbie
 
Join Date: Dec 2016
Location: CALIFORNIA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Need help

Basically im still new.. so i own a 2013 ralliart.. and install a aem cold air intake.. ever since i installed it..it was great it was never been tuned.. but lately my service engine light has been showing lately especially when its cold..
Offline
 
Reply With Quote
Old Dec 7, 2016, 06:58 PM   #335
Evolved Member
 
Join Date: Sep 2009
Location: Baltimore, MD
Posts: 1,247
Thanks: 0
Thanked 1 Time in 1 Post

Drives: 2009 Ralliart

Quote:
Originally Posted by johnralliart View Post
Basically im still new.. so i own a 2013 ralliart.. and install a aem cold air intake.. ever since i installed it..it was great it was never been tuned.. but lately my service engine light has been showing lately especially when its cold..
Sooooo, get the code read and go from there.
Offline
 
Reply With Quote
Old Dec 8, 2016, 03:13 AM   #336
Newbie
iTrader: (1)
 
Join Date: Dec 2013
Location: Delaware
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2011 Lancer Ralliart

Quote:
Originally Posted by johnralliart View Post
Basically im still new.. so i own a 2013 ralliart.. and install a aem cold air intake.. ever since i installed it..it was great it was never been tuned.. but lately my service engine light has been showing lately especially when its cold..
Never, ever, ever, ever, ever install a mod without doing your damn research! Check the code, put the stock intake back on, and wait til you can get a tune with either the GST basemaps or a pro tune.
Offline
 
Reply With Quote
Old Jan 24, 2017, 10:32 AM   #337
Newbie
 
Join Date: Jan 2017
Location: Huntsville, AL
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2010 Lancer Raliiart

just purchased a 2010 Lancer Ralliart Sportback in Tarmac Black completely bone stock!
I have not figured out what i am going to do with it as of now
Offline
 
Reply With Quote
Old Jan 25, 2017, 09:02 PM   #338
Newbie
 
Join Date: Jan 2017
Location: Northridge, CA
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2002 Mitsubishi lancer

Hello i was wondering who can help me out. Ive had 02 lancer oz rally for about a year now and my timing belt wripped so i was wondering what I can do. Some people tell me i need to check the valve pressure others tell my i need a refurbishing kit or change my engine.. so i ask what do i do
Offline
 
Reply With Quote
Old May 12, 2017, 07:03 PM   #339
Newbie
 
Join Date: May 2017
Location: Laval
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi Lancer Ralliart 2014

Hey guys just bought myself a RA 2014 today very happy with it, can't wait to play around with it.
Offline
 
Reply With Quote
Old May 19, 2017, 07:56 AM   #340
Newbie
 
amanwithalancer's Avatar
 
Join Date: May 2017
Location: Kent, OH
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2011 Lancer Ralliart

Hey everyone! I'm new to the forum. I have an '11 RA that's mostly only customized on the exterior. I also have s sport, UR exhaust, Evo X DV, and soon will install the X Intercooler. Can't wait to be apart of the forum!
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New WW IX MR kyoo Project Cars and Build Threads 537 May 12, 2017 11:31 PM
How To Install FUSE into a Non FUSE lancer beetle_orange Evo X How Tos / Installations 45 May 9, 2017 08:30 AM
Rally Innovations RA Sportback Diffuser - Who wants one ever12 09+ Lancer Ralliart General 59 Sep 15, 2016 08:17 AM
Warning Light "Service Required" connos Lancer General 1 Jun 1, 2016 10:44 AM
Long Time Canuck Lurker ... 09 Rotor Glow RA pounder 09+ Ralliart Show and Shine 25 Apr 12, 2011 01:41 PM


Tags
2010, 2011, baby, backup, camera, car, dyno, fit, headlights, lancer, owners, ralliart, seats, uneven, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 02:04 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send