Ralliart transmission help? - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices

Ralliart transmission help?

Old Feb 9, 2018, 10:11 AM
  #1  
Newbie
Thread Starter
 
chrisrojas10's Avatar
 
Join Date: Feb 2018
Location: New Brunswick
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Ralliart transmission help?

I am new to this community but I am very excited about my new car and joining the mitsubishi scene and community
The evo has always been my dream car, and a couple days ago i had the chance pick up a 2010 lancer ralliart (not an evo but I'm very happy with my car). The car is used and has 116000 miles, and the carfax was clean. After about 2 days of driving the car I got a "engine system service required" alert. The owners manual says the timing belt may be worn, but the mechanic said the timing belt was recently changed and in good shape. I took it to a mitsubishi dealer to have it diagnosed by the service team and they told me that the entire transmission must be replaced. The light went away after the diagnostic but sure enough a day later here I am with the light back. I find it odd because the car runs fine. I do notice a burning smell from the car, but this is my first "high" horsepower and turbocharged car (i drove a NA veloster before, which did have a bad transmission so I have experience on what a dying transmission feels like). Ive been reading that the SST fluid could be old and should be flushed and replaced, and this is what I'm going to do but hopefully someone here can give me some suggestions??

Also, i forgot but one time the car did not want to go in reverse or forward, and i got a light saying transmission was overheating, weird because the car was parked before.

Last edited by chrisrojas10; Feb 9, 2018 at 10:13 AM. Reason: Wanted to add transmission on title because this is what I'm asking about
chrisrojas10 is offline  
Old Feb 9, 2018, 12:22 PM
  #2  
Evolving Member
iTrader: (19)
 
DontStopMe's Avatar
 
Join Date: Apr 2008
Location: Wisconsin
Posts: 482
Thanked 61 Times in 38 Posts
Welcome!

Sorry to hear about your issues. Unfortunately i'm willing to bet this car is not going to be too kind to you.

First, the Ralliart had a 4b11 engine with a timing chain, not a timing belt like the evo8 & evo 9's(4G63) has. The timing chain on earlier evo's have been known to stretch.

The SST transmissions on the ralliarts are most expense part of the car and the fluid needs to be changed every 20k miles or so. Did the previous owner have any maintenance records? You can try swapping the fluid and hope that helps, but i'm willing to be the previous owner may have done that very recently(any only recently) to dump it off and sell it.

Good luck
DontStopMe is offline  
Old Feb 9, 2018, 03:25 PM
  #3  
EvoM Super Moderator
iTrader: (3)
 
MinusPrevious's Avatar
 
Join Date: May 2008
Location: So.Cal
Posts: 5,055
Thanked 635 Times in 608 Posts
Yes, welcome aboard as well

Listen to Pauls advice. He's been around the block & one of our EvO Gurus

If you have continued questions, let us know

Joe,
MinusPrevious is offline  
Old Sep 13, 2018, 03:13 PM
  #4  
Newbie
 
Join Date: Sep 2018
Location: North Carolina
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hey guys. I am having the same issue with the service engine service required light. Is it the Timing Chain?I changed the transmission fluid recently but it kinds feels like it chunks sometimes when coming to a stop. mine is a 2011 Ralliart Sportback
MrJake4933 is offline  
Old Sep 13, 2018, 09:49 PM
  #5  
Newbie
Thread Starter
 
chrisrojas10's Avatar
 
Join Date: Feb 2018
Location: New Brunswick
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I ended up changing the timing chain, transmission fluid, engine oil and the lights have gone away. The car hasn't given me a single problem since. You should also check the oil pump.
chrisrojas10 is offline  
Old Sep 14, 2018, 10:00 AM
  #6  
Evolving Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Overland Park, KS / Tampa, FL
Posts: 280
Thanked 0 Times in 0 Posts
Good to hear your issues were resolved. Enjoy your ralliart 👍🏻
hixlancer is offline  
Old Sep 14, 2018, 10:00 AM
  #7  
Evolving Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Overland Park, KS / Tampa, FL
Posts: 280
Thanked 0 Times in 0 Posts
Mr Jake can you read the code and see what it says?
hixlancer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
seankhan
Evo How To Requests / Questions / Tips
48
Apr 25, 2017 03:16 AM
eburhans
Lancer Tranny/Drivetrain Tech
14
Aug 28, 2011 04:35 PM
SSP Jeremy
EvoX 'For Sale' Engine Internals and Drivetrain
24
Feb 19, 2011 08:26 AM
Pro
Evo General
47
Sep 18, 2007 03:15 PM
be12nard
Evo Engine / Turbo / Drivetrain
2
Mar 11, 2005 10:15 PM


Thread Tools
Search this Thread
Quick Reply: Ralliart transmission help?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.