HOW TO DISASSEMBLE &
REASSEMBLE EVO ECU CODE

Introduction

This is a summary of the steps and tools required to disassemble, reassemble, link, trim and
re-flash Evo code into your ROM. It was pulled together from many threads on the

site, to make it easier to figure out how to do this for anyone who
wants to get into coding their own mods to the Mitsubishi ECUs. It is an open work in
progress, so feel free to make any corrections or additions as needed.

ECU Disassembly

This section explains how to disassemble an Evo ROM binary file, downloaded from your ECU
using EcuFlash, into a GNU assembly text file using a Windows PC. It assumes you know how
to dump your ROM to a hex file using ECUFlash.

1. Get a copy of IDA Pro 6.1 and the IDA Pro Book 2" edition from the internetz.
Spend many days reading about how to install and use this powerful disassembly
tool.

2. Download a copy of the Hitachi Renesas SH-2 Software Manual to get familiar with
the assembly language used in the Evo ROMs.

3. Download a copy of the Hitachi Renesas SH7052F-Hardware Manual to get familiar
with the Evo 8 ECU.

4. Download a copy of the Hitachi Renesas SH7055SF-Hardware Manual for the Evo 9
ECU.

5. Open IDA Pro 6.1 and click Go! (Work on your own).
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W IDA: Quick start

New Disassemble a new file

Go Work on your own

Previous Load the old disassembly

C:\Users\Carl\Downloads\9653E706.hex -
C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653
C:\Users\Carl\Downloads\9653£706.0
C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653
C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653
C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653
C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653 ~

‘| | »
M Display at startup

6. Use File > Open to select the ROM hex file you want to disassemble.

7. The Load a new file window will appear:

W Load 2 newfile x ‘

Load file C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653E706-20171216-0830.bin as

—

Processor type
|Intel 80x86 processors: metapc = Set
Loading segment [0x00000000 :
¥ Enabled
Loading offset [0x00000000 ¥ Indicator enabled
Options
¥ Create segments Kernel options 1 ‘
[ Load as code segment
P- Rename DLL entries
™ Manual load Kermel options 2 |
F Fill sagment gaps
I_ Loading options Processor options |
[T Create FLAT group
DLL directory |C:\WINDOWS
0K I Cancal | Help |

Change the processor type in the drop down list from "Intel 80x86 processors: metapc”
to "Renesas: SH4B" and press the Set button.
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8. Click the Kernel Options 1 button.

' Kernel analysis options 1 X |

¥ Create offsets and segments using fixup info
¥ Mark typical code sequences as code

" Delete instructions with no xrefs

V" Trace execution flow

¥ Create functions if call is present

V" Analyse and create all xrefs

¥ use flirt signatures

[~ Create function if data xref data->code32 exists
¥ Rename jump functions as | ...

¥ Rename empty functions as nullsub_...

V' Create stack variables

V" Trace stack pointer

[~ Create ascii string if data xref exists

[™ Convert 32bit instruction operand to offset
[V Create offset if data xref to seg32 exists
V" Make final analysis pass

oK Cancel Help

Uncheck the “Create ascii string if data xref exisits” and “Convert 32 bit instruction
operand to offset” options and then click OK.
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9. Click the Kernel Options 2 button:

* Kernel analysis options 2 x ‘

¥ Locate and create jump tables

[ Coagulate data segments in the final pass
¥ Automatically hide library functions

¥ Propagate stack argument information

¥ Propagate register argument information
[ Check for unicode strings

¥ Comment anonymous library functions

¥ Multiple copy library function recognition
¥ Create function tails

M Automatically convert data to offsets

[ Perform 'no-return’ analysis

[~ Perform full stack pointer analysis

¥ Coagulate code segments in the final pass
¥ Truncate functions upon code deletion

[~ control flow to data segment is ignored

OK Cancel Help

Uncheck the “Check for unicode strings” option and hit OK.

10. Click the Processor Options button.

, SuperH specific analyzer options et ‘

[ Convert immediate loads |

Choose a device

oK Cancel | Help

Remove the check mark from “Convert immediate loads” and hit OK, then OK again.
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11. A new window will appear called "Disassembly memory organization”.

* Disassembly memaory organization x ‘
FLAM

[ Create RAM section |

RAM start address | 0x0 -
RAM size | e =l
ROM

" create ROM section

ROM start address | 0x0 -
ROM size | ;20000 |
Input fila

Loading address | 0x0

Rl
File offset | ox0 -]
Loading size | 0x40000 |

the

Additional binary files can be loaded into the database using
“File, Load file, Addtional binary file" command.

oK Cancel

Check the "Create RAM section”.
Change the RAM start address to OxFFFFO000
Set RAM size to OxFFFF and press OK.

12. Another window will appear (Choose the device name):

O Choose the device name - O

Name Parameters

Line 1 of 1

Check the Renesas SH7058 (SH4B) processor is selected and press OK to continue.



HOW TO DISASSEMBLE & REASSEMBLE EVO ECU CODE

13. The disassembled hex file will be shown on your IDA pro window:

‘ IDA - C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653E706-20171216-0830.bin o a X
File Edit Jump Search View Options Windows Help
B e~ [Bmms B3 |||ttt 2 X > @O Jl@rvEEEldbae sw

IE — E]

[ Functionswindow & x [ DaviewA B | B Hexviewa © | B seucres @ | F ewms 0 | & mpns 0 | @ epots [ |

Functionname 0000000 ; EI

; * )

0000000 ; | This file has been generated by The Interactive Disassembler (IDA) |

0000000 ; | Copyright (c) 2011 Hex-Rays, <support@hex-rays.com> |
e i License info: B3-432E-FS558-21 |

0000000 ; | I1fak Guilfanou |

e I e R e R *

0000000 ;

0000000 ; Input MDS : BA3SFEICFSBY4T25T3ES11A9CHEEBEAA2

0000000 ; Input CRC32 : AGFB2E3A

10000060

0000E00 ; File Name : C:\Users\Carl\Documents\EuvoScan u2.9\ROMS\9653E706-20171216-0830.bin

0000000 ; Format : Binary file

0000000 ; Base Address: 0000h Range: 0000h - 40000h Loaded length: 40000h

0000000

0000000 ; Processor : SH4B
; Target bler: SHASM Assembler

0000000 ; Byte sex : Big endian

0000000

000000 ; ===s=zszzzzszzzsszzssIISIIIIIIIIIIISIIISISSISIISISISSISsssssssssssssssssaas

0000000

0000000 ; Segment type: Pure code
.section ROM, CODE

* leeeo0ee .data.b 2]
* [eeoe001 .data.b 2]
* leee0002 .data.b h'9C ; £
* [oeoe003 .data.b h'SC ; \
‘ i3 f : ROM: -
L .
=] Output window & x
Executing function ‘main’... :,
Compiling file 'C:\Apps\IDA PRO 6l\idc\onload.idc’...
Executing function 'Onload'...
IDA is analysing the input file...
You may start to explore the input file right now.
<Default>: incompatible saved desktop has been ignored
Can not set debug privilege: Not all privileges or groups referenced are assigned to the caller.
Can not set debug privilege: Not all privileges or groups referenced are assigned to the caller.
Python 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)]
IDAPython v1.5.0 final (serial 0) (c) The IDABython Team <idapython@googlegroups.com>
The initial autcanalysis has been ﬂnuhed.| -

Python |
AU:  idle [Down [Disk: 149GB

A

14. Use keyboard shortcut "G" to jump to the beginning of the code.
Press "G", insert 0000 and press OK.

***Now you are at the beginning of the code***
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15. Press keyboard "D" 3 times and that reference will transform into another number

D IDA - C\Users\Carl\Documents\EvoScan v2. 9\ ROMS\9653E706-201 71216-0830.bin - O X |
Edit Jump Search View Options Windows Help
= WA VL E AL R Y- 2

(7] Functions vandow 2Xx [ DAVewsa O | B HeaviewAs O | B soucwes £ | B Eums O | @ mpots O | @  Bgos O |
Function name [eaceeen il
0008060 ; |  This file has been generated by The Interactive Disassembler (IDA) 1
0000080 ; | Copyright (c) 2611 Hex-Rays, <support@hex-rays.com> 1
0000000 ; | License info: B3-432E-F558-21 1
0000000 ; | Ilfak Guilfanou 1
0000000 ;
0000000 ; Input MDS  : GA3SFEICFSB4T25TIES11AICHECBEAR2
0008060 ; Input CRC32 : AGFB2E3A
0006000
0000000 ; File Name : C:\Users\Carl\Documents\EuoScan u2.9\ROMS\9653E706-20171216-0830.bin
0000000 ; Format : Binary file
0000060 ; Base Address: ©00Bh Range: 0808h - 400Bh Loaded length: 48806h
0000000
; Pr or SHUB
0000000 ; Target assembler: SHASM Assembler
0008000 ; Byte sex : Big endian
0000000
0000000 ; =
0000000
0008000 ; Segment type: Pure code
0000000 .section ROM, CODE
* leooeaoo .data.l unk_8cSC
* leoeooy .data.b h'FF
* le0e00s .data.b h'FF
* 0060006 .data.b h'AB ; X
* 0000007 .data.b  ©
* leoepoos .data.b @
e .data.b 0O
* leoenoon .data.b h'3C ; £
* 0000008 .data.b h'SC ; \
* leoepoec .data.b h'FF
* |008006D .data.b h'FF
* |006000E .data.b h'AB ; X
* |le0e000F .data.b  ©
Ll 2 [00000000 [00000000: RoM: 00000000
4

'E] Output window
Tunccion 'main’...
Compiling file 'Ci\Apps\IDA FRO él\idc\enlosd.idc’...

Python |
|av:  idle [Down bisk: 145GB

S LIL_: HL

16. Double-click on the “unk_XXXX” reference to jump to the start of the main

routine.
‘ IDA - C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653E706-20171216-0830.bin - a
File Edit Jump Search View Options Windows Help
[ R e[| % S s
L7} imchoes wowiow BN | X | o |
Function name * 10009CS7 f il
* joee9Css
*© |0009Cs9 y
* |0009CSA
* |0009CSB 9
“10009CSC unk _9CSC: N ; DATA XREF: ROM:00000000To
* fooescsD
* |0009CSE =
* |0009CSF
* |0009C60 L
* j0009Ce1
* f009c62 h'20
* joee9Cce3 h*12
* joeo9cey h'E® ; a
* |0009CeS 0
* |0009C66 h'40 ; @
* [0009C67 h'2E ;
* joee9ces h'40 ; @
* joee9Cces h*1E
* |0009C6A h'DO ; -
* j0009CeB L
* joeesceC h'40 ; @
* joee9ceD h'B
* |0009C6E ]
* |0009CEF 9
* jooescte h'A0 ; &
* fooe9c 1 8
© joeesct2 ]
*joee9c?3 9
* |0009C T4 h'FF
* |0009CTS h'FF
* [0009C 76 h'AB ; X%
*joee9c?? ]
Ml clelcETorg:] h'FF
* |0009CT9 h'FF
* |0009CTA h'AB ; %
o | 2 >
»
=] output window & x
I Tunction ‘main’... =
Compiling file 'C:\Apps\IDA PRO é1\idc\onload.idc'... ~
Python |
jAU:  idle [Down Disk: 145GB 4
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17. Now you need to press keyboard "C" and wait. This will convert the code from
binary into assembly. It will change to something like this:

¥ IDA - C:\Users\Carl\Documents\EvoScan v2.9\ROMS\9653E706-20171216-0830.bin -

File Edit Jump Search View Options Windows Help . .
R e~ NS D0t F-#d X /> DO JIFFF B @ s

B ovavewsa B | T Hexviews O | & swucwes © |F  Ewms 0 | @ mpns 0 | @ epons @ |
* |0609CSS .data.b h'FF
° |0009CS6 .data.b h'88 ; &
° |eeO9CST .data.b h'66 ; f
* |0009CS8 .data.b 0
* |0609CS9 .data.b h'79 ; y
° 10009CSA .data.b 0
° |0oO9CSB .data.b h'39 ; 9
RQOLITTIE 3 i iiaimini o oo oo m m m o o o o o o o o o o o o o o o 1 33515 5 5 5 55 . 5 5 1 1 5 1 1 5 0 1
10009CSC
10009C5C loc_9CSC: ; CODE XREF: ROM:00009C8A}j
0009C5C ; DATA XREF: ROM:off_6To
r=*"10009C5C mov.l  #h'FFFFABGO, ri1S
“ 10OOICSE mov.1l  #h'FFFFABARO, ro
“ 10009C60 mov.1 #h'FFFFABRO, r1
“ 10009C62 mov.l ri1, @ro
“ |0009C64 mou #0, ro
“ 10e09Ce6 ldc ro, vbr
“ 0o09Ce8 ldc ro, gbr
“ 10009C6A mov.1 #sub_EE94, ro
* 10009C6C jsr @ro ; sub_EE94
t *|0009C6E nop
y -~ |0009C70 bra loc_9C84
1 " eeesct2 nop
U 3 QBOOBCTR: ;. ormmmmmmmimmmm s e e m e m i m 5 5 0 2 3 5 0 2 9 5 1 9 5 9 9 9 9 3 9 2 1
+ 1 °10009CT4 dword_9CT74: .data.l h'FFFFABOG ; DATA XREF: ROM:loc_9CSCTr
' | °[0009C78 dword_9C78: .data.l h'FFFFABAG ; DATA XREF: ROM:00009CSETr
' 1 *[0009C7C dword_9C7C: .data.l h'FFFFABAG ; DATA XREF: ROM:00009C60Tr
' | *0009C80 off_9C80: .data.l sub_EE94 ; DATA XREF: ROM:00009C6ATr
U 3 QUOOACHH: 3 cmrmmmmnminiins mmmm e o m e m o m m e - o . . 3 . 1 9 2 1 9 9 . 1 9 0 2 1 9 0 1 9 1
1| joeescsy |
1 |0009C8Y4 loc_9C84: ; CODE XREF: ROM:00009C70Tj
1| |0009C8Y ; DATA XREF: ROM:off_20To
1 *°l0009CcsYy mov.1 H#off_FO, ro
“ 10009C86 ldc.1 @ro+, sr
1 " loooscss mou.l  #loc_9CSC, ro
L--7/0009C8A jmp @ro ; loc_9CSC
00005C84 [00005C84: RoM:loc Sce4 -
- | ,

ommand "HMakeCode® failed
Target assembler: SHASM Assembler

lal) x

Python [

AU: idle [Down Disk: 149GB

***This is actually Renesas SHASM assembly code and is no good for the GNU assembler
that we will use later to build the ROM after modification.

18. To fix this, select Options > General, and on the Analysis tab change the Target
assembler to “GNU Assembler” from the drop down list. Click the Reanalyze
program button, then hit OK.

19. Next run logic’s SH7052.idc script to fix the IDA file to a format that can be used to
produce an .ASM file that the KPIT GNU assembler can use.
Get the script from and
save it to your ..\IDA PRO 61\idc folder.


http://dev.logic.net/hg/esm/file/tip/evo/IDA/sh7052.idc

20. Run the script in IDA using File > Script file, to select and run the SH7052.idc script
in the ..\IDA PRO 61\idc folder.

11l Note !!!

The SH7052.idc script creates a RAM segment for an VIII ECU starting at OxFFFF8000
with a size of 0x3000. IX ECUs start at OxFFFF6000 with a size of 0x8000. It also
creates a third segment for the hardware registers, at OxFFFFE400 with a length of
0x1460. (On the VIII ECU, it's FFFFE400 through FFFFF85F, while on the IX it's FFFFE400
through FFFFF83F; for simplicity, it defines it as the wider VIl range.) For details on
this segment and what addresses are tied to what registers, see Appendix A of either
the SH7052F manual (for VIII ECUs), or the SH7055S manual (for IX ECUs).

The reason it restricts the definition is because when IDA encounters a longword, it
tries to treat it as a reference to a memory address if it falls within one of the existing
segments. This helps to filter out obviously bogus references to things like
"OxFFFFFFFF" or "OxFFFFO000" as there are quite a few instances of the latter used as
bitmasks.

21. Export your ASM text file from IDA using File > Produce file > Create ASM file, and
save it to your favorite project folder.



ECU Assembly

This section describes how to build a ROM binary from a GNU format assembly text file.

1.

Download the pcrel-filter.sh script from
Save it to your project folder.

Download and install the Cygwin 64bit bash shell terminal for Windows using the
instructions at

Download and install the Renesas High-performance Embedded Workshop (HEW) v4
from

This builds the environment needed for assembling and linking Renesas SuperH RISC
programs.

Download the KPIT GNU Toolchain v09.02 installer executable from the

. The name of the installer executable has the form
—GNUSH<version>-ELF.exell, where <version> is toolchain version. For example if
toolchain version is —v0902Il then its installer will have the name —GNUSHv(0902-
ELF.exe

Run the KPIT GNU Toolchain installer and integrate it with HEW. Installation
instructions are in C:\Program Files (x86)\Renesas\Hew\Tools\KPIT
Cummins\GNUSH-ELF\v0902\Doc\ GNUSH_UserManual.pdf

Prepare the ASM text file for the KPIT GNU assembler by running the pcrel_filter.sh
bash script on your assembly text file. This script corrects PC-Relative MOV
instructions to a format that is recognized by the KPIT GNU assembler.

a. Start a Cygwiné4 bash shell by clicking on the Cygwiné64 Terminal option on the
Start menu.


http://dev.logic.net/hg/esm/file/tip/evo/IDA/pcrel_filter.sh
https://cygwin.com/install.html
https://www.renesas.com/en-us/products/software-tools/tools/ide/hew.html
https://gcc-renesas.com/sh/download-legacy-toolchains/
https://gcc-renesas.com/sh/download-legacy-toolchains/

b. Change to the project directory containing your assembly text file and the
pcrel_filter.sh script.
Type cd <drive:/path to project directory> and hit enter.

% cd c:fusers/c ar"'.-"I:h:r.-:r'u'-:n-su:lz.|




c. The line above the $ prompt changes to show the relative path to the project
directory.

B8 /cyqgdrive/c/users/carl/downloads — | >

:/users/carl/downloads

Jovadrive/cfusers carl /downloads

d. At the § prompt, enter “sh pcrel_filter.sh (assembly_file_name).txt >
(assembly_file_name).asm” and hit Enter.

This bash shell script removes the PC relative references from
(assembly_file_name).txt file, and pipes the output to
(assembly_file_name).asm.




B /cygdrive/c/users/carl/downloads — O et

e. Type exit and hit enter to quit the Cygwin64 terminal.

7. Start a DOS command prompt as administrator.

BN Select Administrator: Command Prompt — O x




8. Change to the directory containing the KPIT GNU sh-elf-as.exe assembler

BN Select Administrator: Command Prompt - O *

\kpit cumminsg

h-elf\bin




9. Assemble the code by running this command:
sh-elf-as -o (rom_file_name).o (assembly_file_name).asm.

This will create an output file named (rom_file_name).o.

EX Administrator: Command Prompt — O b

82\sh-elf\bin>

10. Link the code by running:
sh-elf-ld -o (rom_file_name) (rom_file_name).o
This will create a linked output file named (rom_file_name).

EX Administrator: Command Prompt — O b

sh-elf\bin»sh-elf-1d -o c:\use

2\sh-elf\bin>

11. Finally, you'll need to trim the header junk created by the GNU assembler and linker,
using a Cygwin64 Terminal command:

dd if=(rom_file_name) of=rom.hex bs=1 skip=132 count=262144

B8 /cygdrive/c/users/carl/downloads — O *

This will extract the ROM image into a hex file that you can flash to your ECU.



