car stalls with a/c on - Page 5 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



car stalls with a/c on

Reply
 
 
 
Thread Tools Search this Thread
Old Aug 2, 2009, 11:44 PM   #61
Evolved Member
iTrader: (22)
 
Appauldd's Avatar
 
Join Date: Nov 2003
Location: Northern KY near Cincy
Posts: 2,408
Thanks: 0
Thanked 2 Times in 2 Posts

Drives: 2003 Mitsu EVO (white)

Yes, I found them all on here.
Offline
 
Reply With Quote
Old May 15, 2017, 06:37 PM   #62
Evolving Member
iTrader: (4)
 
Bmurray's Avatar
 
Join Date: Nov 2012
Location: Burlington, NC
Posts: 305
Thanked 12 Times in 11 Posts

Drives: 06 Evo IX SSL

Can someone help me. Instead of making a new thread I am just going to ask here. So I had a iacv issue last week. Basically, I thought mine was bad, so I bought a cheap eBay one, cheap eBay one came in and I was having an erratic idle so I messed with the biss screw. I said screw the cheap eBay iacv, cleaned my oem one good and put it back in. I also turned the biss screw back a few turns to where it was. Ever since then, whenever I turn my AC on, the car stumbles horribly and eventually shuts off. What in the hell could have happened? Car runs perfect with AC off, as soon as I turn it on, dies.

Please help!
Offline
 
Reply With Quote
Old May 16, 2017, 01:22 AM   #63
Evolving Member
 
Join Date: Mar 2013
Location: in a garage
Posts: 263
Thanked 9 Times in 9 Posts

Drives: Lancer

Just back off the biss screw a bit, then a bit more.

Do you have an atmo BOV?
Offline
 
Reply With Quote
Old May 16, 2017, 02:36 AM   #64
Evolved Member
iTrader: (37)
 
gsrboi80's Avatar
 
Join Date: Aug 2005
Location: Where the streets have no name
Posts: 7,704
Thanked 17 Times in 17 Posts

Drives: 03 TB VIII

Quote:
Originally Posted by Bmurray View Post
Can someone help me. Instead of making a new thread I am just going to ask here. So I had a iacv issue last week. Basically, I thought mine was bad, so I bought a cheap eBay one, cheap eBay one came in and I was having an erratic idle so I messed with the biss screw. I said screw the cheap eBay iacv, cleaned my oem one good and put it back in. I also turned the biss screw back a few turns to where it was. Ever since then, whenever I turn my AC on, the car stumbles horribly and eventually shuts off. What in the hell could have happened? Car runs perfect with AC off, as soon as I turn it on, dies.

Please help!
Was the battery disconnected at the time? The Evo ECU will need to relearn idle settings for both AC on and AC off, this takes a few drive cycles to complete. Also, when you "adjusted" the BISS did you do so using EVOSCAN actuator section to turn off the ISCV, set it, then re enable the ISCV per the FSM, if not I'd go back through that procedure and set the Base Idle correctly.
Offline
 
Reply With Quote
Old May 16, 2017, 04:46 AM   #65
Evolving Member
iTrader: (4)
 
Bmurray's Avatar
 
Join Date: Nov 2012
Location: Burlington, NC
Posts: 305
Thanked 12 Times in 11 Posts

Drives: 06 Evo IX SSL

Quote:
Originally Posted by RightSaid fred View Post
Just back off the biss screw a bit, then a bit more.

Do you have an atmo BOV?
Yes but I am on speed density. Okay I will try that

Quote:
Originally Posted by gsrboi80 View Post
Was the battery disconnected at the time? The Evo ECU will need to relearn idle settings for both AC on and AC off, this takes a few drive cycles to complete. Also, when you "adjusted" the BISS did you do so using EVOSCAN actuator section to turn off the ISCV, set it, then re enable the ISCV per the FSM, if not I'd go back through that procedure and set the Base Idle correctly.
Battery was never disconnected. Alright thank you looks like it all just needs to be reset in evoscan and via biss screw
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 OZ Rally A/C Blower and A/C Clutch - strange behavior kd5byb Lancer Troubleshooting 0 Sep 7, 2013 05:44 AM
stalling issues PlanoEvo EcuFlash 88 Aug 12, 2013 09:16 PM
AC Stalling/Car wont turn over Evo_IX_Guy Evo Engine / Turbo / Drivetrain 23 Dec 5, 2012 12:19 AM
A/C idle issues EvoJoeIX EcuFlash 18 Aug 9, 2012 04:15 PM
stalling/idle dip problem deadstockkpomp Evo General 15 Jul 16, 2012 07:41 PM


Tags
2003, ac, biss, car, control, idle, lancer, mitsubishi, ralliart, running, screw, stability, stall, stalls, timing

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 04:51 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: