4G18 on ecuflash - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



4G18 on ecuflash

Reply
 
 
 
Thread Tools Search this Thread
Old Jun 23, 2010, 05:40 PM   #1
Newbie
Thread Starter
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
4G18 on ecuflash

Hi, first of all im using Proton Waja year 2001 . I got 4G18P Mitsubishi engine inside with manual tranny. i manage download my rom using Evoscan software.

But i have cannot edit the my ecu rom. how can i edit it ?
Attached Files
File Type: zip FlashImage_20101506_1345.zip (67.5 KB, 0 views)
Offline
 
Reply With Quote
Old Jun 23, 2010, 07:25 PM   #2
Evolving Member
 
Join Date: Apr 2008
Location: Reading, PA
Posts: 265
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 95 Talon TSi AWD

You need to write a definition for it, or have someone write one.

From the file size it looks like its a SH-2 ecu.
Offline
 
Reply With Quote
Old Jun 23, 2010, 10:21 PM   #3
Evolved Member
 
acamus's Avatar
 
Join Date: Mar 2008
Location: Lattitude 48.38, Longitude 17.58, Altitude 146m = Slovakia, for common dude
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: his wife crazy & 14 ASX

here
Attached Files
File Type: txt 97400004.xml.txt (5.5 KB, 0 views)
Offline
 
Reply With Quote
Old Jun 24, 2010, 08:23 PM   #4
Newbie
Thread Starter
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
acamus: so i just replace the current C:\Program Files\OpenECU\EcuFlash\rommetadata\mitsubishi\lanc er\97400004.xml with yours.

when i load the rom files

it says

[11:22:45.937] Unable to find parent metadata evo7base
[11:22:45.953] 262144 byte image read.

is this normal bro ?
Offline
 
Reply With Quote
Old Jun 24, 2010, 08:32 PM   #5
Newbie
Thread Starter
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
i think its SH7? am i right ? my friend told me its SH7
Offline
 
Reply With Quote
Old Jun 24, 2010, 09:37 PM   #6
Evolved Member
 
acamus's Avatar
 
Join Date: Mar 2008
Location: Lattitude 48.38, Longitude 17.58, Altitude 146m = Slovakia, for common dude
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: his wife crazy & 14 ASX

Quote:
Originally Posted by holydevil View Post
acamus: so i just replace the current C:\Program Files\OpenECU\EcuFlash\rommetadata\mitsubishi\lanc er\97400004.xml with yours.

when i load the rom files

it says

[11:22:45.937] Unable to find parent metadata evo7base
[11:22:45.953] 262144 byte image read.

is this normal bro ?
Reinstall your ECUFlash, the base files shall be available in evo subdir.
Offline
 
Reply With Quote
Old Jul 6, 2010, 10:49 AM   #7
Evolving Member
 
Join Date: Feb 2008
Location: Guatemala
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
acamus, sorry do you have definition for these rom
Attached Files
File Type: zip beto 4g18.zip (65.6 KB, 0 views)

Last edited by nestoledo; Jul 6, 2010 at 10:53 AM.
Offline
 
Reply With Quote
Old Jul 10, 2010, 11:53 PM   #8
Newbie
Thread Starter
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
i reinstall and so on i still get
[11:22:45.937] Unable to find parent metadata evo7base
[11:22:45.953] 262144 byte image read.

i have no idea o.o
Offline
 
Reply With Quote
Old Jul 12, 2010, 12:28 AM   #9
Evolved Member
 
acamus's Avatar
 
Join Date: Mar 2008
Location: Lattitude 48.38, Longitude 17.58, Altitude 146m = Slovakia, for common dude
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: his wife crazy & 14 ASX

You should have this file
C:\Program Files\OpenECU\EcuFlash\rommetadata\mitsubishi\evo\ evo7base.xml
it comes with installation.
Offline
 
Reply With Quote
Old Jul 12, 2010, 12:29 AM   #10
Evolved Member
 
acamus's Avatar
 
Join Date: Mar 2008
Location: Lattitude 48.38, Longitude 17.58, Altitude 146m = Slovakia, for common dude
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: his wife crazy & 14 ASX

Quote:
Originally Posted by nestoledo View Post
acamus, sorry do you have definition for these rom
No, but I could create one
Offline
 
Reply With Quote
Old Jul 13, 2010, 07:58 PM   #11
Newbie
Thread Starter
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by acamus View Post
You should have this file
C:\Program Files\OpenECU\EcuFlash\rommetadata\mitsubishi\evo\ evo7base.xml
it comes with installation.

ok i manage open it well

[10:54:45.046] 97400004 (20 tables) inheriting evo7base (73 tables) [10:54:45.078] 262144 byte image read.


after i put a evo7base.xml on

C:\Program Files\OpenECU\EcuFlash\rommetadata\mitsubishi\lanc er

then it work perfectly fine thanks! hehehe. wanna see my setup now bro? can review abt it?
Offline
 
Reply With Quote
Old Jul 22, 2010, 06:01 AM   #12
Newbie
 
Join Date: Apr 2009
Location: Trini
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsu Lancer

hey, i'm having a problem with my ECU. Its the 4G18 engine and I had CVT but replaced it with a gearbox. Now it seems that i'm getting a cut in power under load...mostly in 4th and 5th gear and going up hill. I am using the same automatic ECU, i think this is the reason for the problems.

how can i fix this? its real hard to get the manual ecu where i live.

Last edited by dollarwize; Jul 22, 2010 at 06:05 AM. Reason: added information
Offline
 
Reply With Quote
Old Sep 26, 2010, 05:20 PM   #14
Newbie
 
Join Date: Nov 2008
Location: GUATEMALA
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi Lancer GLX 1.6

hi, well i used this definition acamus sent to nestoledo, and i gave a +20 and when i ran mitsulogger, there were no knocks detected, is this alright or mitsulogger is not having good comunication with the ecu??? thanks
Offline
 
Reply With Quote
Old Sep 26, 2010, 10:00 PM   #15
Evolved Member
 
acamus's Avatar
 
Join Date: Mar 2008
Location: Lattitude 48.38, Longitude 17.58, Altitude 146m = Slovakia, for common dude
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: his wife crazy & 14 ASX

According to the ROM there is no Knock sensor. Does it answer your question?
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird Stock ROM File on Final Edition Decil Ecuflash 4 Apr 21, 2017 12:28 AM
Final Edition Rom (Tactrix) Smolik1010 Ecuflash 3 Jun 7, 2016 08:54 AM
4g93 wich rom for turbo??? danny1058 Other Mitsubishi vehicles 1 May 30, 2016 12:36 PM
tuning 4g64 evo dom4g63 General Engine Management / Tuning Forum 17 May 4, 2016 06:48 AM
Weird issue with XML's, table's and tuner seeing different things on the same ROM SmurfZilla EcuFlash 6 Sep 7, 2015 01:27 PM


Tags
4g18, date, ecu, ecuflash, engine, evo, manual, mitsu, mitsubishi, photo, replace, rom, software, tuning, waja, xml

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:44 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: