Notices
EcuFlash

Flashing an Airtrek Turbo

 
Old Sep 15, 2018, 06:08 PM
  #316  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
Originally Posted by Craig Pounsford View Post
I think I may have bigger problems, I changed the read method in the rom and that still didn't work, I noticed that the check engine light wasn't working so I pulled the dash apart to find out that the previous owner had siliconed over the bulb, I removed the silicone to find out that the light is constantly on! I have tried to connect to a couple of OBD scanners with no luck, I'm sort of lost as to what to do next.
well that sucks! Do you have evoscan? Your tactrix cable with evoscan can do your error code scans. I would be seeing what codes come up with that.. there is a large list of error codes on the the evoscan website. .
OzAirtrek is offline  
Old Sep 15, 2018, 06:26 PM
  #317  
Newbie
 
Join Date: Sep 2018
Location: Christchurch, New Zealand
Posts: 8
Likes: 0
Liked 0 Times in 0 Posts
I do have evoscan but am still unable to connect for some reason, I'm quite new to all this ecu tuning, I have the tactrix 2.0 cable and the separate re-flash connector which I am unsure how to connect.
Craig Pounsford is offline  
Old Sep 15, 2018, 06:42 PM
  #318  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
you dont need to connect the reflash connector to use evoscan .. i use the 1.3 cable but others have used the 2.0 cable fine. just make sure you have settings correct as per the pic and connect your cable up



OzAirtrek is offline  
Old Sep 15, 2018, 06:46 PM
  #319  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
btw you need to have the car running (idling) for evoscan to connect (unlike ecuflash which works with the key to 'on')
OzAirtrek is offline  
Old Sep 15, 2018, 07:13 PM
  #320  
Newbie
 
Join Date: Sep 2018
Location: Christchurch, New Zealand
Posts: 8
Likes: 0
Liked 0 Times in 0 Posts
Oh, that's where I have been going wrong with evoscan! Thank you very much
Craig Pounsford is offline  
Old Sep 15, 2018, 09:34 PM
  #321  
Newbie
 
Join Date: Sep 2018
Location: Christchurch, New Zealand
Posts: 8
Likes: 0
Liked 0 Times in 0 Posts
It still doesn't work, I don't know what is going on, it's giving me a 'j2534 error read code' and says it can't connect to vehicles ECU. I'm close to giving up and letting a professional rob me of my money.
Craig Pounsford is offline  
Old Sep 16, 2018, 12:00 AM
  #322  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
Originally Posted by Craig Pounsford View Post
It still doesn't work, I don't know what is going on, it's giving me a 'j2534 error read code' and says it can't connect to vehicles ECU. I'm close to giving up and letting a professional rob me of my money.
sounds like an issue with your cable drivers and computer not the car.

read more Here

try uninstall ecuflash and reinstall latest version
OzAirtrek is offline  
Old Sep 17, 2018, 01:26 PM
  #323  
Newbie
 
Join Date: Feb 2012
Location: New Zealand
Posts: 38
Liked 0 Times in 0 Posts
If you were in Auckland i could have a look for you.

It took me a while to get mine to work, a few things:
My <flashmethod>mitsukernel</flashmethod> had to be <flashmethod>mitsukernelocp</flashmethod> as i think it's to do with 80700017 the later version needing this 2003 (along with the SH7055, instead of 7052 which is manual/auto gearbox / 256kb, 512kb difference, includes the autobox maps) on my airtrek (which was 8+ years ago)
The other problem i had was the 2nd connector needed re wiring, but i think this is for writing, not reading so shouldn't be giving you these issues (i am sure someone has already posted about this, when using an evoscan cable, the cable on some airtreks is the opposite, i just swapped the plug over from a wrecked one)

Also for those interested in launch control - i paid for it but it's been so many years it's time to share it on - attached - Merry Christmas
Please copy your own boost/limits/fuel and timing tables as mine from memory weren't finished and it ran 22+psi with an EBCS, along withfuel was super rich (after market fuel pump) Never got round to finishing the tune before i sold the car.

Launch control is fun though. You need the read file and the tune to work together/ then copy ur own map configurations over.
For evo gt-a - untested for airtrek.

Please note there are changes to shift times as well in these maps (yes these maps have all shift tables and times too!) i tweaked 4th-5th to change later, and the shift times have been set shorter/quick (at risk of premature gearbox faliure)
Attached Files
File Type: bin
Johno GT-A Final1.bin (512.0 KB, 0 views)
poachersun is offline  
Old Sep 17, 2018, 07:40 PM
  #324  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
Thanks poachersun! I'll be looking at that in detail! Any mods to your injectors or maf? I know gta runs different parts for those than Airtrek

also what turbo?
OzAirtrek is offline  
Old Sep 18, 2018, 03:10 AM
  #325  
Newbie
 
Join Date: Feb 2012
Location: New Zealand
Posts: 38
Liked 0 Times in 0 Posts
Yeh evo 7 gta is a bit different in allot of aspects. Td05 turbo

my airtek setup had td05 evo 8 turbo fmic kit and subaru sti drop in 550cc injectors from memory.

you really gotta swap over all maps snd be careful/know what ur doing 😁. I took risks and managed not to blow anything up lol
poachersun is offline  
Old Sep 18, 2018, 06:04 AM
  #326  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
The spark shift cut tables are interesting! - none of those defined in the airtrek. I''m getting some overboost in 2 to 3rd shift im wondering if it is caused by WGDC varying too much (starting at 100% dropping to 60%) or another issue
OzAirtrek is offline  
Old Sep 18, 2018, 06:53 AM
  #327  
Newbie
 
Join Date: Oct 2017
Location: Perth, Australia
Posts: 35
Liked 2 Times in 2 Posts
these are the tables im running for the 3 port - boosting around 12psi on guage. However 2 to 3 is spiking to 16 on gear change...

OzAirtrek is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PhilJ
09+ Ralliart Engine/Turbo/Drivetrain
3
Sep 17, 2018 01:23 PM
Learning
Lancer Engine Management / Tuning Forums
1
Dec 11, 2017 01:04 AM
Paul73
Evo Engine / Turbo / Drivetrain
3
Jun 23, 2017 12:28 AM
jarjar1977
EcuFlash
1
May 9, 2016 03:59 AM
jarjar1977
General Engine Management / Tuning Forum
0
May 9, 2016 01:40 AM


Thread Tools
Search this Thread
Quick Reply: Flashing an Airtrek Turbo


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.