How to Eliminate "Rev-Hang" on the 05+ EVO 8/9s - Page 4 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

How to Eliminate "Rev-Hang" on the 05+ EVO 8/9s

Reply

 
 
 
Old Jul 10, 2017, 05:05 PM
  #46  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 8,617
Thanked 170 Times in 165 Posts
How in heck did I miss this?? Bookmarked for future reference!
kaj is offline  
Reply With Quote
Old Jul 14, 2017, 12:21 PM
  #47  
Evolving Member
 
TJung's Avatar
 
Join Date: Oct 2008
Location: Poland, Katowice
Posts: 286
Thanks: 0
Thanked 0 Times in 0 Posts
Hello guys. I have rev-hang problem in my EDM Evo 9 07' with 88580714 v7 rom.
I'm not sure which tables should I touch to eliminate it. Except rev hang, sometimes when I stop the car (i.e. at red light), idles are raisning up to 1800 - 2000 rpm or "waving".


TJung is offline  
Reply With Quote
Old Jul 14, 2017, 04:03 PM
  #48  
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by TJung View Post
Hello guys. I have rev-hang problem in my EDM Evo 9 07' with 88580714 v7 rom.
I'm not sure which tables should I touch to eliminate it. Except rev hang, sometimes when I stop the car (i.e. at red light), idles are raisning up to 1800 - 2000 rpm or "waving".


Read this post from beginning, there are some tables to add and lots of helpful things. Also links to other ideas about it.
06_SSL is offline  
Reply With Quote
Old Jul 14, 2017, 06:20 PM
  #49  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,002
Thanked 86 Times in 84 Posts
Did you try to find a way to wind up the throttle spring? Maybe your spring was reinstalled 1 round less when throttlebody seals were replaced?

Originally Posted by 06_SSL View Post

Ugly I know, but it sure snaps the throttle closed. That's why I need a better way to mount. But you get the idea
2006EvoIXer is offline  
Reply With Quote
Old Jul 14, 2017, 11:03 PM
  #50  
Evolving Member
 
TJung's Avatar
 
Join Date: Oct 2008
Location: Poland, Katowice
Posts: 286
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by 06_SSL View Post
Read this post from beginning, there are some tables to add and lots of helpful things. Also links to other ideas about it.
Ofcourse i've read it, few times, but there's no definitions for my rom number.

Ok, I think I'm good thanks to this thread
https://www.evolutionm.net/forums/ec...8586714-a.html

Last edited by TJung; Jul 15, 2017 at 12:12 AM.
TJung is offline  
Reply With Quote
Old Jul 14, 2017, 11:04 PM
  #51  
Evolving Member
 
TJung's Avatar
 
Join Date: Oct 2008
Location: Poland, Katowice
Posts: 286
Thanks: 0
Thanked 0 Times in 0 Posts
Double post

Last edited by TJung; Jul 15, 2017 at 12:09 AM.
TJung is offline  
Reply With Quote
Old Jul 15, 2017, 07:05 AM
  #52  
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by TJung View Post
Ofcourse i've read it, few times, but there's no definitions for my rom number.

Ok, I think I'm good thanks to this thread
https://www.evolutionm.net/forums/ec...8586714-a.html
Sorry missed your rom ID, I'm no expert I assure you, try searching for compatible roms that will work in your ecu

06_SSL is offline  
Reply With Quote
Old Jul 15, 2017, 07:14 AM
  #53  
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by 2006EvoIXer View Post
Did you try to find a way to wind up the throttle spring? Maybe your spring was reinstalled 1 round less when throttlebody seals were replaced?
Yes it's as tight as it can be, I rebuilt it myself and couldn't get another wind on it. Tried all the tuning "fixes" , boost leak tested 100x's, and it still just felt like the throttle was being forced or sucked open. I thought about new springs but since people have complained about this since the 9 came out I decided why bother. 1 thing that helped it slightly on warm up was to hook back up the FAIV (coolent to TB).
06_SSL is offline  
Reply With Quote
Old Jul 15, 2017, 07:17 AM
  #54  
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by TJung View Post
Ofcourse i've read it, few times, but there's no definitions for my rom number.

Ok, I think I'm good thanks to this thread
https://www.evolutionm.net/forums/ec...8586714-a.html
Nice I'm glad you found that, good luck.
06_SSL is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tephra
Ecuflash
16
Jan 28, 2018 04:37 PM
simple_lancer
EcuFlash
73
Aug 12, 2017 05:26 PM
tephra
Evo X Engine Management / Tuning Forums
151
Jun 18, 2017 03:22 PM
Dynotech Tuning
EcuFlash
80
Sep 20, 2016 01:30 PM
mrfred
EcuFlash
399
Jul 29, 2016 07:02 PM


Thread Tools
Search this Thread
Quick Reply: How to Eliminate "Rev-Hang" on the 05+ EVO 8/9s


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.