Speed Density Idle problem ( 70 LOAD- 10.5 AFR ) - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Speed Density Idle problem ( 70 LOAD- 10.5 AFR )

Reply
 
 
 
Thread Tools Search this Thread
Old May 10, 2016, 02:45 AM   #1
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

Speed Density Idle problem ( 70 LOAD- 10.5 AFR )

Hello Guys,
After 5 days my Evo 8 with speed density running!
Car running at idle with 70 LOAD(95Hz airflow) instead 30, and 10.5 AFR instead stoich.

What's wrong? Seems needs a sort of calibration MAP -> LOAD ?

Thanks
Offline
 
Reply With Quote
Old May 10, 2016, 06:22 AM   #2
Newbie
 
Join Date: Jun 2014
Location: Russia
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Airtek

maf load = sd load, check you calibration
Offline
 
Reply With Quote
Old May 10, 2016, 07:02 AM   #3
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

This is my sd ve table.

Any suggestions?

Thanks
Attached Thumbnails
Speed Density Idle problem ( 70 LOAD- 10.5 AFR )-immagine.png  
Offline
 
Reply With Quote
Old May 10, 2016, 07:32 AM   #4
Evolving Member
 
Join Date: Oct 2012
Location: Dubai
Posts: 265
Thanked 1 Time in 1 Post

Drives: 2006 Evo9 MR

I am not a professional nor a tuner, although your RPM VE seems a bit rich on the idle.
Offline
 
Reply With Quote
Old May 10, 2016, 12:55 PM   #5
Evolving Member
 
Join Date: Oct 2007
Location: Charleston, WV
Posts: 491
Thanks: 0
Thanked 8 Times in 8 Posts

Drives: 2005 Evolution MR

Just noticed that you said after 5 days like this was a problem that just came up after 5 days of running differently on the same tune? If that occurred you might have a mechanical issue.

Last edited by ridenrunwv; May 10, 2016 at 01:01 PM.
Offline
 
Reply With Quote
Old May 10, 2016, 12:58 PM   #6
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

Quote:
Originally Posted by EvilEvolution8 View Post
This is my sd ve table.

Any suggestions?

Thanks
Quote:
Originally Posted by ridenrunwv View Post
Just noticed that you said after 5 days like this was a problem that just came up after 5 days of running differently on the same tune? If that occurred you might have a mechanical issue.
Ohh no sorry! 5 days to male a conversion...today is a first day that i run with SD
Offline
 
Reply With Quote
Old May 10, 2016, 01:01 PM   #7
Evolving Member
 
Join Date: Oct 2007
Location: Charleston, WV
Posts: 491
Thanks: 0
Thanked 8 Times in 8 Posts

Drives: 2005 Evolution MR

Try RPM VE 500 to 2000 as 64, 67, 70, 75, 80 and see if that leans it out any.
Offline
 
Reply With Quote
Old May 10, 2016, 01:02 PM   #8
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

Quote:
Originally Posted by ridenrunwv View Post
What cams and injectors?
All stock at the moment .
Offline
 
Reply With Quote
Old May 10, 2016, 01:03 PM   #9
Evolving Member
 
Join Date: Oct 2007
Location: Charleston, WV
Posts: 491
Thanks: 0
Thanked 8 Times in 8 Posts

Drives: 2005 Evolution MR

I was trying to edit posts because reading replies you made right as I posted so messed the order of posts up a bit.

Try RPM VE 500 to 2000 as 64, 67, 70, 75, 80 and see if that leans it out any.
Offline
 
Reply With Quote
Old May 10, 2016, 01:04 PM   #10
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

Thanks a lot!! I will try!
Offline
 
Reply With Quote
Old May 10, 2016, 01:05 PM   #11
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

In your opinion...the rest of RPM VE and the MAP VE is correct ?
Offline
 
Reply With Quote
Old May 10, 2016, 01:07 PM   #12
Evolving Member
 
Join Date: Oct 2007
Location: Charleston, WV
Posts: 491
Thanks: 0
Thanked 8 Times in 8 Posts

Drives: 2005 Evolution MR

Can't really tell just by looking at that. You could honestly have all different variations of data in tables and the car still run fine.
Offline
 
Reply With Quote
Old May 10, 2016, 01:10 PM   #13
Newbie
Thread Starter
 
Join Date: Dec 2015
Location: xx
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post

Drives: Evo 8

Ok perfect!
Offline
 
Reply With Quote
Old Jun 22, 2017, 05:26 AM   #14
Newbie
 
Join Date: Aug 2014
Location: Scottsdale, AZ
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Bump

im having a similar issue with my load, it's 44% at idle and the car uses mid LTFT at idle and sometimes goes to low, any ideas? Did raising your RPM ve tables a bit help as suggested?
Offline
 
Reply With Quote
Old Jun 22, 2017, 11:46 AM   #15
Evolved Member
iTrader: (1)
 
letsgetthisdone's Avatar
 
Join Date: Oct 2013
Location: Las Vegas
Posts: 9,396
Thanked 349 Times in 332 Posts

Drives: 2005 Evo 8. 2011 F150 FX4

Need to change the crossover points for your fuel trims. It shouldn't go to mid until like 55-60 load.
Online
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How To: Speed Density on the evo8 using tephra v7/Phenem pre-patched roms scheides EcuFlash 341 Sep 4, 2017 10:08 PM
Speed Density Questions Rom 96531706 4b11slayer EcuFlash 16 Jul 28, 2017 11:33 AM
10.0AFR decel 941701715 v7 ReidFletcher EcuFlash 33 Apr 27, 2017 02:03 AM
car runs weird after compression test. help! lostsoulsevo Evo Engine / Turbo / Drivetrain 28 Feb 9, 2017 06:52 PM
Neal's Built 2.0L FP Zero GSC S2 MAP Rev3 93oct + meth results tscompusa Evo Dyno Tuning and Results 17 Nov 19, 2015 03:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 02:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: