need help! High idle after EVAP&EGR removal & ported throttle body - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

need help! High idle after EVAP&EGR removal & ported throttle body

Reply

 
 
 
Old Apr 14, 2017, 12:39 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2012
Location: Montreal, Quebec
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
need help! High idle after EVAP&EGR removal & ported throttle body

High,

I remove EVAP and EGR with FPR solenoid this winter. I also ported stock throttle body to 65mm and the intake manifold.

Now finish, I flash with the bit change that was said in the EVAP removal thread. This is good, I have no CEL.

But my idle is at 2000rpm. I data log the target RPM, it's 824rpm. Why doesn't go to the target rpm. so well adjust in the idle map.

I dit a leak test before starting everything with all the hole cap and everything and it was good. So I don't think i'm taking air from somewhere else because of all the things remove and cap.

When I log, everything is normal, timing AFR (at this rpm)...

I check the TPS % in the case that if I had do a bad alignement of the sensor on the throttle body when I reassemble it. before winter, it was to 11%, now it's to 10.5%, so this seems ok. Should it be lower because the hole is now bigger?

so guys that have remove EVAP&EGR or change to ported intake and throttle body,
Any idea of what I could look at or why ECU won't adjust to target rpm?

Thanks!
PL_MR is offline  
Reply With Quote
Old Apr 14, 2017, 07:06 PM
  #2  
Newbie
Thread Starter
 
Join Date: Sep 2012
Location: Montreal, Quebec
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
I try to compare every map the version before I change all the bit to see if I have change one that I should't. I found in the periphery different value. It this a result of the bit I change that as affect those by default? for one who has done the removal, what do you have for those hex? the upper value our before, the lower are with the removal. do you get the same?

PL_MR is offline  
Reply With Quote
Old Apr 15, 2017, 06:40 AM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2012
Location: Montreal, Quebec
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Trhough my search, i found thread on IACV and BISS screw.
I test like shown on other post the IACV this morning, it's working good.
I screw the BISS but i'm only able to to it half-turn and it's at the end of his stroke. Idle goes 300rpm lower but not enough...

I see on ported forum that maybe the butterfly plate could have a bad fit with the core, letting more air to go but mine seems very good...

anybody has an idea?
PL_MR is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BigJohnnyturbo
EcuFlash
46
Sep 4, 2017 01:18 AM
fostytou
Evo How To Requests / Questions / Tips
317
Jul 27, 2017 01:57 PM
browningderek
AEM EMS
71
Jul 17, 2017 02:21 PM
xceler8rob
Evo Engine / Turbo / Drivetrain
34
Jul 17, 2016 12:57 PM
bakuro117
For Sale - Cars For Sale
1
Jul 11, 2016 11:24 AM


Thread Tools
Search this Thread
Quick Reply: need help! High idle after EVAP&EGR removal & ported throttle body


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.