EVO X Barometric Parameters - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



EVO X Barometric Parameters

Reply
 
 
 
Thread Tools Search this Thread
Old May 26, 2017, 12:01 PM   #1
Newbie
Thread Starter
iTrader: (1)
 
Join Date: Jun 2007
Location: Orlando
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2012 X GSR (and folks crazy)

EVO X Barometric Parameters

I've unmarried an AP v3 and recently had an ecu tune. I live at a higher elevation than where the tune was done. It's about 2000 feet difference. I'm getting a surge using a Grimspeed MBC from around 2400-3000rpm. If I stomp the gas even at 2800-3000rpm the surge is quite pronounced. I can also "follow" it (surge) easing the pedal down slowly until it's gone. And when the surge is gone, it's gone. All the way to redline.

HP/TQ on a Mustang were about par at 320whp, ecu tune or Cobb.
There goes that myth!

Boost builds to 30psi and tapers to around 24-26psi (gauge).
That's where the tuner had it set. Reluctant to tune with EBC.
A previous tune with the AP and EBC did the same thing. The tuner could not get a flash to me that killed the surge.Once I put an MBC on, problem solved. Although I did lose that 30psi I had. At 26psi peak boost and leveling out to around 22, no surging.

If I go to a lower elevation I can get back to 30psi with no surging at all.
I thought that an EBC was supposed to solve those problems.
AND that the ecu was smart enough to know how high (baro sensor) I was at a particular moment.
And with the AP tuned map and EBC at lower elevations things were just fine.

So, in EvoScan and EcuFlash I see a reference to barometric and timing.
(I have Golden's XML for my ecu).
But only that. I did piurchase a Tacrtix at the tuner because I suspected this would happen.
I'm new to this. I only got to logging and flashing with the AP.
And maps were locked by the tuner.
Different tuner now. Better as far as I'm concerned. But out of the shop for awhile.

What other ties, if any, would let a person vary tuning parameters according to elevation?
MIVEC.
EBC Duty Cycle
Timing (of course).
And what would a person do to target a particular area of rpm to diagnose a surging at only high altitudes?

I could really use some help here.
Thanks!

The goods:
2012 GSR. Sleeved 4B11T
Ported head, GSC S1 cams
Ported stock exhaust manifold.
Cobb intake.
3" Cobb TBE with high flow cat.
Perrin IC, piping.
Grimmspeed MBC (Cobb 3 port there but bypassed).
Stock turbo and injectors.
Offline
 
Reply With Quote
Old May 31, 2017, 09:46 AM   #2
Newbie
Thread Starter
iTrader: (1)
 
Join Date: Jun 2007
Location: Orlando
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2012 X GSR (and folks crazy)

Really?
Nobody?

I have a *****in' engine, great tune.
Just a few problems.
Offline
 
Reply With Quote
Old Jun 5, 2017, 06:15 AM   #3
Newbie
 
Join Date: Jul 2015
Location: Maryland
Posts: 26
Thanked 2 Times in 2 Posts

Drives: 2014 Evo GSR

Did you put the boost pill in the line leading to the wastegate?
Offline
 
Reply With Quote
Old Jun 12, 2017, 01:56 PM   #4
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

A reply. Cool.
NO. In every instance I've ever seen, installing a MBC or aftermarket 3 port. Pill comes out.
My tuner has been busy. In the mean time I found the bleed port on the MBC and restricted it with a piece of tubing.
It gives the effect of still letting pressure build to 30psi, but when it opens diverts more pressure to the wastegate. It does make that surge point rpm a little better, less sudden and violent.

Been trying to find out mivec tweaks to let a little more pressure blow through the engine where it surges. No joy on that, although I do see the mivec curves. I'll try to get a good log up. The deer have thinned out, and it's not so soggy with rain now.

Now that I have an open source tune I could put the 3 port back in the loop and work on the curve. Hopefully targeting the surge point and solving it.

But I still question the fact that surge under the exact same condition but at lower altitudes simply isn't there at all in the same rpm range.
In ecflash with Golden's def for my ecu, there is a timing/baro section.
But nothing for boost/baro.

I saw in another forum an exchange between Tephra and Golden. From what I got there is something that could be done to 'help the guys who live in the mountains, but still work when they go to the beach'.
It got a bit involved. If explained to me like I was in 1st grade with a touch of theory it would be absorbable.
Because they are fluid and do it every day, sometimes it gets way over a person's head.

Right now I'm seeing that with EBC...OR MBC....my only option is to bump timing in my surge range. What does that do when I go down to the beach? 22psi boost now dips to 16ish?

I'd really hate to tether a laptop everywhere I go.
Even with the AP I could switch maps. And that was built in the it from the factory.
Locked maps from the former tuner made it impossible to do anything with them.

Over the past several weeks scouring the 'net for posts for my troubles and solutions for it are vague. The EVO ecu is supposed to be 'smart'. Perhaps the only discovered part of barometric is the timing adjustment. Or I'm missing the relationship, need to add a table, etc
Offline
 
Reply With Quote
Old Jun 12, 2017, 09:28 PM   #5
Newbie
 
Join Date: Jul 2015
Location: Maryland
Posts: 26
Thanked 2 Times in 2 Posts

Drives: 2014 Evo GSR

Quote:
Originally Posted by Arlo View Post
A reply. Cool.
NO. In every instance I've ever seen, installing a MBC or aftermarket 3 port. Pill comes out.
My tuner has been busy. In the mean time I found the bleed port on the MBC and restricted it with a piece of tubing.
It gives the effect of still letting pressure build to 30psi, but when it opens diverts more pressure to the wastegate. It does make that surge point rpm a little better, less sudden and violent.

Been trying to find out mivec tweaks to let a little more pressure blow through the engine where it surges. No joy on that, although I do see the mivec curves. I'll try to get a good log up. The deer have thinned out, and it's not so soggy with rain now.

Now that I have an open source tune I could put the 3 port back in the loop and work on the curve. Hopefully targeting the surge point and solving it.

But I still question the fact that surge under the exact same condition but at lower altitudes simply isn't there at all in the same rpm range.
In ecflash with Golden's def for my ecu, there is a timing/baro section.
But nothing for boost/baro.

I saw in another forum an exchange between Tephra and Golden. From what I got there is something that could be done to 'help the guys who live in the mountains, but still work when they go to the beach'.
It got a bit involved. If explained to me like I was in 1st grade with a touch of theory it would be absorbable.
Because they are fluid and do it every day, sometimes it gets way over a person's head.

Right now I'm seeing that with EBC...OR MBC....my only option is to bump timing in my surge range. What does that do when I go down to the beach? 22psi boost now dips to 16ish?

I'd really hate to tether a laptop everywhere I go.
Even with the AP I could switch maps. And that was built in the it from the factory.
Locked maps from the former tuner made it impossible to do anything with them.

Over the past several weeks scouring the 'net for posts for my troubles and solutions for it are vague. The EVO ecu is supposed to be 'smart'. Perhaps the only discovered part of barometric is the timing adjustment. Or I'm missing the relationship, need to add a table, etc
Datalog when you feel the surge. I think I know your issue but want to see it looked. Do a rax fast log if possible
Offline
 
Reply With Quote
Old Jun 13, 2017, 08:12 AM   #6
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

Reply

Quote:
Originally Posted by WickWhiteEvox View Post
Datalog when you feel the surge. I think I know your issue but want to see it looked. Do a rax fast log if possible
Will do. Have to read to get RAX placed properly.
Merlin's guide has given me some insight, forums have helped me understand more.
I'm thinking that if the everyday terminology for seasoned tuners was explained a bit...simpler....it would be helpful.

I'm very familiar with sbc programming, ini and xml edits, and data logging.
Unfortunately I do not have a tuner close by. And what looks great on the dyno is not working well on the street.

I knew what I was up against and the frustration of emailing Cobb logs with new locked maps to try. My previous tuner failed immensely.

My new tuner was reluctant to get into the Mustang software and dial in a road grade setting. While I watched the tune I saw that logging only took place from 3k to redline. So, as expected the same rpm of 2500-3000 rpm surge remained.
Although the car runs so much better from 3k to red with the ecu tune.

At the time the tuner did not want to have anything to do with 3 port tuning. As I assembled the engine and installed it in, broke it in, etc, and made an appt. for a new tune the mbc was all hooked up. Then I found out he had learned how to tune 3 ports. Time did not allow me to switch plumbing back to the ebc.

If any tuners read this who do it on a daily basis. I have read where I'm not the only instance of this happening. At this time I really don't have the funds to swap out for an anti surge turbo to fix a 500rpm band surge. And closer to sea level, the car ran awesome and great.

Hoping to get a log or 2 up here soon. Suggestions of what to log besides the obvious greatly appreciated.
Offline
 
Reply With Quote
Old Jun 15, 2017, 11:05 AM   #7
Evolved Member
 
richardjh's Avatar
 
Join Date: Oct 2010
Location: Australia
Posts: 2,410
Thanked 6 Times in 6 Posts

Drives: '09 Ralliart Lancer

Quote:
Originally Posted by Arlo View Post
Will do. Have to read to get RAX placed properly.
Merlin's guide has given me some insight, forums have helped me understand more.
I'm thinking that if the everyday terminology for seasoned tuners was explained a bit...simpler....it would be helpful.

I'm very familiar with sbc programming, ini and xml edits, and data logging.
Unfortunately I do not have a tuner close by. And what looks great on the dyno is not working well on the street.

I knew what I was up against and the frustration of emailing Cobb logs with new locked maps to try. My previous tuner failed immensely.

My new tuner was reluctant to get into the Mustang software and dial in a road grade setting. While I watched the tune I saw that logging only took place from 3k to redline. So, as expected the same rpm of 2500-3000 rpm surge remained.
Although the car runs so much better from 3k to red with the ecu tune.

At the time the tuner did not want to have anything to do with 3 port tuning. As I assembled the engine and installed it in, broke it in, etc, and made an appt. for a new tune the mbc was all hooked up. Then I found out he had learned how to tune 3 ports. Time did not allow me to switch plumbing back to the ebc.

If any tuners read this who do it on a daily basis. I have read where I'm not the only instance of this happening. At this time I really don't have the funds to swap out for an anti surge turbo to fix a 500rpm band surge. And closer to sea level, the car ran awesome and great.

Hoping to get a log or 2 up here soon. Suggestions of what to log besides the obvious greatly appreciated.
Hi. Regarding the logging, if you've added RAX Patch's "RAX Fast Logging" to your flashed ROM, you should just be able to select "RAX Fast Logging" mode in EvoScan, and log everything on offer. It's fast enough to give you a good set of data.

If you have issues applying RAX Patch to your ROM, feel free to email the ROM image to me. I can apply the patch, and email the revised ROM image file back to you:

raxpatch {at} gmail {dot} com

Cheers,

Rich
Offline
 
Reply With Quote
Old Jun 21, 2017, 02:14 PM   #8
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

Log

Funky log with Evoscan 2.9
Can't get 2.7 or 2.8 to communicate.
RPM winds up into and past the surging.
TPS is nuts, boost is nuts, and vehicle speed is nuts.
Attached Files
File Type: csv EvoScanDataLog_2017.06.15_12.40.37.csv (88.2 KB, 0 views)
Offline
 
Reply With Quote
Old Jun 23, 2017, 07:36 AM   #9
Newbie
 
Join Date: Jul 2015
Location: Maryland
Posts: 26
Thanked 2 Times in 2 Posts

Drives: 2014 Evo GSR

Quote:
Originally Posted by Arlo View Post
Funky log with Evoscan 2.9
Can't get 2.7 or 2.8 to communicate.
RPM winds up into and past the surging.
TPS is nuts, boost is nuts, and vehicle speed is nuts.
Log is definitely wack, what year evo?
Offline
 
Reply With Quote
Old Jun 23, 2017, 07:55 AM   #10
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

re:

Quote:
Originally Posted by WickWhiteEvox View Post
Log is definitely wack, what year evo?
It's a 2012 GSR.
I suspect that the xml is incorrect, although I used the Golden 58010005 xml.
If I had the resources to find which one was used during tuning, it would help.
Not complaining at all. But w/o knowing, I may be screwed.
How to get logs back to a tuner if they wont give info of what was used to do it?

Of course the learning curve is a bit new to me. Hopefully with a little insight I can "get it".

The AP tune was easy to log data. At the time I did not have a wideband. Now I do.
Setting that up in evoscan was easy. Getting data out...meh.

Evoscan has not responded to tech support. Could it be that the Service Engine Soon flag that tripped was caused by my cell phone being in the cup holder? Working on that. The light tripped twice. I reset it with the AP. Evoscan read them but would not reset them. No phone in the holder, and waiting to see if the codes pop up again. Something led to a canbus comm failure.
The mitsu dealer said the ACD warranty only targeted one code, which mine didn't show.

Dilemmas....

Arlo
Offline
 
Reply With Quote
Old Jun 23, 2017, 08:14 AM   #11
EvoM Guru
iTrader: (8)
 
razorlab's Avatar
 
Join Date: Aug 2003
Location: Alameda, ca
Posts: 10,422
Thanked 152 Times in 134 Posts

Drives: a laptop connected to your ECU.

Are you logging via RAX in evoscan or something else?

If you are not logging via RAX you need to select the correct ECU in Evoscan.

Can you take a screenshot of your evoscan screen?

I hope you are kidding about the cell phone....
Offline
 
Reply With Quote
Old Jun 23, 2017, 08:43 AM   #12
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

I'll have to go out and hook it all up. It's raining bad today. So it's sleeping in the garage.
When I got home with the Tactrix and found Evoscan 2.9 (before I bought it) and downloaded ecuflash. I backed up the tuned rom.

Opening Evoscan, it identified my rom as 58010005. Logging looked strange. I found Goldens file for 58010005 and plugged it in. Things looked better. Then I bought Evoscan 2.9, got 2.7 & 2.8.

It was shortly after that I started to read up. A lot. And during some not so spirited driving through town the SES light came on. Came home, read the codes. Tried first to read the ACD/AYC unit. Got Openport errors in 2.7 & 2.8 trying to read the awd unit.
A single code in ECU came up with nothing. Reading the unit in MUTIII came up with a few.
I couldn't read anything at all in MUTIII. Although I did get sensor lists..steering wheel, wheel sensors, etc., no data populated.
Stumped.
Reset them with Evoscan. ECU came up clean. MUTIII still had the codes. So I reset them with my AP. I was worried that I'd have to marry it first. I didn't.

And no. I'm serious. Canbus communication failure. Key not detected. Cell phone was in the cup holder. And I tripped codes twice (never happened with the AP tune). New fob battery.
Since I haven't had the phone near the holder, no codes. But I'm waiting.

And IF fast logging is enabled in my rom already (how do I know??) is it working the bus so hard that it glitches because of my phone? I know if I put it close to my laptop, strange things happen...jumpy mouse cursor, lagging keystrokes....wtf?
I'm an electronics geek, engineer. Had stranger things happen.
Am I nuts?

If I was at this, ecu tuning, for a bit of time perhaps I would be able to tear apart my rom and figure out what patches are in it. My tuner sure as hell won't tell me. except he did say Yes, Golden was involved. I haven't touched my ROM since tuned. But it's backed up.
How do I log if I don't have the correct way to log?

So I REALLY appreciate you all jumping in to assist.


Arlo
Offline
 
Reply With Quote
Old Jun 23, 2017, 09:20 AM   #13
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

Okay. I just got off of the phone with my tuner.
Verified he did not backup my original rom.
I requested that he please email it. And I was sent the oem rom.
So, the big question. Since SES lights started coming on after the ecu tune.
Is whatever was incorporated in the ecu tune lacking what the recall flash had in it?
The car was flashed before I ever used the AP v3, and even while using it I never had a code pop up.
Oh,and mind you. It was a lightly treaded conversation. Clear and concise.
And we're working with EBC mapping now. I'll hook up the 3 port and see what we get.

Arlo
Offline
 
Reply With Quote
Old Jun 23, 2017, 10:09 AM   #14
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

Help tephra!

Would sure like to send this to him. His box is full.
Attached Files
File Type: txt Tephra.txt (1.7 KB, 0 views)
Offline
 
Reply With Quote
Old Jul 3, 2017, 08:52 AM   #15
Newbie
 
Join Date: Jul 2016
Location: up north in the sticks
Posts: 45
Thanked 0 Times in 0 Posts

Drives: 2012 GSR

Well. I'm going to keep on trying this. I appreciate the replies and PM's.

Nope. I'm not "lugging" the engine. The S1 cams are suppose to support mid/higher range power.
My tuner did not adjust anything in MIVEC from looking at stock vs tuned maps. I'm using Golden's 58010005 EVO X files for evoscan and the one for Evoscan.

I have a map from my tuner to flash using the COBB 3 port. I have to switch out the Grimmspeed MBC I bought and plumb in the COBB, then flash. Not much in boost seems different from factory/tuned bin in ecuflash.


This is elevation based surging. Definitely. I went to Harrisburgh PA over the weekend. About 500ft above sea level. I could not get a hint of surge at all in highway driving under the same road conditions "up here". I could slam the gas to the floor, pass a car at 55mph, in 5th. No surge.

So. What I'm getting is this. My map is not taking in account that at higher elevations with (not so sure on the whole "Load" thing).
If I'm working the engine at the same throttle, rpm....at 2200ft. I can only "tolerate" this much boost before starting to surge". So I need to tune that out.
BUT if I go where it's lower in elevation...my barometric sensor knows it....and I can add a little boost in the rpm range without having any surge at all.

So, wtf do we do? Change cam timing (overlap)? Timing? Duty cycle?.
I'm spiking 30psi and tapering to around 22-24psi. And 22-24psi is where the surge is happening. Boost gauge flutters with it. And I'm not going to make the $12,000 mistake again making surge to data log for my tuner to tweak maps again and again.

Thoughts?


Arlo
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Evoscan/RAX/Golden Tuning guide and glossary Arlo Ecuflash 7 Sep 11, 2017 08:44 PM
3 Port Boost Tuning Help Please Arlo Evo X Engine Management / Tuning Forums 30 Nov 13, 2016 12:18 PM
Stage 3 Pro Tune Problems supwiddiss Cobb AccessPORT 3 Jun 24, 2016 01:21 PM
Waste Gate Flutter? Grimmspeed EBCS + UICP install J Yim Evo X Engine / Turbo / Drivetrain 6 Jan 25, 2016 01:00 PM
At what gear/RPM should you hit max boost? Blackevo mr Cobb AccessPORT 1 Oct 28, 2015 12:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:15 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: