Evo 8 stutters and goes lean above 20 psi.All of a sudden. - Page 3 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

Evo 8 stutters and goes lean above 20 psi.All of a sudden.

Reply

 
 
 
Old Jan 21, 2018, 06:58 AM
  #31  
Evolved Member
 
Biggiesacks's Avatar
 
Join Date: Aug 2005
Location: The Bay Area
Posts: 2,699
Thanked 146 Times in 140 Posts
Originally Posted by RightSaid fred View Post
A misfire causes a lean spike not a rich spike.


So it's misfiring because the AFR isn't right, the logger shows lean afterwards.


Your fuel pressure will be wrong of course......lol.
Yah that actually makes sense, if there is no combustion that means oxygen isn't being used up so the wideband will read lots of oxygen and think lean condition.
Biggiesacks is offline  
Reply With Quote
Old Jan 21, 2018, 07:50 AM
  #32  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
So im gonna call this a misfire then.

Because i dont thknk its fuel or boost cut.
4b11slayer is offline  
Reply With Quote
Old Jan 21, 2018, 08:46 AM
  #33  
EvoM Guru
iTrader: (8)
 
razorlab's Avatar
 
Join Date: Aug 2003
Location: Alameda, ca
Posts: 10,936
Thanked 212 Times in 187 Posts
Have you pulled the pump yet? Do that before you post anything else.
razorlab is offline  
Reply With Quote
Old Jan 21, 2018, 11:35 AM
  #34  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by razorlab View Post
Have you pulled the pump yet? Do that before you post anything else.
Yes i pulled it yesterday. No issues found. Pick up sock was dirty but not clogged. I cleaned it with brake cleaner and high air pressure.
4b11slayer is offline  
Reply With Quote
Old Jan 21, 2018, 04:17 PM
  #35  
EvoM Guru
iTrader: (8)
 
razorlab's Avatar
 
Join Date: Aug 2003
Location: Alameda, ca
Posts: 10,936
Thanked 212 Times in 187 Posts
Originally Posted by 4b11slayer View Post
Yes i pulled it yesterday. No issues found. Pick up sock was dirty but not clogged. I cleaned it with brake cleaner and high air pressure.
What did the OEM filter look like. Not the sock, the one embedded in the white plastic assembly. If it looks really dark, it might be clogged. That is what happened to me twice. New assemblies fixed everything.
razorlab is offline  
Reply With Quote
Old Jan 21, 2018, 05:17 PM
  #36  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by razorlab View Post
What did the OEM filter look like. Not the sock, the one embedded in the white plastic assembly. If it looks really dark, it might be clogged. That is what happened to me twice. New assemblies fixed everything.
So your not referring to the pick up sock? The one that clips to bottom of pump
4b11slayer is offline  
Reply With Quote
Old Jan 21, 2018, 06:16 PM
  #37  
EvoM Guru
iTrader: (8)
 
razorlab's Avatar
 
Join Date: Aug 2003
Location: Alameda, ca
Posts: 10,936
Thanked 212 Times in 187 Posts
Originally Posted by 4b11slayer View Post
So your not referring to the pick up sock? The one that clips to bottom of pump
No, the filter in the white plastic housing:

You can also see it in this thread where the OP cuts it open: https://www.evolutionm.net/forums/ev...-evo8-9-a.html

razorlab is offline  
Reply With Quote
Old Jan 21, 2018, 06:32 PM
  #38  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by razorlab View Post
No, the filter in the white plastic housing:

You can also see it in this thread where the OP cuts it open: https://www.evolutionm.net/forums/ev...-evo8-9-a.html

Dang so i would need a new hangar for testing?

I wana eliminate spark plugs and coils first. The plugs i threw in were not brand new but they were about 2500 miles. Im gonna try new plugs and borrow some coils.
4b11slayer is offline  
Reply With Quote
Old Jan 22, 2018, 06:01 AM
  #39  
Newbie
 
400s's Avatar
 
Join Date: Mar 2014
Location: C
Posts: 59
Thanks: 0
Thanked 6 Times in 5 Posts
Originally Posted by 4b11slayer View Post
Have not performed fuel pressure test.

Also I can take the car to 6500 rpm part throttle
Are you passing 20 psi on part throttle with no issues?

Last edited by 400s; Jan 22, 2018 at 06:12 AM. Reason: adding text
400s is offline  
Reply With Quote
Old Jan 22, 2018, 06:26 AM
  #40  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by 400s View Post
Are you passing 20 psi on part throttle with no issues?
Yes i can go part throttle 25 psi.

I did it last night i did 3rd gear part throttle and hit 25 and it was smooth. No stutter good afr.

So it only happens on WOT.
4b11slayer is offline  
Reply With Quote
Old Jan 22, 2018, 07:08 AM
  #41  
EvoM Guru
iTrader: (8)
 
razorlab's Avatar
 
Join Date: Aug 2003
Location: Alameda, ca
Posts: 10,936
Thanked 212 Times in 187 Posts
I'm gonna pull an RSF and ask if you know what your fuel pressure looks like.
razorlab is offline  
Reply With Quote
Old Jan 22, 2018, 07:32 AM
  #42  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by razorlab View Post
I'm gonna pull an RSF and ask if you know what your fuel pressure looks like.
Lol. Rsf

No i have not performed a fuel pressure test.
I will try and get my hands on a guage today.
So it should be 43.5 base with or without vaccum line?

And 43.5+ boost?
4b11slayer is offline  
Reply With Quote
Old Jan 22, 2018, 08:10 AM
  #43  
Evolved Member
 
Biggiesacks's Avatar
 
Join Date: Aug 2005
Location: The Bay Area
Posts: 2,699
Thanked 146 Times in 140 Posts
Originally Posted by razorlab View Post
I'm gonna pull an RSF and ask if you know what your fuel pressure looks like.
A broken clock is right twice a day lol
Biggiesacks is offline  
Reply With Quote
Old Jan 22, 2018, 08:52 AM
  #44  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
Originally Posted by Biggiesacks View Post
A broken clock is right twice a day lol
lol
4b11slayer is offline  
Reply With Quote
Old Jan 22, 2018, 09:27 AM
  #45  
Evolved Member
Thread Starter
 
4b11slayer's Avatar
 
Join Date: Nov 2015
Location: Santa Ana
Posts: 1,784
Thanked 82 Times in 82 Posts
If fuel pressure tests ok. Whats next guys?
4b11slayer is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Evo 8 stutters and goes lean above 20 psi.All of a sudden.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.