Airtrek Ecuflash issue - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

Airtrek Ecuflash issue

Reply

 
 
 
Old Apr 8, 2018, 02:17 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2017
Location: Zaandam
Posts: 6
Thanked 0 Times in 0 Posts
Airtrek Ecuflash issue

Hello guy's,

I own a Airtrek turbo-R from 2002
I have successfully obtained my ecu data it is 512K and is usable.
I used the definition from gregM.
the problem is that I am missing the shift maps and pressure maps values. they all are 0.0 in the cell structure.

Is this normal?

Best regards,
Jeroen
jero-neo is offline  
Reply With Quote
Old Apr 9, 2018, 03:12 PM
  #2  
Evolved Member
 
Join Date: Jun 2008
Location: Sydney
Posts: 806
Thanks: 0
Thanked 15 Times in 14 Posts
not normal
the axis address and the map address are likely to be wrong in the xml.
merlin.oz is offline  
Reply With Quote
The Following User Says Thank You to merlin.oz For This Useful Post:
jero-neo (Apr 11, 2018)
Old Apr 9, 2018, 10:02 PM
  #3  
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 441
Thanks: 0
Thanked 1 Time in 1 Post
Mine shows them fine, are you sure the rom you have is the same one the xml is for?

GregM is offline  
Reply With Quote
The Following User Says Thank You to GregM For This Useful Post:
jero-neo (Apr 11, 2018)
Old Apr 10, 2018, 12:20 AM
  #4  
Newbie
Thread Starter
 
Join Date: Sep 2017
Location: Zaandam
Posts: 6
Thanked 0 Times in 0 Posts
I have only changed the speedlimiter and compared the changes then uploaded the ecu. the car is acting normal. but I need to change some things in the shift timing.
This is what I got the first time I pulled the rom out off the vehicle.

Last edited by jero-neo; Apr 10, 2018 at 12:24 AM. Reason: missing info
jero-neo is offline  
Reply With Quote
Old Apr 11, 2018, 08:50 AM
  #5  
Newbie
Thread Starter
 
Join Date: Sep 2017
Location: Zaandam
Posts: 6
Thanked 0 Times in 0 Posts
I just take a good look at my first pull out of my ECU and is see the shift maps etc...(thank fully I made a copy of the fist read out).
strange thing is I have only changed the speed limiter and compared the data with the trek, then uploaded the rom data to the ECU.
if I read the data I read 0.00 in the cells of the AT but notice no changes in the shifting of the car.

If there are things mixed up GregM should have the same problem back in the days (I thought the ECU in every Airtrek from 2002 is exactly the same).

Jero.
jero-neo is offline  
Reply With Quote
Old Apr 11, 2018, 12:21 PM
  #6  
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 441
Thanks: 0
Thanked 1 Time in 1 Post
I've never seen anything like that before. I've only ever done the one pull from my ecu, I read it, make changes and save it and flash it. I don't pull it again to make changes, I just make changes to the saved one and reflash as its alot easier. Not that what you are doing would explain those values coming up.

I don't know if all are the same, but there are 3-4 roms for the Airtrek, so it pays to check.
GregM is offline  
Reply With Quote
Old Apr 16, 2018, 05:18 AM
  #7  
Newbie
Thread Starter
 
Join Date: Sep 2017
Location: Zaandam
Posts: 6
Thanked 0 Times in 0 Posts
Found the problem!
At first I have read out the ECU with the Read_evo9 method.
second made a copy of GregM his dev and changed the memmodel to SH7055.
third Forgot to remove the old dev out of the rommedata folder.
the first pull I did was 512kb large, changed my speedlimiter value uploaded this back in the ECU.
shut down my pc.
forth Booted up my pc did a read-out. and at that point ecuflash opened up the first unchanged dev from GregM with the memmodel SH7052
that is why I lost the AT settings.

so this was a well made mistake by myself

things are all good and clear now!


Now it is time to fine tune the car.

Best regards,

Jeroen
jero-neo is offline  
Reply With Quote
Old Apr 16, 2018, 12:03 PM
  #8  
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 441
Thanks: 0
Thanked 1 Time in 1 Post
Cool, good you got it sorted.
GregM is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.