EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

EvolutionM - Mitsubishi Lancer and Lancer Evolution Community (https://www.evolutionm.net/forums/)
-   Evo Engine / Turbo / Drivetrain (https://www.evolutionm.net/forums/evo-engine-turbo-drivetrain-22/)
-   -   Looking for all EVO 8, 9 people with 6 speed still. (https://www.evolutionm.net/forums/evo-engine-turbo-drivetrain/621273-looking-all-evo-8-9-people-6-speed-still.html)

milruner Jul 22, 2012 07:11 AM

Looking for all EVO 8, 9 people with 6 speed still.
 
What I'm trying to find out is who is the highest HP EVO 8 or 9 with a 6 speed trans still in the car. Wanting to see what's numbers your putting down, and are you having any problems with your trans at that power level? what are you doing to prevent any problems, hope the true 6 speed lovers will chime in, because I know there are people out there saying 6 speed is weak go with 5 speed, but I know there is some big number 6 speeds out there.

I have as of right now 348hp and 305tq. With the power I have in my EVO I have never once had a problem with my trans. Trying to find out more info, because I'm about to do a big build, and probably make power more along the lines 550+, and wanna still keep the 6 speed.
MIKE

MR. EVO MR Jul 22, 2012 07:33 AM

I was at 542whp on my 6 speed Fp Black.
It was to much, I'm now at 480whp 490wtq still 6 speed!

EvoIIIAj Jul 22, 2012 09:38 AM

My race gas tune is 382/377 VD. I haven't run into any problems yet, what is it that goes bad anyway?

milruner Jul 22, 2012 09:38 AM

Was the 542hp just to much for the trans, that you could tell, or was it just to much for you to handle? Thanks for the input.
MIKE

richdegrave Jul 22, 2012 09:41 AM

Mine is acting funny at only 320 on a mustang dyno power next is a 5 speed swap cause it won't be holding what's about to be thrown at it

milruner Jul 22, 2012 09:55 AM

They say the gears are weak in the trans, that why they can't handle much, but the fq400 still uses the 6 speed, so is there trans any different then ours, because It seems that, that trans can handle 400hp no problem.
MIKE

EvoIIIAj Jul 22, 2012 10:55 AM

That's what they say yeh, but what happens? Lock out of gears? Gears break?

Tanro Jul 22, 2012 02:12 PM

The problem is your trying to stuff an extra gear into the same amount of space. The gear sets are weaker.

http://www.teamrip.com/choosing_the_...utch_info.html

Look at the evo section for the relative torque limits of these transsmissions. You can probably run quite a bit over them as long as your not constantly beating on the car.

Edit:

Torque is what kills transmissions. Dumping the clutch like a fool, and shifting at high rpm a lot will kill a trans even at stock powerlevels. Slip the clutch when your launching, and don't wind every gear just because you can.

kanovic Jul 22, 2012 05:32 PM

355whp and im getting grinding in 3 and 4th pretty sure my synchros are about done so saving for a 5speed.

golgo13 Jul 22, 2012 06:00 PM

IIRC heat is what eventually does the fourth gear in. This is usually found with Evo MRs that participate in race events, auto-x and so on where the car doesn't have enough time to shake off the heat soak from continuous flogging.

I don't recall people having issues due to power under 500whp, but of course with anything once you go outside the realm of OEM spec it's a crap shoot.

RoMeIX Jul 22, 2012 06:25 PM


Originally Posted by MR. EVO MR (Post 10294748)
I was at 542whp on my 6 speed Fp Black.
It was to much, I'm now at 480whp 490wtq still 6 speed!

When you say "It was to much", do you mean it was too much for the transmission or just too much power in general?

RoMeIX Jul 22, 2012 06:28 PM


Originally Posted by kanovic (Post 10295492)
355whp and im getting grinding in 3 and 4th pretty sure my synchros are about done so saving for a 5speed.

I have the 5 speed and at about 30,000 miles it started grinding into 3rd and 5th. Turns out it was the synchros, which Mitsubishi covered under warranty.

uamafioz Jul 22, 2012 09:18 PM

My two 06 MR's needed the transmission rebuilt at 70k miles, none moded.

milruner Jul 23, 2012 04:47 AM

Bump, let's keep this alive anyone else?
MIKE

GTijoejoe Jul 23, 2012 07:35 AM

umm I'm at the power mods in my sig ~350 VD and it seems fine, stock clutch, auto-x this weekend, no concerns... but honestly I don't think I'm even approaching the concern level for this mission.

X2 on the heat concern.


All times are GMT -7. The time now is 09:51 PM.


© 2019 MH Sub I, LLC dba Internet Brands