No start/No crank issue - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Lancer Troubleshooting Get help with any troubleshooting problems you may have.

No start/No crank issue

Reply

 
 
 
Old Mar 12, 2018, 05:42 PM
  #1  
Newbie
Thread Starter
 
eatsleepEVO's Avatar
 
Join Date: Feb 2010
Location: San Antonio, Tx
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
No start/No crank issue

Need some help trying to diagnose a problem with my car.

I have a 2005 Lancer ES 5 speed with 167K miles. When I turn the ignition, the car doesnt crack nor hearing any clicking noise from the starter. What I do hear is blicking noise coming from the dashboard where the dash lights, radio, and clock all start blinking for about 5 seconds and then it stops. If I try to turn the key, it starts blinking again. Even when I try to jump start the car, car wont turn either. I checked my battery with a volt meter and it is reading 12.5v - 13v, also cleaned the terminals, so it cant be that either and battery is a little over a year old. Also checked the fuse box under the hood with no blown fuses.

I'm at a lost on what it could be...bad starter, bad alternator? Any help would be appreciated.
eatsleepEVO is offline  
Reply With Quote
Old Mar 13, 2018, 07:15 AM
  #2  
Newbie
Thread Starter
 
eatsleepEVO's Avatar
 
Join Date: Feb 2010
Location: San Antonio, Tx
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
BUMP.....190 views with no replies......................
eatsleepEVO is offline  
Reply With Quote
Old Mar 13, 2018, 07:21 AM
  #3  
Evolved Member
 
Biggiesacks's Avatar
 
Join Date: Aug 2005
Location: The Bay Area
Posts: 2,812
Thanked 158 Times in 152 Posts
what does the battery read while cranking?
Biggiesacks is offline  
Reply With Quote
Old Mar 13, 2018, 09:17 AM
  #4  
Newbie
Thread Starter
 
eatsleepEVO's Avatar
 
Join Date: Feb 2010
Location: San Antonio, Tx
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Biggiesacks View Post
what does the battery read while cranking?
I will check later on this evening. What is confusing is that Ive had a similar issue before where the car didnt want to start but you could hear the starter clicking. It ended up being just the terminals were corroded, so I cleaned them up and it started fine.

What has never happened is all the interior lights flashing when you turn the ignition and I dont hear the starter clicking
eatsleepEVO is offline  
Reply With Quote
Old Mar 13, 2018, 11:43 AM
  #5  
Evolved Member
 
Biggiesacks's Avatar
 
Join Date: Aug 2005
Location: The Bay Area
Posts: 2,812
Thanked 158 Times in 152 Posts
evos had problems with the actual ignition switch in the steering column. If your car has the same part it might be worth looking into that.
Biggiesacks is offline  
Reply With Quote
Old Mar 13, 2018, 04:38 PM
  #6  
Newbie
Thread Starter
 
eatsleepEVO's Avatar
 
Join Date: Feb 2010
Location: San Antonio, Tx
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
ended up being the alarm system that was preventing the car from starting. Turned the key to the on position and held the reset button that is close to the clutch pedal. I have the alarm horn disabled so that's why I didnt figure out at first. But the flashing and blink was the alarm going off. I hope this helps someone else in the future.
eatsleepEVO is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.