EvolutionM - Mitsubishi Lancer and Lancer Evolution Community - View Profile: mrfred

Notices

mrfred mrfred is offline

EvoM Guru

About Me

  • About mrfred
    Location
    Tri-Cities, WA // Portland, OR
    Vehicle
    Evo IX MR
  • Signature
    English Racing drop-in build :: Ported BBK-3B :: cardboard cold air box :: Amsoil cone filter :: ETS v2 LICP :: ETS 3.5" IC :: TiAl QRJ DV :: MIL.SPEC TB seals :: MAP Rev3 IM :: GSC R2 cams/springs :: ER ported head :: MAP Short Runner EM :: MAP O2 Eliminator DP :: MIL.SPEC 100 cps cat :: RRE Stealth Stainless :: Rewired Walbro 416 :: Wilson fuel rail :: ASNU1500s :: GM BCS :: SpoolinUp COP :: E85 :: self-tuned :: 4XX wtq/5XX whp at English Racing

    For sale
    RS trunk lid

Statistics

Total Posts
Visitor Messages
Total Likes
General Information
  • Last Activity: Mar 6, 2019 09:08 PM
  • Join Date: Mar 12, 2006

Friends

Showing Friends 1 to 5 of 5

Visitor Messages

Showing Visitor Messages 1 to 10 of 23
  1. ranz
    May 29, 2018 02:36 PM
    I have sent you a pvt msg.
  2. pnwapexsilver
    Dec 7, 2017 12:51 PM
    hey you located in tri cities?
  3. Jan 28, 2017 09:56 PM
    Hi EvoM Guru, can you help, Need some advise, I'm Azlan From Malaysia.

    My email : [email protected]

    My Car is Evo8 JDM, 3 Pin of ECU.
    Removed Maf and Replaced with 3Bar Haltech Map Sensor
    3 Inch Down Pipe
    Evo 9 Turbin with upgraded Billet Fin 25G
    Removed EGR
    Current Running 96531706_TephraV7_speed density
    Fuel using RON95

    Fuel Map and Ignition tuned and no issue

    Problem :
    No Immobilizer
    No Launch Control

    Have Tried :
    Enable Clucth Pedal Cuircuit , Result NOT OK
    Enable Immobilizer and copy all code , Result NOT OK
  4. Sep 3, 2016 10:51 AM
    Hello the one and only Mr. Fred! Please check your pms !
  5. Aug 11, 2016 09:42 AM
    To the one and only, mrfred:
    I would love your help with getting Tephra v7 to work on my EVO 8. I have followed all the instructions:
    https://www.evolutionm.net/forums/ev...hramod-v7.html

    including those given on the official TephraMod v7 thread, and the car runs horribly. I am confused as I am simply using my stock EVO timings/ fuel/ boost/ MAF/ etc. (well, it has been tuned from English Racing) and the car hardly drives. Any help would be very much appreciated. My detailed question is in the following thread:
    https://www.evolutionm.net/forums/ec...ur-answer.html

    Best,
    -Shane
  6. gvr4v
    Jul 13, 2016 07:11 PM
    mrfred,
    I IM'd you. Can you check, please
  7. Evo MR IX Fritz
    May 15, 2016 06:27 PM
    Hey bud I just added you on fb. Jm Fritz
  8. Apr 18, 2016 09:11 AM
    Hey Mrfrrd,

    I was hoping you could help me get the XML coding to upgrade my Evo 9 rom to accept the JDM/Evo 10 map sensor? Your post below has the definitions blank/missing.

    Thank you so much for your help!

    https://www.evolutionm.net/forums/ec...tructions.html
  9. SmurfZilla
    Mar 16, 2016 08:54 PM
    mrfred can you clear your inbox or IM me. I have something I need to run by you.
  10. mines5
    Oct 24, 2015 11:44 PM
    Hi Mr Fred,

    sorry to bother you again. As per your advice, i am going through your ISCV disassembly thread in order to have a better understanding of the system.

    Can you suggest me a few threads that could help me in understanding and tuning the large injectors . why there response is variable at idle and cruise?


    A little assistance is all that i require. if u want i can send you the logs o your email.

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.