Can't flash or read the ROM from your ECU - Start Here! - Page 4 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

Can't flash or read the ROM from your ECU - Start Here!

Reply

 
 
 
Old Aug 24, 2013, 06:22 PM
  #46  
Newbie
 
Join Date: Jul 2010
Location: Vernon BC
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
can anybody make sense of this?



[19:11:37.641] -- connecting to kernel --
[19:11:37.641] kernel get version
[19:11:37.647] kernel version is : OpenECU Mitsubishi M32186 CAN Kernel V1.09
[19:11:37.647] reading kernel comm buffer size
[19:11:37.651] comm buffer size set to 1024
[19:11:37.651] reading kernel flash buffer size
[19:11:37.656] flash buffer size set to 4096
[19:11:37.669] -- dumping ECU memory --
[19:11:37.681] kernel read area: addr: 00000000 len: 0400
[19:11:37.726] invalid / no kernel response to read
[19:11:37.726] kernel read area: addr: 00000000 len: 0400
[19:11:37.772] invalid / no kernel response to read
[19:11:37.772] kernel read area: addr: 00000000 len: 0400
[19:11:37.817] invalid / no kernel response to read
[19:11:37.817] ECU memory read failure.
[19:11:37.817] can't read image.
[19:11:37.817] -- unloading kernel --
[19:11:37.817] kernel reset
[19:11:39.926] -- unlocking ECU --
[19:11:39.926] starting session...
[19:11:39.934] requesting seed...
[19:11:39.943] sending key...
[19:11:41.282] -- resetting ECU --
[19:11:42.704] -- reading ECU ID --
[19:11:42.832] ECU HW part number : xxxxx
[19:11:42.852] ECU SW part number : xxxxx
[19:11:42.867] VIN : xxxxxxx
[19:11:42.887] interface close
[19:11:42.903] interface close



[19:12:33.657] using metadata XML ID read_mitsum32186f8can from file C:/Program Files (x86)/OpenECU/EcuFlash/rommetadata/read templates/read_mitsum32186f8can.xml
[19:12:33.686] J2534 API Version: 04.04
[19:12:33.686] J2534 DLL Version: 1.00.3721 Jan 9 2013 17:24:59
[19:12:33.686] Device Firmware Version: 1.12.3688
[19:12:33.686] Device Serial Number: xxxxx
[19:12:36.320] -- loading kernel --
[19:12:36.320] -- connecting to kernel --
[19:12:36.320] kernel get version
[19:12:36.652] ECU HW part number : xxxx
[19:12:36.672] ECU SW part number : xxxxxxxxx
[19:12:36.687] VIN : xxxxxxxx
[19:12:36.704] -- unlocking ECU --
[19:12:36.704] starting session...
[19:12:37.035] requesting seed...
[19:12:42.037] interface close
[19:12:43.064] interface close

Last edited by myparkerbros; Aug 24, 2013 at 06:27 PM.
myparkerbros is offline  
Reply With Quote
Old Oct 19, 2013, 11:32 AM
  #47  
Evolved Member
iTrader: (14)
 
Frew's Avatar
 
Join Date: Oct 2010
Location: Pittsburgh
Posts: 583
Thanks: 0
Thanked 0 Times in 0 Posts
This is the issue we are having, I can pull the current rom and save it but I cannot flash a new rom on.

[13:39:24.175] J2534 API Version: 04.04
[13:39:24.175] J2534 DLL Version: 1.00.3719 Dec 28 2012 23:38:48
[13:39:24.175] Device Firmware Version: 1.12.3688
[13:39:24.175] Device Serial Number: TAwaIK*d
[13:39:26.865] sending init sequence 1 (0001)
[13:39:27.910] got 0x05 response
[13:39:27.910] sending init sequence 2
[13:39:27.910] got 0x1B response
[13:39:27.910] sending init sequence 3
[13:39:28.284] entering bootloader
[13:39:28.300] sending kernel size (0)
[13:39:28.300] sending kernel load address (0xFFFF6000)
[13:39:28.316] uploading kernel
[13:39:28.316] verifying kernel checksum response
[13:39:28.316] kernel valid
[13:39:28.316] sending init sequence 2
[13:39:30.328] interface close
Frew is offline  
Reply With Quote
Old Dec 20, 2013, 05:33 AM
  #48  
Newbie
 
Join Date: Dec 2013
Location: Thailand
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Help! my ECU is locked because i modified my flash ROM, cant rewrite ROM or start car

How can i fix this problem? I just need to get my ROM unlocked so i can rewrite or change my ROM and to be able get my car started and running again.
PLEASE help i am desperate.
Nomyen is offline  
Reply With Quote
Old Jan 24, 2014, 09:18 PM
  #49  
Newbie
iTrader: (2)
 
jbuhrman's Avatar
 
Join Date: Jan 2009
Location: PDX/Vancouver
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
So I was trying to read from the ECU tonite and here is what ECUflash V1.44 was saying:
[21:14:50.525] EcuFlash Version 1.44.3721
[21:14:50.525] OS Version Windows (unknown version)
[21:14:50.525] Qt Version 4.8.0
[21:14:50.556] 63 memory models read.
[21:14:50.556] scanning for metadata models in C:/Windows/EcuFlash/rommetadata/mitsubishi
[21:14:50.697] 159 ROM metadata models scanned.
[21:14:50.697] checksum module "subarudbw" loaded.
[21:14:50.697] checksum module "mitsucan" loaded.
[21:14:50.697] checksum module "mitsuh8" loaded.
[21:14:50.697] patch module "Subaru CAN Enhanced RAM Parameter Logging" loaded.
[21:14:50.697] patch module "Mitsu CAN RAM Parameter Logging" loaded.
[21:14:50.697] flashing tool "wrx02" loaded.
[21:14:50.712] flashing tool "wrx04" loaded.
[21:14:50.712] flashing tool "sti04" loaded.
[21:14:50.712] flashing tool "sti05" loaded.
[21:14:50.712] flashing tool "mitsukernel" loaded.
[21:14:50.712] flashing tool "mitsukernelocp" loaded.
[21:14:50.712] flashing tool "mitsubootloader" loaded.
[21:14:50.712] flashing tool "shbootmode" loaded.
[21:14:50.712] flashing tool "shaudmode" loaded.
[21:14:50.728] flashing tool "subarucan" loaded.
[21:14:50.728] flashing tool "subarucand" loaded.
[21:14:50.728] flashing tool "mitsucan" loaded.
[21:14:50.806] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.806] interface close
[21:14:50.853] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.853] interface close
[21:14:50.900] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.900] interface close

I can read downloaded ROMS just fine with no issue's but I cannot read the ECU in the car. I have 12.4V with the key on(on the charger) verified by evoscan. Any advice??

Using a 1.3U cable
jbuhrman is offline  
Reply With Quote
Old Jan 26, 2014, 01:14 PM
  #50  
Newbie
 
Wille's Avatar
 
Join Date: Jan 2014
Location: Sweden, Stockholm
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
I have a beginner's question, when I start ESUFLASH (first time) and starts a box will apper where I should choose my car. My car (Lancer Ralliart 2010) is not in the list, what do I do? Running EcuFlash version 1.43.3150.

I have downloaded the ROM files from golden evo and put dem in the lancer folder.

Last edited by Wille; Jan 26, 2014 at 01:22 PM.
Wille is offline  
Reply With Quote
Old Jan 31, 2014, 03:54 PM
  #51  
Newbie
 
The Nothing's Avatar
 
Join Date: Apr 2007
Location: florida
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by jbuhrman View Post
So I was trying to read from the ECU tonite and here is what ECUflash V1.44 was saying:
[21:14:50.525] EcuFlash Version 1.44.3721
[21:14:50.525] OS Version Windows (unknown version)
[21:14:50.525] Qt Version 4.8.0
[21:14:50.556] 63 memory models read.
[21:14:50.556] scanning for metadata models in C:/Windows/EcuFlash/rommetadata/mitsubishi
[21:14:50.697] 159 ROM metadata models scanned.
[21:14:50.697] checksum module "subarudbw" loaded.
[21:14:50.697] checksum module "mitsucan" loaded.
[21:14:50.697] checksum module "mitsuh8" loaded.
[21:14:50.697] patch module "Subaru CAN Enhanced RAM Parameter Logging" loaded.
[21:14:50.697] patch module "Mitsu CAN RAM Parameter Logging" loaded.
[21:14:50.697] flashing tool "wrx02" loaded.
[21:14:50.712] flashing tool "wrx04" loaded.
[21:14:50.712] flashing tool "sti04" loaded.
[21:14:50.712] flashing tool "sti05" loaded.
[21:14:50.712] flashing tool "mitsukernel" loaded.
[21:14:50.712] flashing tool "mitsukernelocp" loaded.
[21:14:50.712] flashing tool "mitsubootloader" loaded.
[21:14:50.712] flashing tool "shbootmode" loaded.
[21:14:50.712] flashing tool "shaudmode" loaded.
[21:14:50.728] flashing tool "subarucan" loaded.
[21:14:50.728] flashing tool "subarucand" loaded.
[21:14:50.728] flashing tool "mitsucan" loaded.
[21:14:50.806] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.806] interface close
[21:14:50.853] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.853] interface close
[21:14:50.900] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.900] interface close

I can read downloaded ROMS just fine with no issue's but I cannot read the ECU in the car. I have 12.4V with the key on(on the charger) verified by evoscan. Any advice??

Using a 1.3U cable
Im having the same issue also. Im trying to read my cars ecu rom. yet everytime it open ECU flash i get the same error. i have well over 12.6v that is suggested.

Last edited by The Nothing; Feb 1, 2014 at 12:06 PM.
The Nothing is offline  
Reply With Quote
Old Apr 3, 2014, 01:31 PM
  #52  
Evolving Member
iTrader: (7)
 
flippymcbean's Avatar
 
Join Date: Apr 2013
Location: Beaufort, SC
Posts: 296
Thanks: 0
Thanked 0 Times in 0 Posts
I'm getting the samething. Anybody figure it out?
flippymcbean is offline  
Reply With Quote
Old Apr 25, 2014, 09:16 AM
  #53  
Newbie
 
Join Date: Dec 2012
Location: Sweden
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
I cant read or flash or log, seems like my OBD2 port is not working, i have tried one of those ODB2 connectors that you can try on ebay etc and it work's in another car but not in my E8 USDM. I have checked my battery and its fine 12.54V and its like 2 months old.
I also checked the fuse box under the steering thats been said to have affects but haven't found any bad fuse, anyone know exactly witch one it is?
I got a Tactrix 1.3u cable.

So i don't know what to look for, any suggestions would be really welcome since i am really stuck. I guess they broke it when they stole my car last year, so i would really appreciate any tips!

Last edited by basn; Apr 25, 2014 at 09:30 AM.
basn is offline  
Reply With Quote
Old May 1, 2014, 06:41 PM
  #54  
Evolving Member
iTrader: (1)
 
Joshthree6three's Avatar
 
Join Date: May 2011
Location: Rochester, NY
Posts: 176
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by jbuhrman View Post
So I was trying to read from the ECU tonite and here is what ECUflash V1.44 was saying:
[21:14:50.525] EcuFlash Version 1.44.3721
[21:14:50.525] OS Version Windows (unknown version)
[21:14:50.525] Qt Version 4.8.0
[21:14:50.556] 63 memory models read.
[21:14:50.556] scanning for metadata models in C:/Windows/EcuFlash/rommetadata/mitsubishi
[21:14:50.697] 159 ROM metadata models scanned.
[21:14:50.697] checksum module "subarudbw" loaded.
[21:14:50.697] checksum module "mitsucan" loaded.
[21:14:50.697] checksum module "mitsuh8" loaded.
[21:14:50.697] patch module "Subaru CAN Enhanced RAM Parameter Logging" loaded.
[21:14:50.697] patch module "Mitsu CAN RAM Parameter Logging" loaded.
[21:14:50.697] flashing tool "wrx02" loaded.
[21:14:50.712] flashing tool "wrx04" loaded.
[21:14:50.712] flashing tool "sti04" loaded.
[21:14:50.712] flashing tool "sti05" loaded.
[21:14:50.712] flashing tool "mitsukernel" loaded.
[21:14:50.712] flashing tool "mitsukernelocp" loaded.
[21:14:50.712] flashing tool "mitsubootloader" loaded.
[21:14:50.712] flashing tool "shbootmode" loaded.
[21:14:50.712] flashing tool "shaudmode" loaded.
[21:14:50.728] flashing tool "subarucan" loaded.
[21:14:50.728] flashing tool "subarucand" loaded.
[21:14:50.728] flashing tool "mitsucan" loaded.
[21:14:50.806] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.806] interface close
[21:14:50.853] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.853] interface close
[21:14:50.900] Using interface OpenPort 1.3 Universal TX27CvWqe42135d5da842c33819006c601646bf4e9099d38
[21:14:50.900] interface close

I can read downloaded ROMS just fine with no issue's but I cannot read the ECU in the car. I have 12.4V with the key on(on the charger) verified by evoscan. Any advice??

Using a 1.3U cable
Originally Posted by The Nothing View Post
Im having the same issue also. Im trying to read my cars ecu rom. yet everytime it open ECU flash i get the same error. i have well over 12.6v that is suggested.


I am having a similar issue. I can log data with EVOScan but can not connect to ECU. I have battery voltage at 12.2, hooked up the jumper cables to my jeep, same issue. Started the car with my AEM ran the car to get some coolant temperature movement. Pulled out the AEM, put back in the stock ecu and still will not connect.

Will be throwing in a full size battery in tomorrow after work. Hoping its a battery voltage issue.
Joshthree6three is offline  
Reply With Quote
Old May 1, 2014, 06:43 PM
  #55  
Evolving Member
iTrader: (1)
 
Joshthree6three's Avatar
 
Join Date: May 2011
Location: Rochester, NY
Posts: 176
Thanks: 0
Thanked 1 Time in 1 Post
I am using 1.3 cable and EcuFlash Version 1.44.3721. EvoScan version is 2.9
Joshthree6three is offline  
Reply With Quote
Old Aug 12, 2014, 04:55 PM
  #56  
Evolving Member
iTrader: (7)
 
flippymcbean's Avatar
 
Join Date: Apr 2013
Location: Beaufort, SC
Posts: 296
Thanks: 0
Thanked 0 Times in 0 Posts
I having an issue. Ecu flash can't/won't read my ECU. But EvOscan can log and read my computer. Is there something I'm doing wrong? I did a test write, and I even changed my target rpm(not much) but ecu flash is a no go for me. Any thoughts?
flippymcbean is offline  
Reply With Quote
Old Aug 25, 2014, 05:37 AM
  #57  
Newbie
 
Join Date: Aug 2014
Location: Cyprus
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Might be me being dump but I downloaded my rom, changed the limiter and there is no option to write the rom back. If I load the tephra rom in ecuflash I DO have the option to write. Any clues people?
Evo_newb is offline  
Reply With Quote
Old Aug 25, 2014, 06:51 AM
  #58  
Newbie
 
Join Date: Aug 2014
Location: Cyprus
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Btw this is Rom id 93660005 which it has a def file in the ecuflash rommetadata folder
Evo_newb is offline  
Reply With Quote
Old Aug 25, 2014, 07:37 AM
  #59  
Newbie
 
Join Date: Aug 2014
Location: Cyprus
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Now resolved - thanks
Evo_newb is offline  
Reply With Quote
Old Oct 8, 2014, 09:11 AM
  #60  
Newbie
 
amiturbo's Avatar
 
Join Date: Sep 2014
Location: tampa
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
thank goodness for this thread
amiturbo is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Can't flash or read the ROM from your ECU - Start Here!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.