Flashing an Airtrek Turbo - Page 3 - evolutionm.net



Flashing an Airtrek Turbo

Reply
 
 
 
Thread Tools Search this Thread
Old Dec 20, 2012, 02:24 PM   #31
Evolving Member
Thread Starter
 
limaynard's Avatar
 
Join Date: Nov 2012
Location: Sydney
Posts: 277
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Airtrek Turbo R 2002

if you need any help from me then let me know...
Offline
 
Reply With Quote
Old Dec 21, 2012, 12:38 PM   #32
Newbie
 
Join Date: Dec 2012
Location: gloucester
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: airtrek

airtrek

hi greg how you hope all is good
i down loaded the file you sent pasted it over the file in ecuflash rommetadate mitsubishi airtrek over write the origenal file started ecuflash done a read of the airtrek and can not view the file at all and the file size is still 256 kb
do you think it could be corrupted file and could you send it to [email protected]
also when the file is loaded to ecuflah i take it i can do everything from there and dont need any other softwear as on the forum the guy siad he maid hes own read file any help would be great thanks and sorry to be a pain thanks

also any help on other read write softwear would help too thanks
Offline
 
Reply With Quote
Old Dec 29, 2012, 01:18 PM   #33
Evolving Member
Thread Starter
 
limaynard's Avatar
 
Join Date: Nov 2012
Location: Sydney
Posts: 277
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Airtrek Turbo R 2002

Quote:
Originally Posted by fred sampson View Post
hi greg how you hope all is good
i down loaded the file you sent pasted it over the file in ecuflash rommetadate mitsubishi airtrek over write the origenal file started ecuflash done a read of the airtrek and can not view the file at all and the file size is still 256 kb
do you think it could be corrupted file and could you send it to [email protected]
also when the file is loaded to ecuflah i take it i can do everything from there and dont need any other softwear as on the forum the guy siad he maid hes own read file any help would be great thanks and sorry to be a pain thanks

also any help on other read write softwear would help too thanks
Hi, sounds like you need the read file. Let me email that to you with some instructions. Greg's metadata file will work fine if you read it the correct way.
Offline
 
Reply With Quote
Old Jan 9, 2013, 09:21 AM   #34
Newbie
 
jasonksng's Avatar
 
Join Date: Mar 2012
Location: Malaysia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi AirTrek Turbo

Hi All You AirTrek Guys,

I'm Jason from Malaysia. Got a 2005 JDM Airtrek Turbo. I've seen GregM and Fred from the old AirTrekker forum (now defunct).

I just started trying to reflash my car's ECU. Got myself a Openport 1.3U cable off Limitless Designs (the makers of EVOScan) in NZ. The funny thing is that I can read my ECU's data perfectly, but I can't seem to flash back into my car's ECU.

I started trying to flash my ecu using ECUFlash 1.43. No luck. I downgraded to 1.42, and still no luck. I got GregM's .xml file copied into the Rommetadata folder. So, I can read all my ECU's data perfectly, with all the bells and whistles.

What has happened is that everytime I try to "Write to ECU" or "Test Write to ECU" or "Compare to ECU", I get the error message window. The ECUFlash logs say that there is "Preamble 1 Error".

Anybody encounter this problem before? Please help. Thanks.
My e-mail is [email protected]
Offline
 
Reply With Quote
Old Jan 9, 2013, 10:41 AM   #35
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Ford Territory

Sounds like the reflash connector isn't plugged in. There is a white plug beside the other one, think it has 2 wires, you connect the reflash wire to one of those. I can't remember which one, will take a look at mine later today and confirm which wire it is.
Offline
 
Reply With Quote
Old Jan 9, 2013, 08:39 PM   #36
Newbie
 
jasonksng's Avatar
 
Join Date: Mar 2012
Location: Malaysia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi AirTrek Turbo

Hi Greg,

Thanks for your reply. Haven't spoken to you since the Airtrekker forum was shut down. Its a great pity that that bunch did not renew the website / domain, even after some of us gave him some small donations to the Airtrekker club.

Thanks also for your created xml defination. I managed to download it from the Airtrekker forum a while back (before the website went down). I have been using your defination for some time now, but so far, I can only read the data from my ECU. All the parameters appear perfectly. High-Octane Fuel N,1,2, High-Octane Fuel 3,4,5, Low-Octane Ignition N,1,2, Low Octane Ignition 3,4,5, etc. It's all there. Thanks a bunch. I figure that you had spend a whole ****load of time just to create that defination. Great work.

I actually bought the Evoscan 1.3U cable off Limitless Designs (NZ). I spliced the green wire below my steering column with a "spade connector" for easy connection to the 1.3U's "single wire connector socket". Without connecting this wire to the 1.3U's wire, we cannot even read from the ECU via ECUFlash. Correct?

Anyway, last night, I tried to flash using another laptop running Win XP, and still no luck. Same results. Able to read perfectly, unable to write, test write and compare.

BTW, my car's ECU has been flashed before here in Malaysia. Any possibility that there is some sort of "lock" placed inside my ECU's programming by the previous tuner? I have tried running ActiveMatrix's ECU Unlocker (kept running together with ECUFlash), but there is no difference.

Any ideas? Thanks.

My email is [email protected]
Offline
 
Reply With Quote
Old Jan 9, 2013, 10:02 PM   #37
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Ford Territory

The green wire doesn't need to be connected to read, only reflash. I'd check the connection, as it sounds like the reflash wire isn't connected properly.

If the ecu was locked, as long as ecu unlocker is running prior to opening ecuflash, it should work, although I've only used ecu unlocker once when i had a flash fail half way through.

I have a better definition file since those days, have abit more stuff, but thats available on donation only. As you said, there was alot of time and money as well to get the definition file where it is today. The one you have only cost time.
Offline
 
Reply With Quote
Old Jan 9, 2013, 10:08 PM   #38
Newbie
 
jasonksng's Avatar
 
Join Date: Mar 2012
Location: Malaysia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi AirTrek Turbo

Offline
 
Reply With Quote
Old Jan 9, 2013, 10:14 PM   #39
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Ford Territory

Email sent.
Offline
 
Reply With Quote
Old Jan 10, 2013, 01:32 AM   #40
Newbie
 
Join Date: Apr 2011
Location: new zealand
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2003 Airtrek Turbo

One other thing you can check is open Greg's XML and check the section :-

<flashmethod>mitsukernel</flashmethod>

I had to modify the flash method to the following to get the reflashing to work with ECUFLASH to:- <flashmethod>mitsukernelocp</flashmethod>

Cheers,
Russell
Offline
 
Reply With Quote
Old Jan 10, 2013, 03:21 AM   #41
Evolving Member
Thread Starter
 
limaynard's Avatar
 
Join Date: Nov 2012
Location: Sydney
Posts: 277
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Airtrek Turbo R 2002

it seems like the flash wire connection. If you try it without the wire connected, do you get the same error?

I am using the Openport 2 and that works fine although i initially had problems due to a poor connection.
Offline
 
Reply With Quote
Old Jan 10, 2013, 10:54 AM   #42
Evolving Member
iTrader: (1)
 
GregM's Avatar
 
Join Date: Aug 2009
Location: New Zealand
Posts: 413
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Ford Territory

Looks like I need to make a change to my xml, I must have screwed that up over the years.
Offline
 
Reply With Quote
Old Jan 12, 2013, 06:21 PM   #43
Newbie
 
Join Date: Mar 2004
Location: Dominica
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2008 Outlander J, 1989 Galant VR4, Evo 7 RS

Found on a few airtreks i've reflashed that the AFRs are overly rich.

I really need to look into getting some of the tephra stuff ported over to the airtrek/gta roms
Offline
 
Reply With Quote
Old Jan 14, 2013, 04:55 AM   #44
Newbie
 
jasonksng's Avatar
 
Join Date: Mar 2012
Location: Malaysia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi AirTrek Turbo

Hi guys,

Sorry, I have not been checking into this forum since last week.

Thanks Greg for your updated .xml. I haven't had time to try it our yet though. Got caught up with work, and not enough personal time to scoot over to the workshop to try it out in my Trek.

Thanks Russellc2 for your suggestion. I already had Mitsukernelocp running and also Mitsukernel running. With Mitsukernel, I can't even read from ECU. When set with Mitsukernelocp, read from ECU is fine, but still cannot write or compare or test-write to ECU.

Hey Scientist, nice to see you here too. Haven't seen you since Airtrekker forum went down. Great to see you here too.

Thanks.
Offline
 
Reply With Quote
Old Jan 15, 2013, 09:12 AM   #45
Newbie
 
jasonksng's Avatar
 
Join Date: Mar 2012
Location: Malaysia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mitsubishi AirTrek Turbo

Hi Everyone,

Just wanted to share with everyone who is encountering problems with reflashing AirTrek Turbo ECUs with ECUFlash. I had the opportunity to reflash successfully two different Airtrek Turbos today.

First AirTrek Turbo was a 2002/2003 JDM. To successfully read and write from ECU, please use the EVO 7-8 method. Also, before reading, please check that the .xml has been set with Flashmethod "mitsukernel" and the Memory Model is "SH7052". Also, do get a decent .xml from GregM, and you'll get to adjust a whole load of functions of your ECU.

Second AirTrek Turbo was a 2004/2005 JDM. To successfully read and write from ECU, please use the EVO 9 / Eclipse AT method. As usual, you would need to ensure that .xml has been set with Flashmethod "mitsukernelocp" and the Memory Model is "SH7055". Again, a good definition is available from GregM.

If anyone has more to add, please feel free to add-on to this knowledge base. Thanks.
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Airtrek ecuflash defs jarjar1977 EcuFlash 1 May 9, 2016 03:59 AM
Airtrek ecuflash defs jarjar1977 General Engine Management / Tuning Forum 0 May 9, 2016 01:40 AM
new airtrek owner airtrek365 Evo Engine / Turbo / Drivetrain 0 Jan 7, 2016 04:40 PM
My Wife's Airtrek Turbo upgrade path SX200 Other Mitsubishi vehicles 5 Dec 30, 2015 01:56 AM
Help needed please, Converting Airtrek to MPH djcontrol. General Engine Management / Tuning Forum 1 May 27, 2015 04:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:08 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send