How to Eliminate "Rev-Hang" on the 05+ EVO 8/9s - Page 3 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



How to Eliminate "Rev-Hang" on the 05+ EVO 8/9s

Reply
 
 
 
Thread Tools Search this Thread
Old Jul 17, 2013, 07:07 PM   #31
Evolved Member
iTrader: (11)
 
Blitz's Avatar
 
Join Date: Jan 2007
Location: Earth
Posts: 1,202
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: CT9A

Figured out both questions. Reinstalled ECU flash /Tephra and can see tables fine now. And when you edit Decel Fuel Cut Delay tables the ISCV Demand TPS Adder tables change automatically. Now to go try this. Thanks!
Offline
 
Reply With Quote
Old Jul 17, 2013, 08:28 PM   #32
Evolved Member
iTrader: (11)
 
Blitz's Avatar
 
Join Date: Jan 2007
Location: Earth
Posts: 1,202
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: CT9A

My rev hang is 100% gone. Can't believe it. Just this morning I was thinking if I can't make it go away I'll sell the car and get a GT-R or something someday. Was totally sucking the fun out of driving a manual.

Jay I sent $10 your way on PayPal. Get yourself a six pack on me.
Offline
 
Reply With Quote
Old Jul 17, 2013, 10:18 PM   #33
Former Sponsor
Thread Starter
iTrader: (12)
 
Join Date: Jun 2005
Location: Chico, CA (Nor-Cal)
Posts: 2,382
Thanks: 0
Thanked 3 Times in 3 Posts

Drives: WW 04 RS, 330i, AW 04 STI (sold), 2 EVOs (sold)

^ Thanks. Glad it helped you out.
Offline
 
Reply With Quote
Old Jul 17, 2013, 11:12 PM   #34
Evolving Member
iTrader: (25)
 
evobros's Avatar
 
Join Date: Sep 2008
Location: CA, 90303
Posts: 455
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 05 RR RS

Quote:
Originally Posted by evobros View Post
I'm having this same problem but my car is stock with stock tune. Any ideas?
Anyone???
Offline
 
Reply With Quote
Old Jul 18, 2013, 08:22 AM   #35
Evolved Member
iTrader: (3)
 
fireroasted's Avatar
 
Join Date: Apr 2008
Location: CA
Posts: 860
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: USDM Evo 9 MR

Quote:
Originally Posted by evobros View Post
Anyone???
If you are looking for a cause of the type of behavior described, the engine accelerating off throttle, consider what might be happening to make it accelerate. One factor is that it's behaving as though you have your foot on the gas still, correct? This is essentially air is getting through the intake as if the throttle plate is still open. This path of thinking is what the code fixes address, but it could also be air getting in after the throttle plate. Any super en leaning condition will make the motor accel with the clutch depressed (no resistance on the motor).

Check for boost leaks after the TB. All those tiny ERG hoses and fittings, can leak a little bit and you will still drive relatively fine with boost pressure but they will leak in vacuum as well. Off throttle after a big pull creates a lot of sudden vacuum which will pull in air for a few seconds enough to rev up an engine that is not connected to the driveline.

Last edited by fireroasted; Jul 18, 2013 at 05:41 PM. Reason: grammer
Offline
 
Reply With Quote
Old Jul 18, 2013, 05:38 PM   #36
Evolving Member
iTrader: (1)
 
CRONZ305's Avatar
 
Join Date: Jan 2011
Location: Oceanside, CA
Posts: 136
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: GG 2006 Evo IX MR

Oh my gawd thank you!!!!
Offline
 
Reply With Quote
Old Jul 28, 2013, 10:48 AM   #37
Evolving Member
iTrader: (15)
 
Join Date: Oct 2010
Location: L.I. New York
Posts: 402
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2005 EVO VIII

anyone have the definitions for
94170715

thanks
Offline
 
Reply With Quote
Old Jul 28, 2013, 10:50 AM   #38
Former Sponsor
Thread Starter
iTrader: (12)
 
Join Date: Jun 2005
Location: Chico, CA (Nor-Cal)
Posts: 2,382
Thanks: 0
Thanked 3 Times in 3 Posts

Drives: WW 04 RS, 330i, AW 04 STI (sold), 2 EVOs (sold)

Quote:
Originally Posted by catman78 View Post
anyone have the definitions for
94170715

thanks
9417 doesnt have the rev hang, so this isnt needed.
Offline
 
Reply With Quote
Old May 26, 2015, 03:58 AM   #39
Newbie
 
Join Date: Feb 2015
Location: Moscow
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Evo IX

Hello everyone!
How i can correctly resolve problem (rev hang) on my 88580714 rom?

In my 88580714 i dont see tables from this guide

http://2.firepic.org/2/images/2015-0...og56zv8y9b.png
thats all what i have

Maybe exist custom XML definitions with those tables (i searched... but with no result )

if EDM roms don't have solution, can i use USDM rom on my car?

Anybody know "true way" for fix rev hang.. for EDM roms

Thank for answer!

Last edited by Pyatka-ubiyca; May 26, 2015 at 05:13 AM.
Offline
 
Reply With Quote
Old May 28, 2015, 12:00 AM   #40
Former Sponsor
Thread Starter
iTrader: (12)
 
Join Date: Jun 2005
Location: Chico, CA (Nor-Cal)
Posts: 2,382
Thanks: 0
Thanked 3 Times in 3 Posts

Drives: WW 04 RS, 330i, AW 04 STI (sold), 2 EVOs (sold)

Quote:
Originally Posted by Pyatka-ubiyca View Post
Hello everyone!
How i can correctly resolve problem (rev hang) on my 88580714 rom?

In my 88580714 i dont see tables from this guide

http://2.firepic.org/2/images/2015-0...og56zv8y9b.png
thats all what i have

Maybe exist custom XML definitions with those tables (i searched... but with no result )

if EDM roms don't have solution, can i use USDM rom on my car?

Anybody know "true way" for fix rev hang.. for EDM roms

Thank for answer!
You would have to find those tables for that ROM. If you search around, you can probably find them.
Offline
 
Reply With Quote
Old Oct 27, 2015, 06:56 PM   #41
Newbie
iTrader: (2)
 
Join Date: Jun 2007
Location: napa
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 08 Evo X GSR

What tables would I adjust to fix this for an Evo X?
Offline
 
Reply With Quote
Old Oct 31, 2015, 06:06 AM   #42
Registered User
 
Join Date: Jan 2014
Location: ny
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: gsx

Quote:
Originally Posted by imdrax View Post
What tables would I adjust to fix this for an Evo X?
Throttle tables...
Offline
 
Reply With Quote
Old Jul 10, 2017, 02:04 PM   #43
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post

Drives: 04 WRX wagon dd, 06 evo ix and 88 4g63 Conquest

My solution

Mine felt like it stayed where it was when I lifted to shift, tried some different things but the fact it felt as something was pushing or pulling on throttle plate disturbed me. So I added a spring from throttle arm to the strut tower brace (temporary nd better mounting solution) and it drives awesome now. Had car for awhile and thought throttle felt light the whole time. Just my .2
Offline
 
Reply With Quote
Old Jul 10, 2017, 02:39 PM   #44
EvoM Moderator
iTrader: (26)
 
kyoo's Avatar
 
Join Date: May 2006
Location: US
Posts: 6,511
Thanked 34 Times in 34 Posts

Drives: IX

Quote:
Originally Posted by 06_SSL View Post
Mine felt like it stayed where it was when I lifted to shift, tried some different things but the fact it felt as something was pushing or pulling on throttle plate disturbed me. So I added a spring from throttle arm to the strut tower brace (temporary nd better mounting solution) and it drives awesome now. Had car for awhile and thought throttle felt light the whole time. Just my .2
pic?
Offline
 
Reply With Quote
Old Jul 10, 2017, 04:52 PM   #45
Newbie
 
06_SSL's Avatar
 
Join Date: Jun 2015
Location: swpa
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post

Drives: 04 WRX wagon dd, 06 evo ix and 88 4g63 Conquest

Pics


Ugly I know, but it sure snaps the throttle closed. That's why I need a better way to mount. But you get the idea
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stop your Car Stalling from Clutch in! simple_lancer EcuFlash 73 Aug 12, 2017 05:26 PM
psi based boost control tephra Evo X Engine Management / Tuning Forums 151 Jun 18, 2017 03:22 PM
Start-up Fuel and ISCV Tables Dynotech Tuning EcuFlash 80 Sep 20, 2016 01:30 PM
ISCV control system disassembly mrfred EcuFlash 399 Jul 29, 2016 07:02 PM
*Better* fix for P0300 tephra Evo X Engine Management / Tuning Forums 8 May 16, 2016 09:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 03:56 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: