Highbeams wont stay on?!?!? - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo Electrical / Audio / Security Discuss electrical systems, audio system upgrades, or alarm configurations.

Highbeams wont stay on?!?!?

 
Old Nov 20, 2018, 01:17 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2016
Location: CA
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Highbeams wont stay on?!?!?

Hey what's up everyone I have a 2005 evo 8 with some goodies but when I baught the car I never fixed this issue. The issue is that when I pull the highbeams they turn on.. but when I release the blinker lever they go off. It will not click and stay on I pull it they go on and I release they go off any help would be great thanks in advanced
Y_U_no_run_evo is offline  
Old Nov 29, 2018, 06:35 PM
  #2  
Evolved Member
iTrader: (6)
 
cdrinkh2o's Avatar
 
Join Date: Nov 2006
Location: San Francisco
Posts: 758
Thanked 37 Times in 33 Posts
You either have a problem with the column switch, the wiring between it and the high-beam relay, the relay itself, or the Front ECU. If you don't have the Mitsu Scan Tool and SWS Monitor Kit I recommend you take it to the dealer and ask them to trouble shoot it.
cdrinkh2o is offline  
 


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.