Misfire ??? tune related? - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo Engine / Turbo / Drivetrain Everything from engine management to the best clutch and flywheel.

Misfire ??? tune related?

Old Jan 6, 2019, 07:00 AM
  #1  
Evolving Member
Thread Starter
iTrader: (6)
 
audiofan's Avatar
 
Join Date: Oct 2010
Location: Vzla
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Misfire ??? tune related?

Im having a constant misfire between 4k and 5.5k rpms at half throttle (around 8/10 psi), below that I can rev no problem, WOT no problem. Tried COP and stock coils, new plugs, smaller gap, could this be tune related?

Can too much fuel or too lean condition cause a misfire? or too much advance/retard timing cause a misfire?

Everything seems normal, wideband shows good afr, timing is 14/17 when misfire happens.

Thanks for your reply
audiofan is offline  
Old Jan 6, 2019, 08:08 AM
  #2  
Evolved Member
iTrader: (4)
 
ctfpevoVIII's Avatar
 
Join Date: Feb 2012
Location: connecticut
Posts: 808
Thanked 21 Times in 21 Posts
Originally Posted by audiofan View Post
Im having a constant misfire between 4k and 5.5k rpms at half throttle (around 8/10 psi), below that I can rev no problem, WOT no problem. Tried COP and stock coils, new plugs, smaller gap, could this be tune related?

Can too much fuel or too lean condition cause a misfire? or too much advance/retard timing cause a misfire?

Everything seems normal, wideband shows good afr, timing is 14/17 when misfire happens.

Thanks for your reply
So your saying while in that rpm range 4-5.5 your afrs are fine but its misfiring?? That seems odd, also what fuel are you running and regardless 14-17 degrees of timing seems way too high at that rpm range.
ctfpevoVIII is offline  
Old Jan 6, 2019, 12:20 PM
  #3  
Evolving Member
Thread Starter
iTrader: (6)
 
audiofan's Avatar
 
Join Date: Oct 2010
Location: Vzla
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Fuel is 93oct pump, this is at really low boost 5/10 psi half throttle, should I retard timing in this area?
audiofan is offline  
Old Jan 6, 2019, 12:49 PM
  #4  
Evolved Member
iTrader: (7)
 
Teal2nnr's Avatar
 
Join Date: Apr 2009
Location: Winnipeg, MB, Canada
Posts: 1,429
Thanked 29 Times in 26 Posts
Originally Posted by audiofan View Post
Fuel is 93oct pump, this is at really low boost 5/10 psi half throttle, should I retard timing in this area?
the timing shouldn't be your issue. At only 5-10 psi that timing sounds fine. Misfires can be lots of things. Bad MAP sensor, bad cam position sensor, boost leaks. There's lots of threads out there on things to start trying.
Teal2nnr is offline  


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.