Squealing!!!! ITS DRIVING ME CRAZY - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Lancer How Tos / Installations Post or link to your detailed how to / installation articles in here. If you have any questions regarding the how tos, feel free to post them in in the Request sub-forum.

Squealing!!!! ITS DRIVING ME CRAZY

Reply
 
 
 
Thread Tools Search this Thread
Old Jul 19, 2008, 12:31 PM   #1
Newbie
Thread Starter
 
IndoLancr84's Avatar
 
Join Date: Oct 2003
Location: Portland, Or
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: '02 Mitsu Lancer ES

Squealing!!!! ITS DRIVING ME CRAZY

so i have a squealing problem. ive check the forums for answers, but could find any. now, everytime i turn my car on, my belts squeal. Ive changed them three times in the last year, and it doesnt go away! ive sprayed lube, and still doesnt work..so can anyone help me? btw, its the a/c belt.
Offline
 
Reply With Quote
Old Jul 19, 2008, 01:05 PM   #2
Evolved Member
iTrader: (11)
 
lancer2show's Avatar
 
Join Date: Sep 2005
Location: newport news virginia
Posts: 1,643
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2005 Lancer ES/ 92 Talon TSI AWD

you must be ocd.
Offline
 
Reply With Quote
Old Jul 19, 2008, 08:43 PM   #3
Newbie
Thread Starter
 
IndoLancr84's Avatar
 
Join Date: Oct 2003
Location: Portland, Or
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: '02 Mitsu Lancer ES

no, its just driving me crazy! and when i have my kids in the car it scares the crap out of them and then...well they start screaming...common guys...THINK ABOUT THE CHILDREN! :-D. sorry but it doesnt scare the crap out of my kids tho
Offline
 
Reply With Quote
Old Jul 19, 2008, 09:09 PM   #4
Evolving Member
iTrader: (1)
 
coal's Avatar
 
Join Date: May 2003
Location: Portland, OR
Posts: 252
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Lancer ES

I think you need to tighten the belt a little more.
Offline
 
Reply With Quote
Old Jul 19, 2008, 09:16 PM   #5
Newbie
Thread Starter
 
IndoLancr84's Avatar
 
Join Date: Oct 2003
Location: Portland, Or
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: '02 Mitsu Lancer ES

its really tight...and if i tighten it some more, im afraid that itll snap.
Offline
 
Reply With Quote
Old Jul 20, 2008, 12:21 AM   #6
Evolving Member
 
Midnightkid's Avatar
 
Join Date: Aug 2007
Location: Las Vegas
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2003 Mitsubishi Lancer ES

I have the same problem with my alternator belt. I start the car, and it squeals like crazy. It keeps going until my car dips down around 1,000 RPMs.
Offline
 
Reply With Quote
Old Jul 20, 2008, 12:32 AM   #7
Evolving Member
iTrader: (37)
 
evo@24psi's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Posts: 439
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 03 Evo 8

Have you checked to make sure theres not anything wrong with the pulley? Bent, Loose?
Offline
 
Reply With Quote
Old Jul 20, 2008, 03:13 AM   #8
Evolving Member
 
Midnightkid's Avatar
 
Join Date: Aug 2007
Location: Las Vegas
Posts: 188
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2003 Mitsubishi Lancer ES

If you're refering to me, It happened after I installed my belt, after I installed my Light weight crank pulley. It was fine after I installed the pulley, but I noticed there was a tear in my alternator belt. The next day, I installed it and now it squeals everytime I start it up.
Offline
 
Reply With Quote
Old Jul 20, 2008, 05:31 AM   #9
Evolved Member
iTrader: (11)
 
lancer2show's Avatar
 
Join Date: Sep 2005
Location: newport news virginia
Posts: 1,643
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2005 Lancer ES/ 92 Talon TSI AWD

i know my friends integra. his car would squeal like a high pitch wine but it was because of the timing belt.
Offline
 
Reply With Quote
Old Jul 20, 2008, 07:50 AM   #10
Evolved Member
iTrader: (11)
 
03_Lancer_ES's Avatar
 
Join Date: Jan 2007
Location: __
Posts: 601
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2003 Mitsubishi Lancer

Could it be the wrong type of belt? Or maybe one of the pumps, etc it's cranking is whiling, not the belts?
Offline
 
Reply With Quote
Old Aug 2, 2008, 09:58 PM   #11
Evolved Member
iTrader: (1)
 
lancer02Josh's Avatar
 
Join Date: Sep 2002
Location: Newark, De
Posts: 513
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2002 Mitsu Lancer O-Z

Same thing is happening to me pep boys put a new timing belt and alt belt on within the past year and thats when it started. I took i tback and they said its fine.
Offline
 
Reply With Quote
Old Aug 2, 2008, 10:19 PM   #12
JRR
Evolved Member
iTrader: (19)
 
JRR's Avatar
 
Join Date: May 2007
Location: South Central WI
Posts: 1,620
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 99 Dodge Ram 2500 V10

mine does the same thing every one in a while. i think this is "normal" for a mitsu, because u look at all the first and second gen dsm's they do it as well. hopefully its just a tighten thing.
Offline
 
Reply With Quote
Old Aug 11, 2008, 08:27 AM   #13
Evolved Member
iTrader: (1)
 
lancer02Josh's Avatar
 
Join Date: Sep 2002
Location: Newark, De
Posts: 513
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2002 Mitsu Lancer O-Z

that shouldnt be a normal thing. it happens everytime i start my car if its been sitting for id say 5 hours or so. Or if its cold
Offline
 
Reply With Quote
Old Aug 11, 2008, 07:16 PM   #14
Evolved Member
iTrader: (3)
 
Jehuty's Avatar
 
Join Date: Jan 2007
Location: Kissimmee, FL
Posts: 1,557
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Nissan 350Z

dude same here, that's what my thread is about!
Offline
 
Reply With Quote
Old Aug 12, 2008, 02:40 PM   #15
Evolved Member
iTrader: (1)
 
lancer02Josh's Avatar
 
Join Date: Sep 2002
Location: Newark, De
Posts: 513
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2002 Mitsu Lancer O-Z

I just got my Alt belt and timing belt changed not too long ago and pep boys said its just breaking in. Well its been doing it for awhile and they said there is nothing wrong with it. I have sprayed it with lube and it works for about half a day. Its really embarrasing and annoying im almost at the point of taking it to mitsu
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AC Blows Hot Air and Makes belt Noise When On Lancerfry30 04-06 Ralliart General 0 Mar 10, 2017 07:50 AM
Brake pads? joonvang Evo X General 21 Nov 14, 2016 11:33 AM
So how much of a pain is it to do the accessory belt Evo_Goodness Evo General 6 Oct 17, 2016 04:24 PM
Squealing after Radiator Fan turns off BVolo1290 Lancer Troubleshooting 2 Jul 24, 2016 05:28 PM
Where to get OEM rotors & pads? jayree41 Evo X Tires, Wheels, Brakes & Suspension - Sponsored by The Tire Rack 10 Nov 23, 2015 11:24 PM


Tags
2002, 2003, ac, air, belt, belts, conditioner, es, everytime, lancer, mitsubishi, problems2003, screeching, squealing, squeals, start, started

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:40 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: