TPS sensor help!!!!! Throwing a code P0123 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
04-06 Ralliart Engine/Drivetrain (no forced induction)

TPS sensor help!!!!! Throwing a code P0123

Old Sep 16, 2018, 04:37 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: anniston alabama
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
TPS sensor help!!!!! Throwing a code P0123

So my car for the last year has been messing up. So when Iím putting around and barely have the pedal mashed at all it seems to jerk and lose power a bit and I donít know why. Last week it completely lost power but never turned off. It would idle around 2000 rpms and there would only rev up to like 3000 with the pedal to the floor. I turned it off and let it set and turned it back on and itís fine. So I took it to oreilys and it threw a code P0123 which is the throttle/pedal position sensor A circuit high input. And I honestly donít know what to do. Please help!!! Itís my daily and I need it fixed ASAP.
Christian Ford is offline  
Old Sep 16, 2018, 04:37 PM
  #2  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: anniston alabama
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
The car is a 2004 Mitsubishi Lancer ralliart 2.4l engine
Christian Ford is offline  
Old Sep 18, 2018, 05:31 PM
  #3  
Evolved Member
iTrader: (5)
 
CrAnSwIcK's Avatar
 
Join Date: Sep 2010
Location: Ontario, Canada
Posts: 7,415
Thanks: 0
Thanked 74 Times in 73 Posts
replace the sensor.
CrAnSwIcK is offline  


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.