Notices
09+ Lancer Ralliart General Discuss any generalized technical factory turbocharged Ralliart related topics that may not fit into the other forums.

CJ Lancer Ralliart bouncing idle. Check engine light

 
Old Aug 13, 2018, 05:04 AM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2018
Location: Melbourne
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
CJ Lancer Ralliart bouncing idle. Check engine light

Hi guys just got my 2009 CJ Lancer Ralliart and my missus jumped in the car. I watched her jumped in without the electrics booting up and start it. The car started but, it was idling very poor from 600 - 1.5k rpm and then dash threw a engine light then saying engine check. I turned the car off locked the doors and unlocked, jumped in and started again. Started fine drives fine but engine light still on.

Now unfortunately this isn't the first time. The other time was just at a red light and went to take off (normally) the car went into limp mode. Couldn't drive over 40 kms. Got the car towed to friends auto electrician shop and his scan tool told him throttle body sensor. Took the throttle body and sensor to get inspected by professionals and came back without any problems.(After $300) Friend couldn't reset the fault so eventually towed the car to Mitsubishi experts and the inspected the car and ran their scan tool over it and came up with same problem (throttle body sensor). So they used their "special" Mitsubishi scan tool to reset it. Car has driven great for over 6 months now till today.

Has anyone experience this bouncing problem and are the mechanics missing something?


I don't want my car dying again like when my timing chain stretched a few times throwing engine light and dealership just resetting the code 3x times, when the ecu was trying to warn about the chain stretching. Eventually the car bent all valves which cost me over $3k.

(I was pretty furious)

Wasn't cover by warranty because I missed my 1 from the dealership which causes voided of warranty. (My fault I get it)


Any help would be appreciated

Thanks

Dino
dinoscj is offline  
Old Aug 14, 2018, 06:23 AM
  #2  
c08
Newbie
 
Join Date: Aug 2014
Location: Pittsburgh, PA
Posts: 78
Likes: 0
Liked 9 Times in 9 Posts
It would probably be a good idea to read the codes first to start troubleshooting, but one quick thing to check would be to make sure the FPR hose didn't come off: https://cdn.shopify.com/s/files/1/08...g?v=1522821569
c08 is offline  
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.