Dash Light Issues...Any help appreciated - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo Electrical / Audio / Security Discuss electrical systems, audio system upgrades, or alarm configurations.

Dash Light Issues...Any help appreciated

Reply

 
 
 
Old Dec 20, 2017, 07:41 PM
  #1  
Evolving Member
Thread Starter
iTrader: (37)
 
AndyBandy's Avatar
 
Join Date: Oct 2005
Location: Frederick, MD
Posts: 464
Thanks: 0
Thanked 0 Times in 0 Posts
Dash Light Issues...Any help appreciated

For my IX MR, I just had the dealership perform the air bag recall and flash update (since i'm not flashed currently). For them to do the work, I had to remove some of my under-dash wiring from my gauges, radar detector, etc. After I got it back, I took the next month or so to change the location of my Defi gauges and install my AEM wideband. I installed the o2 sensor through the passenger side floor grommet, and wired in the AEM to the lighter fuse using a fuse tap, which is working fine.

When I drove it to work this morning, I noticed that many of my interior lights are not working. The lights that are working are: A/C panel and speedo / main gauge cluster. The lights that are not working are: lights to the left of the speedo/main gauge cluster (ACD, dimmer), hazard lights switch, cigarette lighter, ash tray light.

I've checked the fuses, including the engine bay fuse related to the radio/dome light (in the yellow clip) and everything seems good. Any other ideas as to what may cause this?

I tried attaching a picture, but my iPhone keeps spinning it so I apologize in advance.
Attached Thumbnails Dash Light Issues...Any help appreciated-img_1884.jpg  
AndyBandy is offline  
Reply With Quote
Old Dec 21, 2017, 07:02 AM
  #2  
Evolving Member
Thread Starter
iTrader: (37)
 
AndyBandy's Avatar
 
Join Date: Oct 2005
Location: Frederick, MD
Posts: 464
Thanks: 0
Thanked 0 Times in 0 Posts
Not sure if itís relevant, but during the relocation of the defi gauges I did remove the standard MR gauges and itís wiring.
AndyBandy is offline  
Reply With Quote
Old Feb 25, 2018, 10:19 PM
  #3  
Newbie
 
Join Date: Nov 2009
Location: queens ny
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by AndyBandy View Post
For my IX MR, I just had the dealership perform the air bag recall and flash update (since i'm not flashed currently). For them to do the work, I had to remove some of my under-dash wiring from my gauges, radar detector, etc. After I got it back, I took the next month or so to change the location of my Defi gauges and install my AEM wideband. I installed the o2 sensor through the passenger side floor grommet, and wired in the AEM to the lighter fuse using a fuse tap, which is working fine.

When I drove it to work this morning, I noticed that many of my interior lights are not working. The lights that are working are: A/C panel and speedo / main gauge cluster. The lights that are not working are: lights to the left of the speedo/main gauge cluster (ACD, dimmer), hazard lights switch, cigarette lighter, ash tray light.

I've checked the fuses, including the engine bay fuse related to the radio/dome light (in the yellow clip) and everything seems good. Any other ideas as to what may cause this?

I tried attaching a picture, but my iPhone keeps spinning it so I apologize in advance.
Iím having the same exact problem same day I swapped out my gauges too any luck lmk
fatboyslim86 is offline  
Reply With Quote
Old Jun 9, 2018, 09:30 AM
  #4  
Newbie
 
Join Date: Jun 2018
Location: Iowa
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Im having almost the same issue, except my ac panel lights and my volt, oil temp, and boost gauge lights are not lighting up after getting the most recent passenger side air bag recall.
Atmz25 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
floating doc
04-06 Ralliart General
2
Jul 17, 2017 07:20 PM
rosuegk7
Evo General
2
Apr 19, 2017 08:28 PM
Jinskullz
Evo General
4
Nov 22, 2016 12:28 PM
Evo_Goodness
Evo General
12
Aug 6, 2016 06:53 PM
EvokidIX
Evo How Tos / Installations
31
Mar 12, 2016 04:08 PM


Thread Tools
Search this Thread
Quick Reply: Dash Light Issues...Any help appreciated


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.