Reverse Lights Not Working? It's Probably the Backup Light Switch - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Go Back  EvolutionM - Mitsubishi Lancer and Lancer Evolution Community > Lancer Evolution 1-9 Forums > Evo General
Reload this Page >

Reverse Lights Not Working? It's Probably the Backup Light Switch

Notices
Evo General Discuss any generalized technical Evo related topics that may not fit into the other forums. Please do not post tech and rumor threads here.
Sponsored by: RavSpec - JDM Wheels Central

Reverse Lights Not Working? It's Probably the Backup Light Switch

Reply

 
 
 
Old Feb 2, 2011, 09:52 PM
  #1  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Reverse Lights Not Working? It's Probably the Backup Light Switch

What's up guys?

So a couple of weeks ago I noticed my reverse lights weren't working, and found it odd that they were both out. I figured it was just chance, so I went to AutoZone, picked up some Sylvania SilverStar Ultra 411 bulbs if I'm not mistaken. I initially went off the Sylvania Lamp Replacement guide, but the bulb size they recommended on their site was way too small. I pulled the bulb, walked in and I believe it was a 411. Well, I popped them in, and still nothing. WTF?

I knew it had to be a sensor or a fuse, so after some research, I found that the sensor can go bad. I called around to AutoZone, PepBoys and other local auto parts stores asking if they carried the part but no one did. They either didn't carry it, or weren't sure about the part and price. I didn't want to take any chances with some joe schmoe employee ordering me some "it might be this" part, so I got on the phone with Russell @ Mitsubishiparts.net. I told him what I needed, he gave me the part#, and I placed the order online. Great guy, great service, and arrived in the time frame he said it would.

2006 Evolution IX MR 6-speed (different part# for a 5-speed)
Backup Light Switch
Part# MN132387


5-speed
Backup Light Switch
Part# MD730979


Now, I haven't install the sensor yet, but I will be either tomorrow or Saturday. I just wanted to post some photos so that people know what the sensor looked like. Also because I am a photoholic.

This plugs into the top of your transmission. It's pretty much the only sensor there when you're looking down at the top of the case.

-Jalal

Sorry for the iPhone 4 pic.




Canon EOS 30D
Canon EF 28mm f/1.8 USM


IMG_9099 edited resized by MJ23FE, on Flickr


IMG_9108 edited resized by MJ23FE, on Flickr


IMG_9115 edited resized by MJ23FE, on Flickr


IMG_9132 edited resized by MJ23FE, on Flickr


IMG_9134 edited resized by MJ23FE, on Flickr


IMG_9135 edited resized by MJ23FE, on Flickr
Attached Thumbnails Reverse Lights Not Working? It's Probably the Backup Light Switch-back-up-sensor-1.jpg   Reverse Lights Not Working? It's Probably the Backup Light Switch-back-up-sensor-service-manual.jpg  

Last edited by MJ23FE; Feb 23, 2015 at 12:44 AM.
MJ23FE is offline  
Reply With Quote
Old Feb 2, 2011, 09:55 PM
  #2  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
May a moderator please adjust my title to read:

Reverse Lights Not Working? It's Probably the Backup Light Switch



Thanks!

-Jalal

Last edited by MJ23FE; Feb 2, 2011 at 10:16 PM.
MJ23FE is offline  
Reply With Quote
Old Feb 2, 2011, 10:00 PM
  #3  
Evolved Member
iTrader: (12)
 
GaBe511's Avatar
 
Join Date: Jul 2009
Location: South Jersey
Posts: 540
Thanks: 0
Thanked 0 Times in 0 Posts
I had a problem just like this on my honda. Turns out, a connector was unplugged lol. Bought new bulbs and everything. Hopefully this solves your problem.
GaBe511 is offline  
Reply With Quote
Old Feb 2, 2011, 10:01 PM
  #4  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by GaBe511 View Post
I had a problem just like this on my honda. Turns out, a connector was unplugged lol. Bought new bulbs and everything. Hopefully this solves your problem.
I hope so, too! I unplugged the sensor and plugged it back in but no luck.

We'll see what happens!

-Jalal
MJ23FE is offline  
Reply With Quote
Old Feb 2, 2011, 10:03 PM
  #5  
Evolved Member
iTrader: (4)
 
CJ2X's Avatar
 
Join Date: Sep 2007
Location: SoCal
Posts: 1,804
Thanks: 0
Thanked 0 Times in 0 Posts
Useful. Thanks for sharing!
CJ2X is offline  
Reply With Quote
Old Feb 3, 2011, 06:13 AM
  #6  
EvoM Staff Alumni
iTrader: (3)
 
Ramen_Noodle's Avatar
 
Join Date: Jun 2005
Location: Knoxville, TN
Posts: 761
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by MJ23FE View Post
May a moderator please adjust my title to read:

Reverse Lights Not Working? It's Probably the Backup Light Switch



Thanks!

-Jalal
Fixed per request.
Ramen_Noodle is offline  
Reply With Quote
Old Feb 3, 2011, 06:22 AM
  #7  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Ramen_Noodle View Post
Fixed per request.
Thanks!!!

-Jalal
MJ23FE is offline  
Reply With Quote
Old Feb 3, 2011, 05:38 PM
  #8  
Evolving Member
iTrader: (6)
 
legato's Avatar
 
Join Date: May 2006
Location: Hawaii-San Jose
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Mine went out in Sept/Oct right before I shipped my car up to Cali...Russell was really helpful, and got me the part rushed 2-day I think...I installed it the day before I took my car to the Matson port...
legato is offline  
Reply With Quote
Old Feb 3, 2011, 07:18 PM
  #9  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by legato View Post
Mine went out in Sept/Oct right before I shipped my car up to Cali...Russell was really helpful, and got me the part rushed 2-day I think...I installed it the day before I took my car to the Matson port...
Russell & Mitsubishiparts.net FTW!

-Jalal
MJ23FE is offline  
Reply With Quote
Old Feb 9, 2011, 07:33 PM
  #10  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Success!!! I swapped the sensors today and we are good to go!

Hopefully this thread helps people who may have this same issue in the future.

-Jalal
MJ23FE is offline  
Reply With Quote
Old Jun 29, 2011, 01:15 PM
  #11  
Newbie
iTrader: (3)
 
Join Date: Apr 2010
Location: San Gabriel Valley
Posts: 61
Thanked 0 Times in 0 Posts
nice write up
j.liu is offline  
Reply With Quote
Old Jun 29, 2011, 03:23 PM
  #12  
Evolved Member
Thread Starter
iTrader: (3)
 
MJ23FE's Avatar
 
Join Date: Feb 2004
Location: NJ.201
Posts: 1,459
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by j.liu View Post
nice write up
Thanks, dude!

-Jalal
MJ23FE is offline  
Reply With Quote
Old Aug 12, 2011, 02:45 PM
  #13  
Evolving Member
iTrader: (12)
 
Join Date: Jan 2008
Location: CA
Posts: 332
Thanks: 0
Thanked 0 Times in 0 Posts
both of mine are out also. i'm wondering if i should even go through the hassle of checking the bulbs and all or just buy this part
LakerRaider is offline  
Reply With Quote
Old Aug 12, 2011, 03:08 PM
  #14  
Evolving Member
iTrader: (12)
 
Join Date: Jan 2008
Location: CA
Posts: 332
Thanks: 0
Thanked 0 Times in 0 Posts
is it the same part number for 5 spd?
LakerRaider is offline  
Reply With Quote
Old Oct 29, 2011, 06:46 PM
  #15  
Newbie
 
Join Date: Jul 2005
Location: Buena Park, CA
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
i just installed mine this morning and now i have a hard time shifting into 5th gear or reverse. i hope anyone has an idea what i may have done wrong. thanks
bobodwaisman is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Reverse Lights Not Working? It's Probably the Backup Light Switch


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.