'08 stereo faceplate has no lights except "EJECT" and "LOAD" - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Lancer Troubleshooting Get help with any troubleshooting problems you may have.

'08 stereo faceplate has no lights except "EJECT" and "LOAD"

Reply

 
 
 
Old Jul 16, 2017, 09:29 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 24
Thanked 2 Times in 2 Posts
SOLVED : '08 stereo faceplate has no lights except "EJECT" and "LOAD"

Hi,

my '08 Lancer ES with a standard stereo has always been like that since I've owned it. On my stereo faceplate every button works, the LCD works, but there is no backlight except for LOAD and EJECT but they are very very dim. The "hazard" button doesn't light up either.

It seems like the faceplate could have been swapped at a junkyard by the previous owner as it has this yellow number that was hand written with a yellow paint marker. This yellow number starts by 11- which could lead me to think it might come from an '11 Lancer.

My HVAC controls don't light up either, and if they do, it is very faintly.

So I have 2 questions:

1) Are the 08 and 11 faceplate pinouts different for the connector of the stereo faceplate?

2) Does anyone have a wiring diagram for this ?

Thanks!

Last edited by vizi0n; Sep 15, 2017 at 07:17 PM.
vizi0n is offline  
Reply With Quote
Old Jul 17, 2017, 07:09 PM
  #2  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 24
Thanked 2 Times in 2 Posts
It seems that there are 2 different year ranges according to part numbers I have found.

Some are 2008-09, and others are 2010-13

Anyone knows the difference?
vizi0n is offline  
Reply With Quote
Old Jul 25, 2017, 07:18 PM
  #3  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 24
Thanked 2 Times in 2 Posts
Here are 2 photos, if it can be of any help.

Sorry about the quality. On the second one we can see the dim orange light on my hand in the console under the hvac controls, along with the very dim light blue of the heater temperature
Attached Thumbnails '08 stereo faceplate has no lights except "EJECT" and "LOAD"-img_0141.jpg   '08 stereo faceplate has no lights except "EJECT" and "LOAD"-img_0145.jpg  
vizi0n is offline  
Reply With Quote
Old Sep 15, 2017, 07:09 PM
  #4  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 24
Thanked 2 Times in 2 Posts
Well, found the solution on another forum. I swapped the heater controls from another car ('09 GTS in this case) and now it's all fixed!

- Climate controls light up
- Stereo faceplate lights up
- Hazard button lights up

So if it ever happens to you, try this.

PS : the climate controls with "AUTO" function do work, except that the "AUTO" part will not operate properly as there is no temperature sensor in this car.
vizi0n is offline  
Reply With Quote
The Following User Says Thank You to vizi0n For This Useful Post:
gots_a_sol (Sep 16, 2017)
Old Dec 10, 2017, 03:49 PM
  #5  
Newbie
 
Join Date: Dec 2016
Location: Cambridge, Ontario
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hey, I am having this exact same problem happening with my 2010 gts. So what exactly did you replace?
Trevor Paul is offline  
Reply With Quote
Old Dec 11, 2017, 04:02 AM
  #6  
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 24
Thanked 2 Times in 2 Posts
Originally Posted by Trevor Paul View Post
Hey, I am having this exact same problem happening with my 2010 gts. So what exactly did you replace?
I only replaced the heater controls module (the 3 clicker knobs).

You need to undo :
- glovebox
- trim at the right of the glovebox
- silver trim that goes across the dash
- stereo faceplate
- handbrake surround trim
- shifter knob
- shifter boot trim
- move the handbrake console back a bit (2 10mm bolts at the bottom on the storage space and very straightforward screws)
- undo the 4 bottom screws(2 on each sides) that secure the sides of the plastic trim around the controls and pull out on the trims to allow some wiggling play. There are also 2 silver screws on top the heater unit that will be exposed when you remove the stereo faceplate, you need to undo them as well

You should then be able to pull the controls out with the plastic trim

Im writing this s I remember it but I think thats about it!
vizi0n is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
turbotaloon95
Evo Electrical / Audio / Security
7
May 16, 2017 01:57 PM
MRevolutionX
For Sale - Interior / Exterior / Sound / Styling
8
Dec 15, 2016 02:41 PM
Trevor Paul
Lancer Troubleshooting
0
Dec 13, 2016 11:47 AM
Jkuti13
Evo Engine / Turbo / Drivetrain
16
Jun 13, 2016 07:15 AM


Thread Tools
Search this Thread
Quick Reply: '08 stereo faceplate has no lights except "EJECT" and "LOAD"


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.