'08 stereo faceplate has no lights except "EJECT" and "LOAD" - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Lancer Troubleshooting Get help with any troubleshooting problems you may have.

'08 stereo faceplate has no lights except "EJECT" and "LOAD"

Reply
 
 
 
Thread Tools Search this Thread
Old Jul 16, 2017, 09:29 PM   #1
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 12
Thanked 1 Time in 1 Post

Drives: 2008 Lancer ES

'08 stereo faceplate has no lights except "EJECT" and "LOAD"

Hi,

my '08 Lancer ES with a standard stereo has always been like that since I've owned it. On my stereo faceplate every button works, the LCD works, but there is no backlight except for LOAD and EJECT but they are very very dim. The "hazard" button doesn't light up either.

It seems like the faceplate could have been swapped at a junkyard by the previous owner as it has this yellow number that was hand written with a yellow paint marker. This yellow number starts by 11- which could lead me to think it might come from an '11 Lancer.

My HVAC controls don't light up either, and if they do, it is very faintly.

So I have 2 questions:

1) Are the 08 and 11 faceplate pinouts different for the connector of the stereo faceplate?

2) Does anyone have a wiring diagram for this ?

Thanks!
Offline
 
Reply With Quote
Old Jul 17, 2017, 07:09 PM   #2
Newbie
Thread Starter
 
Join Date: Oct 2016
Location: QC, Canada
Posts: 12
Thanked 1 Time in 1 Post

Drives: 2008 Lancer ES

It seems that there are 2 different year ranges according to part numbers I have found.

Some are 2008-09, and others are 2010-13

Anyone knows the difference?
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
NEED RADIO HELP!!! 2009 Lancer dpelkey Lancer Troubleshooting 0 Sep 4, 2015 07:01 PM
Sony GTX-710 HeadUnit (iPod Ready) mx4life85 For Sale - Interior / Exterior / Sound / Styling 4 Feb 19, 2011 04:50 PM
Bad news guys. A friendly reminder to NTEC. WORD North Texas Evo Club (NTEC) 8 Dec 14, 2010 10:35 AM
Just got my Evo X...anyone installed any aftermarket Stereo?? Rudager Evo X General 4 Apr 1, 2008 06:34 PM
The headunit won't eject my cd PersianEVO Evo General 11 Jul 10, 2006 08:48 PM


Tags
backlight, dead, faceplate, stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:46 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: