Hesitation after turbo swap - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo Engine / Turbo / Drivetrain Everything from engine management to the best clutch and flywheel.

Hesitation after turbo swap

 
Old Dec 24, 2018, 02:14 PM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2018
Location: washington state
Posts: 16
Thanked 1 Time in 1 Post
Hesitation after turbo swap

I just did a turbo swap. Did a fp mani with a hta71 turbo. Everything is installed and the car idles fine. There's no jitters or anything like that. The problem comes when i get on the gas and it takes 4 every to get moving. I hear the turbo spooling like hell but she is not really moving and the bov flutters like there wasn't much air. Even after a pull at 4k there's not much bov sound and the car doesn't really take off. Anybody have a clue as to what the issue could be?
bishop9d4 is offline  
Old Dec 24, 2018, 03:42 PM
  #2  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,635
Thanked 123 Times in 117 Posts
Pictures? Video?
2006EvoIXer is offline  
Old Dec 24, 2018, 06:12 PM
  #3  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 9,904
Thanked 256 Times in 244 Posts
My best guesses:
Massive boost leak. If not: dead turbo.
kaj is offline  
Old Dec 24, 2018, 08:07 PM
  #4  
Newbie
Thread Starter
 
Join Date: Feb 2018
Location: washington state
Posts: 16
Thanked 1 Time in 1 Post
Turbo is new
bishop9d4 is offline  
Old Dec 24, 2018, 08:52 PM
  #5  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,635
Thanked 123 Times in 117 Posts
Pictures of turbo. Especially the blades on each end.

2006EvoIXer is offline  
Old Dec 24, 2018, 08:59 PM
  #6  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,635
Thanked 123 Times in 117 Posts
Originally Posted by bishop9d4 View Post
Turbo is new
it is possible to have a bad new turbo when the wrong wheel is used.
2006EvoIXer is offline  
Old Dec 24, 2018, 09:28 PM
  #7  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 9,904
Thanked 256 Times in 244 Posts
Originally Posted by bishop9d4 View Post
Turbo is new
You did a boost leak test?
kaj is offline  
Old Dec 24, 2018, 10:02 PM
  #8  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,635
Thanked 123 Times in 117 Posts
Does your compressor wheel look like this?:
2006EvoIXer is offline  
Old Dec 25, 2018, 12:19 AM
  #9  
Newbie
Thread Starter
 
Join Date: Feb 2018
Location: washington state
Posts: 16
Thanked 1 Time in 1 Post
Originally Posted by kaj View Post
You did a boost leak test?
Doing that tommorow
bishop9d4 is offline  
Old Dec 25, 2018, 12:22 AM
  #10  
Newbie
Thread Starter
 
Join Date: Feb 2018
Location: washington state
Posts: 16
Thanked 1 Time in 1 Post
Originally Posted by 2006EvoIXer View Post
Pictures of turbo. Especially the blades on each end.

Gotta take it back off the car
bishop9d4 is offline  
Old Dec 25, 2018, 06:42 AM
  #11  
Evolved Member
iTrader: (4)
 
ctfpevoVIII's Avatar
 
Join Date: Feb 2012
Location: connecticut
Posts: 822
Thanked 21 Times in 21 Posts
Originally Posted by bishop9d4 View Post
I just did a turbo swap. Did a fp mani with a hta71 turbo. Everything is installed and the car idles fine. There's no jitters or anything like that. The problem comes when i get on the gas and it takes 4 every to get moving. I hear the turbo spooling like hell but she is not really moving and the bov flutters like there wasn't much air. Even after a pull at 4k there's not much bov sound and the car doesn't really take off. Anybody have a clue as to what the issue could be?
what was your previous turbo/ setup? Could it be tune related?
ctfpevoVIII is offline  
Old Dec 25, 2018, 07:51 AM
  #12  
Newbie
Thread Starter
 
Join Date: Feb 2018
Location: washington state
Posts: 16
Thanked 1 Time in 1 Post
Originally Posted by ctfpevoVIII View Post


what was your previous turbo/ setup? Could it be tune related?
Not tuned yet. We just finished yesterday took it around the block and noticed a hi pitched squeal like something was open but we checked everything 14 times. Fp turbos usually that loud?
bishop9d4 is offline  
Old Dec 25, 2018, 10:47 AM
  #13  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 9,904
Thanked 256 Times in 244 Posts
99% of the time it's a boost leak. That's the easiest and cheapest thing to do. I'd say Start there before stressing about all the bigger stuff.
and good luck ,dude!
kaj is offline  
Old Dec 25, 2018, 10:50 AM
  #14  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 9,904
Thanked 256 Times in 244 Posts
Originally Posted by bishop9d4 View Post
Not tuned yet. We just finished yesterday took it around the block and noticed a hi pitched squeal like something was open but we checked everything 14 times. Fp turbos usually that loud?
If it has the FAP cover ,yes. Also,.If you have a bad enough boost leak, the turbo could be spinning 1,000,000RPM and sucking a ton of air, which could be pretty noisy.
kaj is offline  
Old Dec 25, 2018, 11:04 AM
  #15  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,635
Thanked 123 Times in 117 Posts
Originally Posted by bishop9d4 View Post
Gotta take it back off the car
pop off the intake pipe from MAF and take a picture of blades.
2006EvoIXer is offline  

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.