Evo 7 GTA Headlight/Signal Issue - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo General Discuss any generalized technical Evo related topics that may not fit into the other forums. Please do not post tech and rumor threads here.
Sponsored by: RavSpec - JDM Wheels Central

Evo 7 GTA Headlight/Signal Issue

Reply

 
 
 
Old Mar 12, 2018, 08:39 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2018
Location: Calgary, AB
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Evo 7 GTA Headlight/Signal Issue

Hey I just imported a Evo 7 GTA into Canada, and while at its Out of Province Inspection to make the car road legal the shop pointed out that my headlights and signals were not working. How ever the signals will flash when you lock the car. Anyone have any ideas on what could be wrong or have a solution, anything is greatly appreciated!!
qman11 is offline  
Reply With Quote
Old Mar 18, 2018, 11:04 PM
  #2  
Evolved Member
iTrader: (2)
 
OZR_Lancer's Avatar
 
Join Date: Feb 2007
Location: San Diego - SDSU Area
Posts: 1,167
Thanked 5 Times in 5 Posts
pictures of the 7 lol... just like any other car in general. check the relay for headlights to make sure thy work for high/low etc. replace bulbs if necessary and inspect headlight harness for any loose connections.... I had 2 bad sockets on my oz rally and I just replaced them with weatherpack connectors
OZR_Lancer is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.