Innovate MTX-L problem - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo X Engine Management / Tuning Forums Discuss the major engine management systems.

Innovate MTX-L problem

Old Apr 21, 2012, 12:09 PM
  #1  
Evolving Member
Thread Starter
iTrader: (1)
 
bluedub1's Avatar
 
Join Date: Jan 2011
Location: USA
Posts: 130
Thanks: 0
Thanked 0 Times in 0 Posts
Innovate MTX-L problem

I recently installed an Innovate MTX-L wideband o2 sensor system, and it isn't working..

I know the wiring was done correctly, because it worked just fine yesterday after I hooked it all up. It read AFRs and the LEDs swept through their range. Later last night, it randomly stopped displaying the numbers and the indicator LEDs around the perimeter was stuck at one LED.

Now, when I leave the ignition in the "ON" position (w/o the engine started), it displays all of the Orange/Yellow LEDs and no numbers. If the engine is on, nothing is displayed.

Has anyone run into the same problem? Based on some prelim research, I might have fried the circuit inside due to a voltage spike. Although, I'm kind of doubting that because I haven't seen the same issue occur to anyone after searching evom or evoxforums.

For the wiring, I connected the power to a switching 12V (Fuse 13). The white wire which dims the lights was connected to the green wire behind the ASC button. I checked the green wire to make sure it switched with the headlights (0V = headlights off, 12V = headlights on). The black line is grounded to the chassis.
bluedub1 is offline  
Old Apr 24, 2012, 08:00 AM
  #2  
Evolving Member
iTrader: (1)
 
Join Date: May 2008
Location: New Mexico
Posts: 239
Thanks: 0
Thanked 0 Times in 0 Posts
Check the connectors on the sensor cable. I couldn't get mine to calibrate last night and it was because the larger connector wasn't completely seated. You have to really push it on there
TravisF is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
3vo|3oost
General Engine Management / Tuning Forum
6
May 7, 2017 02:10 AM
LancerShop.com
LancerShop.com
6
Sep 29, 2016 07:30 PM
Giuna99
For Sale/WTB - Engine / Drivetrain / Power
1
Apr 17, 2016 08:35 PM
aggieEVO
General Engine Management / Tuning Forum
0
May 1, 2015 02:17 PM
needsboost
General Engine Management / Tuning Forum
3
Jul 11, 2013 12:09 PM


Thread Tools
Search this Thread
Quick Reply: Innovate MTX-L problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.