Evo x idle rough - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Evo X General Discuss any generalized technical Evo X related topics that may not fit into the other forums.

Evo x idle rough

Reply
 
 
 
Thread Tools Search this Thread
Old Mar 18, 2017, 02:59 PM   #1
Newbie
Thread Starter
 
Join Date: Mar 2017
Location: Boston
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Evo x idle rough

Hello people so I have read a couple of posts here on idle issues and can't seems to find any solution.

2011 EVO GSR
39k miles
Stage 1 Cobb with CHFF

So when coming to a stop ( rolling 10 mph in neutral ) rpms stay high around 1.4k and slowly will go down to 900 after I 100% stop ( sometimes will bound between 1.2k - 900 for 2 second ) . I have checked all lines no leaks that I can see or hear. I also have checked the line near the oil dip stick that is on tight. I had the same issue when I was stock but not as dramatic it would idle 1.1k then go back down.

Am I missing something that is on here ?
Or could it just be the flash tune ?
I have been driving with the flash tune for 2 days now.
I had a turbosmart BOV 50/50 installed on first day of flash tune and it would not close all the way even on tightest setting. So I took it off and put the stocker on.

Please help !!!!!

Last edited by Monkeymypants00; Mar 18, 2017 at 03:00 PM. Reason: Typo
Offline
 
Reply With Quote
Old Mar 18, 2017, 09:57 PM   #2
Newbie
 
SaVaGe_x's Avatar
 
Join Date: Feb 2015
Location: NJ
Posts: 18
Thanked 1 Time in 1 Post

Drives: WW evo x

When I had my cobb stage 1 tune my idle was real ****ty. Its most likely just the cobb OTS tune.
Offline
 
Reply With Quote
Old Mar 19, 2017, 08:58 AM   #3
Evolving Member
iTrader: (1)
 
jakgal04's Avatar
 
Join Date: Jan 2015
Location: Ridley park
Posts: 474
Thanked 19 Times in 18 Posts

Drives: 08 RR Evo X

I think thats normal, mines been doing that since I bought it.
Online
 
Reply With Quote
Old Mar 20, 2017, 01:03 PM   #4
Newbie
 
Join Date: Apr 2016
Location: Ohio
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2013 GSR

This idle behavior drives me CRAZY.

Tuner said there was nothing he could do, it's just the way evo's are. I feel like he knows best, but there has to be a way.

I test drove an evo that was tuned before I bought mine (stock) last year, and it did NOT do this.

I've searched and searched and never found a fix related to this exact issue.
Offline
 
Reply With Quote
Old Mar 20, 2017, 01:19 PM   #5
Newbie
Thread Starter
 
Join Date: Mar 2017
Location: Boston
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Same makes me feel like something is wrong but people keep saying its normal so i guess i will deal with it.
Offline
 
Reply With Quote
Old Mar 20, 2017, 02:33 PM   #6
Evolving Member
 
Join Date: Oct 2016
Location: Race City USA
Posts: 174
Thanked 16 Times in 15 Posts
Mine has done that since the day I got it.


Always makes me look like a shifty noob until the engine warms up too. Never had a car that couldn't compensate for the engine temperature like this... I sometimes wonder if it's for these reasons that Mitsubishi is slowly dying in the US.

I also love the (apparently normal) "mivec drop" the car does sometimes when pushing in the clutch while slowly rolling to a stop...


Cant get enough of these drive-by-wire throttles.
Online
 
Reply With Quote
Old Mar 21, 2017, 05:04 AM   #7
Evolving Member
iTrader: (1)
 
jakgal04's Avatar
 
Join Date: Jan 2015
Location: Ridley park
Posts: 474
Thanked 19 Times in 18 Posts

Drives: 08 RR Evo X

Quote:
Originally Posted by Monkeymypants00 View Post
Same makes me feel like something is wrong but people keep saying its normal so i guess i will deal with it.
You can edit the map to change the idle values to 1000 instead of the stock 700 or whatever it is. Completely solved it for me, plus I like the idle a bit higher.
Online
 
Reply With Quote
Old Mar 21, 2017, 01:18 PM   #8
Newbie
 
Join Date: Apr 2016
Location: Ohio
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2013 GSR

Quote:
Originally Posted by jakgal04 View Post
You can edit the map to change the idle values to 1000 instead of the stock 700 or whatever it is. Completely solved it for me, plus I like the idle a bit higher.
I had my idle bumped up to 1000 also when I got my tune, however it didn't fix the issue.

On cold start it idles all over the place..

When warmed up, if cruising and I press the clutch, idle will drop to ~700, then come up to around ~1300 and stay there until I'm totally stopped. That's when it comes back down to 1000. Might just be something I never get used to

For reference:
UICP
Intake
Test Pipe
CBE
3 Port
Tune
Offline
 
Reply With Quote
Old Mar 21, 2017, 09:13 PM   #9
Newbie
 
Join Date: Dec 2016
Location: san diego
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post

Drives: 2011 GSR

same problem.
Offline
 
Reply With Quote
Old Mar 22, 2017, 07:48 AM   #10
Evolving Member
iTrader: (1)
 
jakgal04's Avatar
 
Join Date: Jan 2015
Location: Ridley park
Posts: 474
Thanked 19 Times in 18 Posts

Drives: 08 RR Evo X

What kind of intakes do you guys have? When the engine is warm the idle RPM can fluctuate, especially if there's no intake heat shield. On cold starts its fairly normally for it to idle around 2k and then casually drop to the coded RPM value.
Online
 
Reply With Quote
Old Mar 23, 2017, 01:04 PM   #11
Newbie
 
Join Date: Apr 2016
Location: Ohio
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2013 GSR

Depo intake, running the shield. Behaved this way before and after intake install so I've ruled that out.

Pretty sure it's just something I have to live with at this point.
Offline
 
Reply With Quote
Old Mar 30, 2017, 10:52 AM   #12
Newbie
 
Join Date: Apr 2016
Location: silver spring MD
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
i have up and down idle on cold start up but doesnt seem to have too much issues when warm.
called the tuner and pretty much told me that its nothing to do with the tune.... i wonder....
Offline
 
Reply With Quote
Old Jul 3, 2017, 11:32 AM   #13
Newbie
 
Join Date: May 2017
Location: 49456
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post

Drives: 2011 Mitsubishi Lancer Evolution X

sounds normal, dipping to 900 won't do any damage anyway
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
*How to setup idle for AEM ECU* browningderek AEM EMS 71 Jul 17, 2017 02:21 PM
Idle insanely high? Evo47 Evo General 6 Mar 30, 2017 07:29 AM
Possible jumped belt timing is off? Symtoms EVOEvolved Evo General 7 Jul 9, 2016 05:42 AM
Rough Idle/lean idle Siluck2 Evo Engine / Turbo / Drivetrain 11 Apr 11, 2016 06:06 PM
Low idle after spark plug change davids2004 Lancer Engine Tech 15 Jul 17, 2005 11:37 AM


Tags
boost, evo, idle, rpm drop

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 10:58 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: