08 Es Radio Replacement with OEM 14 Ralliart touchscreen radio Questions - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Lancer Audio and Security (All models) Discuss new audio system upgrades or alarm configurations.

08 Es Radio Replacement with OEM 14 Ralliart touchscreen radio Questions

Reply
 
 
 
Thread Tools Search this Thread
Old Jun 12, 2017, 04:39 AM   #1
Newbie
Thread Starter
 
SaiyanLancerES's Avatar
 
Join Date: Jun 2017
Location: Florida
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Lancer Es

08 Es Radio Replacement with OEM 14 Ralliart touchscreen radio Questions

Hey Everyone,

First let me start off by saying I am a COMPLETE newbie when it comes to cars but I have been learning a lot via this site and youtube plea

Now with that being said, Im slowly but surely working my 08 Es up, and I recently bought a 2014 OEM Ralliart double din stereo along with a OEM head unit to replace my current one.

I conneted everything and when I turned my car on all of my service prompts started popping up (ie. all doors are open, check engine, low tire pressure, check air bags, ALL OF THEM) so I thought maybe I ****ed something up so I disconnected everything then reconnected my old unit and the prompts DID NOT come on so I tried redoing everything again and everytime I plugged the new unit in it was the same thing all the prompts came back.

While the new unit was in it worked fine (except it did not show it had bluetooth, and the aux did not function via my original rca factory aux setup)

I called a couple of mitsubishi dealerships and service departments and they all had different reasons;

1. I crossed a wire (impossible as it uses the OEM wire harness, and when i plugged my old unit back in it worked perfect)

2. I need to have the service department reset my car (ecu) (personally sounded like a good reason but like i said I am a newbie so idk if this would even do anything)

3. There is a setting on the radio that i have to reset everything ( I looked and looked but there is not a setting for this

4. "we have no idea" (figures lol)

So I am wondering does anyone have any ideas on why this is happening?
Could it be that the radio is not compatible with my car and thats why the Bluetooth,aux functions don't and the service prompts pop up? (if this is the case why would the radio still function though?)

Side Note (I know I plugged everything in properly and securely, and I also unplugged the negative from my battery to avoid short circuits while installing so Im lost.)

Thank you in advance to any and everyone that responds.
Offline
 
Reply With Quote
Old Jul 10, 2017, 10:06 AM   #2
Newbie
 
macgyverphil's Avatar
 
Join Date: Jul 2017
Location: Moncton, NB
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: '16 Lancer SE LTD

This is just from what I read in other forums, but someone said that it does have to be programmed to the car... Can't confirm this though. Can try to unplug the battery for 5-10 minutes after the install and see if that clears it.

As far as BT goes, could have something to with the programming also, but I also read that 2014 Touchscreen units have models that both had and didn't have Bluetooth...

This is just from what I have read so don't hold me to it.

I'd go to the dealership who said it needs to be programmed, get it programmed, and if that doesn't work, they can't charge for something they didn't do...
Offline
 
Reply With Quote
Old Jul 11, 2017, 01:10 PM   #3
Evolved Member
iTrader: (21)
 
Raikiri's Avatar
 
Join Date: Oct 2008
Location: Chicago, IL
Posts: 2,655
Thanks: 0
Thanked 7 Times in 7 Posts

Drives: 05 Pearl White Ralliart AT (sold), 14 WW Ralliart

The OEM FUSE systems have been changed over the years and some features of the OEM radio like BT and Aux may not be compatible between the units
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AUX for W210 and E39 Rolands New Off-Topic 0 Apr 12, 2017 08:02 AM
Android double din radio install review w/full working wheel controls no adapter! Charlienofun Evo X Electrical / Audio / Security 57 Jan 31, 2017 05:48 PM
Custom CarPC built to replace RF nav system Darunt Evo X Electrical / Audio / Security 3 Sep 6, 2016 04:02 PM
Depinning Wires on 18-Pin Stereo Audio Connector? sicily12341 Evo X Electrical / Audio / Security 1 Oct 1, 2015 07:22 AM
First Impressions - Kenwood eXcelon KDP-X693 LTParis Lancer Audio and Security (All models) 0 Jun 27, 2009 02:30 PM


Tags
help me with info, lancer 2008, oem, radio head unit help es, stereo instalation

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:46 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: