High idle after replacing IAC ?! - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Member Unresolved Disputes Discuss incomplete sales including undelivered parts or payment for member to member sales.

High idle after replacing IAC ?!

Old Jun 14, 2018, 03:27 PM
  #1  
Newbie
Thread Starter
 
Dylann Jones's Avatar
 
Join Date: Jun 2018
Location: canada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
High idle after replacing IAC ?!

Let me start by saying the car is a 2003 Mitsubishi Lancer oz rally.

Previously my car would die on cold start and have high idle on hot days I also got a code for my IAC so I replaced it. After replacing the IAC my car started good on cold starts but when I turn my steering wheel my rpm go up like 1500. When I turn my heater on or AC my rpms also jump about 1500. So my cars reving around 2500-3000 when I do those things.

when I unplug the new IAC the idles donít jump doing those things. Iím so confused, has anybody had this ishue?! I gotta be doing something wrong!!!
Dylann Jones is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
4ukc
For Sale/WTB - Engine / Drivetrain / Power
10
Dec 7, 2015 02:33 AM
rm4g3d0n
Evo General
10
Mar 31, 2015 07:25 PM
CeeKayy
Evo General
20
Feb 20, 2013 06:30 PM
MRadjahoe
Evo Engine / Turbo / Drivetrain
6
Nov 30, 2012 04:25 PM
383firstgen
Evo Engine / Turbo / Drivetrain
8
Jul 10, 2012 08:42 AM


Thread Tools
Search this Thread
Quick Reply: High idle after replacing IAC ?!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.