How to reset the "Service Engine Soon" light? - evolutionm.net

Go Back   >
Log In 


Evo X How Tos / Installations Post or link to your detailed how to / installation articles in here. If you have any questions regarding the how tos, feel free to post them in the Request sub-forum.

How to reset the "Service Engine Soon" light?

Reply
 
 
 
Thread Tools Search this Thread
Old Jun 18, 2010, 09:26 AM   #1
Newbie
Thread Starter
 
Join Date: Nov 2009
Location: Houston
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Rally Red GSR

How to reset the "Service Engine Soon" light?

I got my oil and filter changed at the dealer not long ago but the "periodic inspection" wasn't reset and I had to do that myself. Now, my "Service Engine Soon" light is also coming up. How to I reset that?

PS: My car is stock beside a cobb intake. My local Mit dealership just went out of business. My car didn't come with a user manual.
Offline
 
Reply With Quote
Old Jun 18, 2010, 09:39 AM   #2
Evolving Member
iTrader: (3)
 
turpdogg's Avatar
 
Join Date: Feb 2005
Location: Miamisburg, Ohio
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2008 RR Evo X GSR

reset

Quote:
Originally Posted by Kompressorkit View Post
I got my oil and filter changed at the dealer not long ago but the "periodic inspection" wasn't reset and I had to do that myself. Now, my "Service Engine Soon" light is also coming up. How to I reset that?

PS: My car is stock beside a cobb intake. My local Mit dealership just went out of business. My car didn't come with a user manual.

turn off car, press and hold the info button until it beeps/flashes, press info again. Thats the down and dirty way to turn it off. I don't use mine so I just set it at the longest interval.
Offline
 
Reply With Quote
Old Jun 18, 2010, 09:47 AM   #3
Newbie
Thread Starter
 
Join Date: Nov 2009
Location: Houston
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Rally Red GSR

I did that, all it does is reset the periodic inspection on the display. I have a "Service Engine Soon" light that is on the dash. I would of take it to a dealer but the closest dealer to me is like a hour away.

I have read ppl having this light on from installing a TP or bov, but my car is stock.....
Offline
 
Reply With Quote
Old Jun 18, 2010, 10:03 AM   #4
Evolving Member
iTrader: (3)
 
turpdogg's Avatar
 
Join Date: Feb 2005
Location: Miamisburg, Ohio
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2008 RR Evo X GSR

oops

Quote:
Originally Posted by Kompressorkit View Post
I did that, all it does is reset the periodic inspection on the display. I have a "Service Engine Soon" light that is on the dash. I would of take it to a dealer but the closest dealer to me is like a hour away.

I have read ppl having this light on from installing a TP or bov, but my car is stock.....
OOps, I mis-read your post. Then you need to go to autozone/advance and pull the code to see whats going on.
Offline
 
Reply With Quote
Old Jun 18, 2010, 10:11 AM   #5
Newbie
Thread Starter
 
Join Date: Nov 2009
Location: Houston
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Rally Red GSR

Yea i guess so. Thanks anyway bro.

I have read somewhere that disconnecting your battery for 10min to reset the ecu might work. I am try it atm.
Offline
 
Reply With Quote
Old Jun 18, 2010, 10:18 AM   #6
Evolving Member
iTrader: (1)
 
Join Date: Oct 2009
Location: NorCal, Nevada, Military locations
Posts: 243
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 10 GG Evo X GSR

If the light comes back on then get the code checked.
Offline
 
Reply With Quote
Old Jun 18, 2010, 10:46 AM   #7
Newbie
Thread Starter
 
Join Date: Nov 2009
Location: Houston
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Rally Red GSR

It works. I am happy to save myself a trip from the dealer. Having my fingers cross for it to stay off. Thanks again guys.
Offline
 
Reply With Quote
Old Jun 18, 2010, 05:59 PM   #8
dxk
Newbie
 
Join Date: Oct 2008
Location: california
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
i unplugged my negative, waited 20 sec and it worked too
Offline
 
Reply With Quote
Old Jun 18, 2010, 09:07 PM   #9
Evolving Member
iTrader: (1)
 
white_evo27's Avatar
 
Join Date: Mar 2007
Location: NJ
Posts: 394
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 03 ww evo SOLD! 03 tb evo SOLD! 13 pb evo x 2006 gsxr 600

Quote:
Originally Posted by dxk View Post
i unplugged my negative, waited 20 sec and it worked too
+1
Offline
 
Reply With Quote
Old Jun 28, 2010, 12:01 PM   #10
Evolved Member
iTrader: (9)
 
MR. EVO MR's Avatar
 
Join Date: Jan 2005
Location: :noitacoL
Posts: 1,754
Thanked 1 Time in 1 Post
you can evoscan it too..
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
need a how Turn off or reset "PERIODIC INSPECTION" mitsubishimanny Evo X How Tos / Installations 42 Mar 11, 2015 03:45 AM
How do you Reset Service Required Light?? crank_18 Lancer Engine Tech 6 Dec 5, 2012 04:28 PM
EVO X AWC Service Required light Bear.914 Evo X General 12 Jan 26, 2012 02:14 PM
Evo IX service manual RedEvoInKy EvoM Newbie / FAQs Forum 9 Sep 25, 2006 07:28 PM
How can I reset ENGINE SERVICE LIGHT svue Evo How To Requests / Questions / Tips 6 Jan 14, 2004 10:13 AM


Tags
2003, 2010, check, engine, evo, evom, indicator, lancer, light, mit, mits, oil, reset, resetting, service

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -7. The time now is 09:38 PM.