Engine stall issue - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
04-06 Ralliart Engine/Drivetrain (no forced induction)

Engine stall issue

Reply

 
 
 
Old Jul 25, 2017, 03:12 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jul 2017
Location: Alberta
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Engine stall issue

Hey guys, hoping someone can help me with this issue I've been having with my 06 Ralliart. A little historyon it, when I got the car the owner had a turbo for me but was not on the car cause the intercooler has a hole blown in it. But the car ran fine without the turbo for about 6 months, then the throttle position sensor went, replaced that and ever since then I have a this stall issue on and off as I've been in and out of the mechanic, they say it is fixed drives good for a week and comes back. The stall issue happens once the engine is up to operating temperature, it wants to choke and die, I have changed the valve cover gasket cause it was leaking, changed spark plugs, battery and when it stalls it doesn't turn the CEL light on.

A month ago it threw a code for my crankshaft position sensor circuit A? I had the sensor replaced but last week it threw the sensor again. Still dealing with the stall issue as well.

Any ideas to what's causing this stall?

Thanks
Delta Lance is offline  
Reply With Quote
Old May 3, 2018, 10:26 AM
  #2  
Newbie
 
Join Date: May 2018
Location: Puerto Rico
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Delta Lance View Post
Hey guys, hoping someone can help me with this issue I've been having with my 06 Ralliart. A little historyon it, when I got the car the owner had a turbo for me but was not on the car cause the intercooler has a hole blown in it. But the car ran fine without the turbo for about 6 months, then the throttle position sensor went, replaced that and ever since then I have a this stall issue on and off as I've been in and out of the mechanic, they say it is fixed drives good for a week and comes back. The stall issue happens once the engine is up to operating temperature, it wants to choke and die, I have changed the valve cover gasket cause it was leaking, changed spark plugs, battery and when it stalls it doesn't turn the CEL light on.

A month ago it threw a code for my crankshaft position sensor circuit A? I had the sensor replaced but last week it threw the sensor again. Still dealing with the stall issue as well.

Any ideas to what's causing this stall?

Thanks
Hello,
Did you solve your issue? I am have a very similar problem on my 2006 Ralliart. When I check the Throttle parameters the percent is -0.4%. Then when the engine normalize it is in 2.4%.

Thanks
edi3ca is offline  
Reply With Quote
Old May 7, 2018, 12:13 AM
  #3  
Newbie
Thread Starter
 
Join Date: Jul 2017
Location: Alberta
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by edi3ca View Post
Hello,
Did you solve your issue? I am have a very similar problem on my 2006 Ralliart. When I check the Throttle parameters the percent is -0.4%. Then when the engine normalize it is in 2.4%.

Thanks
I ended up cleaning the throttle body and doing and idle relearn procedure, and so far everything has been running smooth no fluctuations, hasnít stalled on me at all, I havenít checked my throttle parameters but will do that in the morning and Iíll let you know what mine are at.
Delta Lance is offline  
Reply With Quote
Old May 7, 2018, 09:26 AM
  #4  
Newbie
 
Join Date: May 2018
Location: Puerto Rico
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Delta Lance View Post


I ended up cleaning the throttle body and doing and idle relearn procedure, and so far everything has been running smooth no fluctuations, hasnít stalled on me at all, I havenít checked my throttle parameters but will do that in the morning and Iíll let you know what mine are at.
Can you tell me how to do the idle relearn procedure? Or there is any post that explain it?

Thank you!
edi3ca is offline  
Reply With Quote
Old May 7, 2018, 01:13 PM
  #5  
Newbie
Thread Starter
 
Join Date: Jul 2017
Location: Alberta
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
https://www.evolutionm.net/forums/ev...lls-start.html

Thatís the link for the Evo X ETV (Electronic Throttle Valve) relearn is in there, that is what I used.
Delta Lance is offline  
Reply With Quote
Old May 10, 2018, 05:49 PM
  #6  
Newbie
 
Join Date: May 2018
Location: Puerto Rico
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the information! I will try it in my RA. 👍
edi3ca is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Freire
Evo Engine / Turbo / Drivetrain
4
Feb 19, 2018 12:41 AM
dcdirtrider
General Engine Management / Tuning Forum
0
Apr 22, 2017 09:21 PM
AKB_EVO
Evo Engine / Turbo / Drivetrain
6
Mar 19, 2017 10:08 AM
clanzkiller
Evo Engine / Turbo / Drivetrain
25
Mar 15, 2017 09:55 PM
Ferp
Evo General
7
Nov 6, 2016 07:25 PM


Thread Tools
Search this Thread
Quick Reply: Engine stall issue


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.