What is this area for? Fuel pump cover - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo General Discuss any generalized technical Evo related topics that may not fit into the other forums. Please do not post tech and rumor threads here.
Sponsored by: RavSpec - JDM Wheels Central

What is this area for? Fuel pump cover

Old Yesterday, 05:53 AM
  #1  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
What is this area for? Fuel pump cover


What is this socket and what is the function of this portion? When i took out the sensor there is a rubber inside. I have a problem where my pressure is too low, around 0.5 bar so my car could not start. Tried changing with a new pump and it is still the same. Tried rewiring as well. Need help.

Last edited by gIGoN; Yesterday at 06:00 AM.
gIGoN is offline  
Old Yesterday, 07:05 AM
  #2  
EvoM Super Moderator
iTrader: (3)
 
MinusPrevious's Avatar
 
Join Date: May 2008
Location: So.Cal
Posts: 5,363
Thanked 687 Times in 657 Posts
This pic should help


MinusPrevious is offline  
Old Yesterday, 06:48 PM
  #3  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
Originally Posted by MinusPrevious View Post
This pic should help


thanks for the pic. What is that socket for? what tube is that? I could see a rubber inside it. I'm losing pressure, i'm not sure if this part is the root cause.
gIGoN is offline  
Old Yesterday, 07:02 PM
  #4  
kaj
Evolved Member
iTrader: (58)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 9,704
Thanked 240 Times in 230 Posts
A rubber? Like... a condom?
kaj is online now  
Old Yesterday, 07:26 PM
  #5  
EvoM Super Moderator
iTrader: (3)
 
MinusPrevious's Avatar
 
Join Date: May 2008
Location: So.Cal
Posts: 5,363
Thanked 687 Times in 657 Posts
Originally Posted by gIGoN View Post
thanks for the pic. What is that socket for? what tube is that? I could see a rubber inside it. I'm losing pressure, i'm not sure if this part is the root cause.
Put some arrows on the picture so we know what youre asking
MinusPrevious is offline  
Old Yesterday, 08:49 PM
  #6  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,601
Thanked 121 Times in 115 Posts
Originally Posted by MinusPrevious View Post
Put some arrows on the picture so we know what youre asking
Nvm. He's been asking about that left tube the entire time with the ground wire.
2006EvoIXer is offline  
Old Yesterday, 09:20 PM
  #7  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
yea, that's the one. There's a socket on that tube. I am wondering what that socket is for and what that tube is for.
gIGoN is offline  
Old Today, 10:19 AM
  #8  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,601
Thanked 121 Times in 115 Posts
That is the low fuel indicator switch.
2006EvoIXer is offline  
Old Today, 10:20 AM
  #9  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,601
Thanked 121 Times in 115 Posts
Maybe this thread can help you figure out your problem: https://www.evolutionm.net/forums/ev...evo-8-9-a.html

Are you installing a Walbro 255 pump?
2006EvoIXer is offline  
Old Today, 05:36 PM
  #10  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
Originally Posted by 2006EvoIXer View Post
Maybe this thread can help you figure out your problem: https://www.evolutionm.net/forums/ev...evo-8-9-a.html

Are you installing a Walbro 255 pump?
my pressure is too low even after replacing with a new pump. I dont think the pump is the issue.
gIGoN is offline  
Old Today, 05:53 PM
  #11  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
Originally Posted by 2006EvoIXer View Post
That is the low fuel indicator switch.
will it cause pressure leak if this rubber at the socket (inside the tube) is faulty..?
gIGoN is offline  
Old Today, 05:54 PM
  #12  
Evolved Member
iTrader: (1)
 
2006EvoIXer's Avatar
 
Join Date: Jul 2012
Location: California
Posts: 2,601
Thanked 121 Times in 115 Posts
Originally Posted by gIGoN View Post

my pressure is too low even after replacing with a new pump. I dont think the pump is the issue.
What pump are you using?
2006EvoIXer is offline  
Old Today, 09:56 PM
  #13  
Newbie
Thread Starter
 
gIGoN's Avatar
 
Join Date: Aug 2007
Location: Malaysia
Posts: 61
Thanked 0 Times in 0 Posts
Originally Posted by 2006EvoIXer View Post
What pump are you using?
walbro 255
gIGoN is offline  


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.