Notices
Evo X Engine Management / Tuning Forums Discuss the major engine management systems.

Bad tune?

 
Old Mar 6, 2019, 05:16 PM
  #1  
X86
Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Mass
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Bad tune?

hey guys new to the forum and new to the evo..

so I just bought my 15 x gsr and itís got ets intake, looks like invidia catles downpipe with invidia single exit exhaust, lightweight fly wheel with comp clutch donít know the stage. And Cobb with a protune.

( I havenít done any logs but I can if that will help with helping me) (it prob will lol )

So the problem Iím having

the car stalls with a/c on every time.... and the car stall sometime when Iím just at idle parked or redlight or on a roll in neutral...and thatís with the heat on (donít know if that matters but I havenít tried it with it off yet ) and the car smells like itís running real rich (gas) i donít know if thatís from the catles pipe.... idle sometime is ruff it sometimes feels like it wants to stall or sometime it high revs I wanna say 1200 rpm maybe a lil more

i searched and found some stuff but nothing to my prob beside the a/c issue witch no one really answered lol i can make vids and logs if you guys need it.

I dont know who tuned it I bought the car with all the stuff on it 2days ago...the dealer said they would look at the a/c issue but Iím thinking itís a tune thing so be4 they look at it and mess things up I wanted to see if Someone has the same issue and if itís something I can do..


Thank you

Last edited by X86; Mar 6, 2019 at 05:23 PM.
X86 is offline  
Old Mar 6, 2019, 06:15 PM
  #2  
AJV
Newbie
iTrader: (3)
 
AJV's Avatar
 
Join Date: Jun 2011
Location: Bay Area, CA
Posts: 80
Received 3 Likes on 3 Posts
Honestly my recommendation is you shouldn't have gotten the car. Especially from a dealer if it's tuned if you have no way to contact the previous owner. Though if I were you I would probably unmarry the cobb from the car, see if there is a stock tune on the access port and flash it back along with stock parts. I would then locate a reputable open source tuner and either
dyno tune or road tune it.

Last edited by AJV; Mar 7, 2019 at 08:32 AM. Reason: left out key
AJV is offline  
Old Mar 7, 2019, 07:13 AM
  #3  
Silver Sponsor
iTrader: (91)
 
ETS Michael's Avatar
 
Join Date: Mar 2007
Location: Vancouver, WA
Posts: 8,666
Received 35 Likes on 30 Posts
Does the intake have the heat shield? Can you send an engine bay picture?

- Robert
__________________
Michael
Pho: 360-896-3000
AIM: ETS MichaelR

Evo 8/9/X Intercoolers, Intakes, Piping Kits, Exhaust Systems, Manifolds, Downpipes, Test Pipes and Turbo Kits
ETS Michael is offline  
The following users liked this post:
JDZNate (Mar 22, 2019)
Old Mar 7, 2019, 07:45 AM
  #4  
Evolved Member
iTrader: (2)
 
Join Date: Jun 2002
Location: Allendale, MI
Posts: 702
Received 49 Likes on 45 Posts
It's normal to smell fuel if you're running catless. You really won't know AFR without a wideband gauge......

Robert's asking about the heat shield because if the radiator/AC fan blows on an open cone intake, it messes with the MAF reading and can cause idle / stalling issues.

If that's in place, check your vacuum lines (especially the line to the FPR on the intake) for any leaks

If those check out, it's quite likely that the tune doesn't match the installed parts any more and you're going to need to address the tune.

DO NOT flash it back to stock unless you have the stock parts to put back on the car. Running an intake and catless on the stock tune would be asking for trouble.
splattj is offline  
Old Mar 7, 2019, 02:04 PM
  #5  
Evolved Member
iTrader: (1)
 
letsgetthisdone's Avatar
 
Join Date: Oct 2013
Location: Las Vegas
Posts: 12,320
Received 712 Likes on 670 Posts
Originally Posted by ETS Michael View Post
Does the intake have the heat shield? Can you send an engine bay picture?

- Robert
Do this first.

If the heat shield isn't there the intake gets super hot air when the fan comes on. Messes with the idle big time.
letsgetthisdone is offline  
Old Mar 7, 2019, 06:33 PM
  #6  
X86
Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Mass
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Thanks for the replyís

When I searched ac issue I did find something on heat shield for intake. I didnít get a chance to try it but I did today after work I just blocked the fan with a card board and turned on the ac seemed to work I had the hood open tho idk if that matters but once I took the card board out in like 1 min it started doing it with hood open. So Iím guessing itís that lol still getting it retuned

so does ets sell just the shield if so it donít look like I would have room for it Iíll try and post a pic of it today
X86 is offline  
Old Mar 7, 2019, 06:45 PM
  #7  
X86
Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Mass
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts

Intake looks to close to put a shield
X86 is offline  
Old Mar 11, 2019, 10:08 AM
  #8  
Newbie
 
Metal_AF's Avatar
 
Join Date: Aug 2018
Location: Ohio
Posts: 44
Likes: 0
Received 6 Likes on 5 Posts
Should be able to fit it on there, but might want to twist the intake a little for everything to line up right. The BOV return looks a little twisted. Here is mine with the shield:


Metal_AF is offline  
Old Mar 11, 2019, 03:42 PM
  #9  
X86
Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Mass
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Metal_AF View Post
Should be able to fit it on there, but might want to twist the intake a little for everything to line up right. The BOV return looks a little twisted. Here is mine with the shield:



It came like that so I thought thatís how it was supposed to be. But i ended up fixing the intake to the right direction yesterday.. after seeing other photos that ppl posted lol.. I couldnít find ets heat shield separate so I ordered stm tuning heat shield hope it works lol.

X86 is offline  
Old Mar 14, 2019, 02:45 PM
  #10  
X86
Newbie
Thread Starter
 
Join Date: Mar 2019
Location: Mass
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
So I got the shield in today installed it and tried it out seems to be working with ac on so far no stall but that was only 10 min of having a the car running with ac on. Lol to cold out for ac lol

now for my other question prob stupid but do I need to retune it. Because wouldnít it have been getting better/more air in the intake be4 the shield?
the intake was more twisted into the wide open spot

im going for a tune just so I know more about the car but thatís not till may
X86 is offline  
Old Apr 15, 2019, 04:24 PM
  #11  
Newbie
 
Join Date: Aug 2018
Location: NYC
Posts: 52
Received 2 Likes on 2 Posts
You don't need to retune it, but I think you should still get Tune so make sure everything
is running the way it should and of course to see how much power shes making.

Its funny I had a similar situation
when I went to look at an Evo (which I now own) at the dealership. I turned it on
with the A/C running and it started to idle horrible and the check engine light came on.
It was so disappointing cause I really really wanted that Evo.
Well as I was about to walk out the dealership. Lucky for me the Manager saw me leaving and came running
to me to see whats going on. Turns out he owns a Evo, so he checked under the hood and noticed the problem right away.
He said give me one minute and went to get a piece of cardboard and like magic the idle was
perfect again. Thank God cause not too many choices you know when shopping for a Evo.
llllBULLSEYE is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.