Evo X official paint issues/problems thread {merge} - Page 2 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Evo X General Discuss any generalized technical Evo X related topics that may not fit into the other forums.

Evo X official paint issues/problems thread {merge}

 
Old Mar 7, 2008, 08:45 AM
  #16  
EvoM Administrator
Thread Starter
iTrader: (23)
 
Noize's Avatar
 
Join Date: Mar 2003
Location: Nashville
Posts: 8,728
Thanked 26 Times in 19 Posts
Originally Posted by scottatayamaha View Post
I found this on www.ripoffreport.com apparently the Lancer GTS is having this same problem and this guy claims Mitsu would not help him at all. Not good news. I cant wait for my mud flaps to get here.

http://www.ripoffreport.com/reports/...Off0313051.htm
Noize is offline  
Old Mar 7, 2008, 02:02 PM
  #17  
Newbie
 
ronmcdon's Avatar
 
Join Date: Feb 2008
Location: Los Angeles
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by seminole2001 View Post
What was the price and part number for the splash guards if you don't mind me asking?
dont know the part #, but the oem ones are about $190.
ronmcdon is offline  
Old Mar 7, 2008, 05:26 PM
  #18  
Newbie
 
Join Date: May 2006
Location: Nor cal, So cal
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
mmm... is this problem really on every single evoX? that could be a big negative for mitsu when i purchase my car in a couple months... (between 135i and evoX)
AzNaLaN15 is offline  
Old Mar 7, 2008, 07:14 PM
  #19  
Evolved Member
iTrader: (2)
 
hel_if_ino's Avatar
 
Join Date: Mar 2003
Location: Monterey, CA
Posts: 639
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by AzNaLaN15 View Post
mmm... is this problem really on every single evoX? that could be a big negative for mitsu when i purchase my car in a couple months... (between 135i and evoX)
Who the hell knows man...
hel_if_ino is offline  
Old Mar 9, 2008, 08:00 AM
  #20  
Newbie
 
Join Date: Jan 2008
Location: Montreal
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
It would be nice for others who have the body kit to comment on this... If it actually protects from chips, it could be an argument to get it before it gets worst. Also, If anybody has pics of mudflaps installed, it would be nice to see if it kills the look (anybody saw the pics of the "rally" evoX with the flaps? Ugly...
kart125 is offline  
Old Mar 9, 2008, 09:16 AM
  #21  
Evolved Member
iTrader: (4)
 
PDXEvo's Avatar
 
Join Date: Jan 2004
Location: Portland, OR
Posts: 1,054
Thanks: 0
Thanked 0 Times in 0 Posts
For cheaper then the mud flaps, you could go get a small sheet of 3M Clear bra installed on those areas. I had that stuff put on behind all my wheels for protection.
PDXEvo is offline  
Old Mar 9, 2008, 04:28 PM
  #22  
UFO
Evolved Member
iTrader: (7)
 
UFO's Avatar
 
Join Date: Feb 2003
Location: Houston, TX
Posts: 1,529
Thanks: 0
Thanked 0 Times in 0 Posts
500 miles....




I live in the city and we have no snow/ice/salt/grit on the roads.
UFO is offline  
Old Mar 9, 2008, 09:14 PM
  #23  
Newbie
 
Join Date: Feb 2008
Location: SoCal
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
damn, that look bad for a car with only 500 miles
///AMG is offline  
Old Mar 10, 2008, 05:52 AM
  #24  
Newbie
 
Join Date: Jan 2008
Location: N.J.
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
250miles : (In NJ driven on paved roads only.) Granted my pass side isn't bad..yet... my driver side took a huge one. Really upsetting.


Driver side chip!






Pass side :

Keepster13 is offline  
Old Mar 10, 2008, 06:28 AM
  #25  
Former Sponsor
iTrader: (101)
 
Jrod@Buschur's Avatar
 
Join Date: Aug 2003
Location: York, PA
Posts: 4,488
Thanks: 0
Thanked 0 Times in 0 Posts
Wow... that freakin stinks!
Jrod@Buschur is offline  
Old Mar 10, 2008, 09:26 AM
  #26  
Newbie
 
BambiTLK's Avatar
 
Join Date: Mar 2007
Location: Dallas, TX
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
I'm scared to look...I was going to wash her today, but now I'm not so sure. It's only been 378 miles...
BambiTLK is offline  
Old Mar 10, 2008, 09:27 AM
  #27  
Evolved Member
iTrader: (5)
 
EVIL_EVO_VIII's Avatar
 
Join Date: Aug 2004
Location: Lake Mary,FL
Posts: 4,110
Thanks: 0
Thanked 0 Times in 0 Posts
Mitsu still using the same cheap paint!
EVIL_EVO_VIII is offline  
Old Mar 10, 2008, 10:02 AM
  #28  
Newbie
 
Join Date: Mar 2008
Location: C/S, CO
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Shoot, I don't think anything compares to Subaru paint quality. I had an '05 STi and that thing + Colorado roads = disaster. Good grief.
Brahmzy is offline  
Old Mar 10, 2008, 12:07 PM
  #29  
Newbie
iTrader: (1)
 
Join Date: Apr 2003
Location: Texas
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
I don't think it has anything to do with the paint quality necessarily. It's more with the way the wheels flare out. Without any 3M type material covering the areas that stick out, they are going to get pelted with rocks.

As others have mentioned, this happened with the Evo VIII and Mitsu fixed it by putting more 3M where it was needed.

Short of waiting for a fix from Mitsu, I'd recommend getting a reputable clear bra provider to cover the area. Just my 2 pennies.

D
articfury is offline  
Old Mar 10, 2008, 12:08 PM
  #30  
Former Sponsor
iTrader: (18)
 
Join Date: Jul 2006
Location: Puyallup, wa
Posts: 5,457
Thanks: 0
Thanked 0 Times in 0 Posts
Mitsubishi paint has not improved from 1990 i see
Billy@EnglishRacing is offline  

Thread Tools
Search this Thread
Quick Reply: Evo X official paint issues/problems thread {merge}


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.