Ignition Retard Limit - evolutionm.net



Ignition Retard Limit

Reply
 
 
 
Thread Tools Search this Thread
Old Oct 17, 2008, 01:06 AM   #1
EvoM Guru
Thread Starter
iTrader: (6)
 
Join Date: Feb 2007
Location: Melbourne, Australia
Posts: 9,473
Thanked 37 Times in 29 Posts

Drives: WW EvoX GSR

Lightbulb Ignition Retard Limit

Hi Guys,

While looking for this knock stuff I came across the Ignition Retard limit in the ROM.

88590015 and 88580013 (9's???): 0x133e
96530006 and 94170015 (8's???): 0x173e

2 bytes, so uint16 scaling.

Now it defaults to 203 (or 0xCB), I found that by increasing it to 220 I was able to run -15* as opposed to the previous limit of -10*.

Now whoever disasm'd this ROM (Bez???) already found this, so I don't want to take any credit for it

Also I don't know the proper scaling yet, but if anyone figures it out let me know

Usual deal of test everything at idle - altmaps makes testing this pretty easy, just leave your standard map as-is, and then flick to altmaps with lots of timing retard at idle..

Cheers
D.
Offline
 
Reply With Quote
Old Oct 17, 2008, 01:32 AM   #2
Evolving Member
 
evo828's Avatar
 
Join Date: Apr 2007
Location: Slovakia
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: yellow Evo 8

That retard limit was referred in this thread as well:

https://www.evolutionm.net/forums/sh...9&postcount=13

90550001 should have the same: 0x173e (uint16)

Have it in my 96530006 def - but not played with it yet (actually do not need such a big retard
Offline
 
Reply With Quote
Old Oct 17, 2008, 07:33 AM   #3
Evolved Member
iTrader: (2)
 
TouringBubble's Avatar
 
Join Date: Jul 2006
Location: Chelsea, AL
Posts: 2,638
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: IX MR SE

Quote:
Originally Posted by evo828 View Post
Have it in my 96530006 def - but not played with it yet (actually do not need such a big retard
Unless you're a ricer and like to shoot flames ... like me.
Offline
 
Reply With Quote
Old Oct 17, 2008, 11:38 AM   #4
EE
Evolving Member
iTrader: (9)
 
Join Date: Oct 2007
Location: Lebanon
Posts: 398
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: evo 9

or want to make a custom ALS using altmap
great find

Tephra, can you find the address for rom 88840016 or 17?

Last edited by EE; Oct 17, 2008 at 11:41 AM.
Offline
 
Reply With Quote
Old Oct 17, 2008, 11:47 AM   #5
Evolved Member
iTrader: (10)
 
todd6027's Avatar
 
Join Date: Jun 2007
Location: Ireland
Posts: 1,820
Thanks: 0
Thanked 2 Times in 2 Posts

Drives: Evo V Mivec Turbo

mine is set to 255 on rom 90550001 but when logged it still only goes to -10 . regardless of what you put in the map.
Offline
 
Reply With Quote
Old Oct 17, 2008, 10:53 PM   #6
Evolving Member
 
Join Date: May 2007
Location: Italy
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Evo IX GSR

Quote:
Originally Posted by EE View Post
or want to make a custom ALS using altmap
great find

Tephra, can you find the address for rom 88840016 or 17?
In 88840016 and 17 address is 0x133e, but changing the value gives not linear results ad tephra wrote. I never logger less than -15 changing only 0x133e...
Offline
 
Reply With Quote
Old Oct 17, 2008, 11:13 PM   #7
EvoM Guru
Thread Starter
iTrader: (6)
 
Join Date: Feb 2007
Location: Melbourne, Australia
Posts: 9,473
Thanked 37 Times in 29 Posts

Drives: WW EvoX GSR

try setting 0x2038 the same as 0x133e

0x2038 should default to 0xCB as well..

edit - 2038 not 2308
Offline
 
Reply With Quote
Old Oct 18, 2008, 01:15 PM   #8
Evolving Member
iTrader: (3)
 
Join Date: Aug 2006
Location: Ireland
Posts: 264
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Mirage Mivec

Howdy dave
according to bez to get the timing to retard to anything below -10 you had to patch a few different places in the rom as there was a lot of code to stop the timing from dropping,
in the rom bez sent me he has full antilag, realtime tuning and speed density setup.
it would be excellent if you could incorporate these mods with your own to make a super patch,
if the above could be patched along with your own mods it would mean the stock ecu would be as powerfull as any aftermarket ecu,
and as bez has stated he is fully willing to share his findings for the benefit of the community
Offline
 
Reply With Quote
Old Oct 18, 2008, 01:31 PM   #9
Account Disabled
iTrader: (38)
 
Join Date: Aug 2005
Location: Virginia Beach, Virginia
Posts: 9,319
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 05 EVO 8

I agree it would be closer but I want more load and rpm columns
Offline
 
Reply With Quote
Old Oct 18, 2008, 04:23 PM   #10
Evolved Member
 
cossie1's Avatar
 
Join Date: Aug 2007
Location: UK
Posts: 569
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Evo6 RSII

Quote:
Originally Posted by todd6027 View Post
mine is set to 255 on rom 90550001 but when logged it still only goes to -10 . regardless of what you put in the map.
Change it to 128 and watch the 36 counts of knock that appear from nowhere
Offline
 
Reply With Quote
Old Oct 18, 2008, 05:20 PM   #11
EvoM Guru
Thread Starter
iTrader: (6)
 
Join Date: Feb 2007
Location: Melbourne, Australia
Posts: 9,473
Thanked 37 Times in 29 Posts

Drives: WW EvoX GSR

yeah because 128 would actually be limitting the retard so much that you are going into advance there... ie not allowing advance to drop below 10* or whatever...
Offline
 
Reply With Quote
Old Oct 18, 2008, 05:34 PM   #12
Evolved Member
 
cossie1's Avatar
 
Join Date: Aug 2007
Location: UK
Posts: 569
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: Evo6 RSII

Quote:
Originally Posted by tephra View Post
try setting 0x2038 the same as 0x133e

0x2038 should default to 0xCB as well..

edit - 2038 not 2308
90550001 uses 0x173e (or 0x173f unit 8) (by the way those address's work for all E7, E8 and E9 roms)

So would 0x2038 workout to be 0x2438 for 90550001 and all other e7 and 8 roms ?
Offline
 
Reply With Quote
Old Oct 18, 2008, 05:42 PM   #13
Evolved Member
iTrader: (10)
 
todd6027's Avatar
 
Join Date: Jun 2007
Location: Ireland
Posts: 1,820
Thanks: 0
Thanked 2 Times in 2 Posts

Drives: Evo V Mivec Turbo

Quote:
Originally Posted by cossie1 View Post
Change it to 128 and watch the 36 counts of knock that appear from nowhere

er, ive enough knock thanks,,think il sharpen up that chainsaw
Offline
 
Reply With Quote
Old Oct 18, 2008, 06:05 PM   #14
Evolved Member
iTrader: (17)
 
Jack_of_Trades's Avatar
 
Join Date: Jun 2007
Location: Opelika,AL
Posts: 3,523
Thanks: 0
Thanked 2 Times in 1 Post

Drives: '02 Passat V6 4-MOTION AWD (DD)

Quote:
Originally Posted by Mellon View Post
I agree it would be closer but I want more load and rpm columns

Amen to that!
Offline
 
Reply With Quote
Old Oct 18, 2008, 06:16 PM   #15
EvoM Guru
Thread Starter
iTrader: (6)
 
Join Date: Feb 2007
Location: Melbourne, Australia
Posts: 9,473
Thanked 37 Times in 29 Posts

Drives: WW EvoX GSR

Quote:
Originally Posted by cossie1 View Post
90550001 uses 0x173e (or 0x173f unit 8) (by the way those address's work for all E7, E8 and E9 roms)

So would 0x2038 workout to be 0x2438 for 90550001 and all other e7 and 8 roms ?
173e doesn't work for all rom's - my first post has what 173e is in evo9 land

I looked at the code for 90550001 and its totally different... doh

Interestingly in 90550011 the 0x173e is 0xBC not 0xCB
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TephraMod V7 tephra EcuFlash 3424 Apr 20, 2017 09:50 AM
Omni 4 bar MAP sensor ROM compatibility settings for USDM Evo 8/9 mrfred EcuFlash 258 Feb 19, 2017 11:23 AM
TephraXMOD V2 tephra Ecuflash 570 Dec 14, 2016 05:30 PM
Tuning pops and bangs in - graph attached confuzion EcuFlash 5 Mar 14, 2016 09:16 PM
Poor Cold Idle (Yes I searched) Appauldd EcuFlash 452 Sep 21, 2015 08:39 AM


Tags
17, 90550001, 94170015, 96530006, als, change, degrees, e85, evo, gsr, ignition, retard, setting, timing, turbo

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 06:03 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send