Patch: Force OBD Inspection Pass (acamus, mrfred) - Page 33 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
EcuFlash
Sponsored by:
Sponsored by:

Patch: Force OBD Inspection Pass (acamus, mrfred)

Reply

 
 
 
Old Mar 25, 2017, 09:00 AM
  #481  
Evolved Member
 
Biggiesacks's Avatar
 
Join Date: Aug 2005
Location: The Bay Area
Posts: 2,726
Thanked 149 Times in 143 Posts
Originally Posted by UShouldLetMeGo View Post
Ah yeah I downloaded Phenoms updated xml for v7 and replaced it with the other v7 I had and it worked. Thanks!

Since mine was tuned in the past and I did not have to modify anything in the xml all my tables should remain what it was from my cars ecu? Because the xml is just telling where to pull the tables and creation of tables essentially correct? Sorry when I learn I like to know dumb details about "how" and "why" things do what they do lol. I just want to know because I know they tuned for the Evo 9 turbo, cams, injectors, and exhaust previously.
That's correct. The XML is just giving the location and labels of the data. The actual information populated in those tables is from the ECU.
Biggiesacks is offline  
Reply With Quote
Old Mar 25, 2017, 05:46 PM
  #482  
Jp7
Evolved Member
iTrader: (6)
 
Jp7's Avatar
 
Join Date: Mar 2007
Location: on the interwebz
Posts: 982
Thanks: 0
Thanked 9 Times in 9 Posts
modifying bits and bytes in an ECU is actually alot like playing 8 bit nintendo back in the 1990s when game "genie came" out.

The game genie codes had hexidecimal values and locations.

No difference between that and fuel injection pulsewidth values, and ignition advance... lol

just like making super mario jump higher, or have infinite lives.
Jp7 is offline  
Reply With Quote
Old May 13, 2017, 02:14 PM
  #483  
Newbie
iTrader: (1)
 
Join Date: May 2017
Location: SF
Posts: 18
Thanked 2 Times in 2 Posts
Question

help when i try to add this patch to my 9694001 xml file i get an error message and nothing works in ecuflash. heres a link to my problem i posted in another thread:

https://www.evolutionm.net/forums/ec...iting-xml.html
city is offline  
Reply With Quote
Old May 14, 2017, 12:31 PM
  #484  
Newbie
 
mufasa39's Avatar
 
Join Date: Sep 2011
Location: Phoenix
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Whats with all the wrx and subaru stuff? never seen that for a EVO, This is not for a suby. You have a HTML editor,when you copy and paste?
mufasa39 is offline  
Reply With Quote
Old May 14, 2017, 01:06 PM
  #485  
Newbie
iTrader: (1)
 
Join Date: May 2017
Location: SF
Posts: 18
Thanked 2 Times in 2 Posts
I got the latest version of ecuflash v1.44.4799 from the tactrix website, so i guess thats why theres subaru stuff because the tractrix openport 2.0 can work with subarus too. i used note pad to edit the xml file. i didn't use a HTML editor.
city is offline  
Reply With Quote
Old May 14, 2017, 01:26 PM
  #486  
kaj
Evolved Member
iTrader: (56)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 8,338
Thanked 160 Times in 155 Posts
Note Pad FTW. I've never been able to edit any other way, but it's been a few years since I've had to.
kaj is offline  
Reply With Quote
Old May 25, 2017, 10:24 AM
  #487  
Newbie
iTrader: (1)
 
Join Date: May 2017
Location: SF
Posts: 18
Thanked 2 Times in 2 Posts
i've tried everything removing ecuflash and reinstalling it, i still can't get it to work. i am using windows 10 OS 64bit, i will try on my friends computer running windows 7 OS 32bit and see if it works.
city is offline  
Reply With Quote
Old Jul 8, 2017, 01:50 PM
  #488  
Newbie
iTrader: (2)
 
Join Date: Apr 2013
Location: Denver
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
I wish I would have revisited this thread before going in for test! I had the original patch settings and failed because of the 3 monitors that shouldn't be enabled on an Evo.

Here's stock vs what works for me:



The "Part 1" value was put back to stock (0x4019).
The "Availability" values are now identical to stock 88590015 ROM.
Pass/fail values were taken from the stock ROM, and then I changed EGR and Catalyst '1'

Last edited by jsmcpn; Jul 8, 2017 at 01:59 PM.
jsmcpn is offline  
Reply With Quote
Old Jul 8, 2017, 02:03 PM
  #489  
kaj
Evolved Member
iTrader: (56)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 8,338
Thanked 160 Times in 155 Posts
Originally Posted by jsmcpn View Post
I wish I would have revisited this thread before going in for test! I had the original patch settings and failed because of the 3 monitors that shouldn't be enabled on an Evo.

Here's stock vs what works for me:


The "Part 1" value was put back to stock (0x4019).
The "Availability" values are now identical to stock 88590015 ROM.
Pass/fail values were taken from the stock ROM, and then I changed EGR and Catalyst '1'
Same thing happened to me. I fixed it and the smog tech said, "I don't know how you fixed it so fast, but it's passing".

I think I had issues because I had the rear o2 patch and it's settings were conflicting. All I now is I gave up, put the cat on and let it pass normally.
I never got the car to pass by only changing settings in these menus. I wish I could.
kaj is offline  
Reply With Quote
Old Jul 8, 2017, 02:18 PM
  #490  
Newbie
iTrader: (2)
 
Join Date: Apr 2013
Location: Denver
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Unfortunately I couldn't finish the updated patch before the testing stations shut down for the weekend. I'm out of town next week so I'll have to wait to re-test until next Saturday.

Last time I went, this ROM was not a problem with all the Availables set to 1, so their system must have gotten an upgrade. This time it was detecting that the Air Injection, Heated Catalyst and A/C Refrigerant monitors were "Available" even though they shouldn't be on an Evo! Air Injection is a diesel-specific OBDII monitor I presume.
jsmcpn is offline  
Reply With Quote
Old Jul 8, 2017, 02:24 PM
  #491  
kaj
Evolved Member
iTrader: (56)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 8,338
Thanked 160 Times in 155 Posts
Originally Posted by jsmcpn View Post
Unfortunately I couldn't finish the updated patch before the testing stations shut down for the weekend. I'm out of town next week so I'll have to wait to re-test until next Saturday.

Last time I went, this ROM was not a problem with all the Availables set to 1, so their system must have gotten an upgrade. This time it was detecting that the Air Injection, Heated Catalyst and A/C Refrigerant monitors were "Available" even though they shouldn't be on an Evo! Air Injection is a diesel-specific OBDII monitor I presume.
All smog shops detect this. Odd they didn't catch it your first time.
kaj is offline  
Reply With Quote
Old Jul 8, 2017, 02:50 PM
  #492  
Newbie
iTrader: (2)
 
Join Date: Apr 2013
Location: Denver
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Does Cali actually dyno test Evos or just do the 2-speed idle sniff?
CO would normally dyno test a vehicle of this age, but the station manager told me they exempt the Evo because even stock they're too scary/difficult for general staff - clutch too grabby, etc.
jsmcpn is offline  
Reply With Quote
Old Jul 8, 2017, 03:54 PM
  #493  
kaj
Evolved Member
iTrader: (56)
 
kaj's Avatar
 
Join Date: Mar 2006
Location: Fresno, CA
Posts: 8,338
Thanked 160 Times in 155 Posts
Originally Posted by jsmcpn View Post
Does Cali actually dyno test Evos or just do the 2-speed idle sniff?
CO would normally dyno test a vehicle of this age, but the station manager told me they exempt the Evo because even stock they're too scary/difficult for general staff - clutch too grabby, etc.
visual and OBD-II scan. There are probably a few shops that are still doing the sniffer, but not to my knowledge. Those are RPM test only; none of them run AWD dynos.
kaj is offline  
Reply With Quote
Old Jul 10, 2017, 07:16 PM
  #494  
Newbie
 
Join Date: Mar 2015
Location: Golden, CO
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
I haven't had much free time lately but promised I would post in this thread for future reference of Evo 9 owners in Colorado. Normally Colorado will run cars on an AWD dyno but they will give you the option to have them scan your OBD system because the factory rims are "low profile" and can be damaged on the rollers.

I am running 88590715 Tephra V7 rom. I never had an issue with them passing my car with all of the settings on "forced pass". This latest go around I failed and was handed a report saying there was an issue with the obd systems being "not supported".

I started a this thread: https://www.evolutionm.net/forums/ec...supported.html

The resolution was changing the "Non-continuous monitor availability patch part 1" from forced pass (e000) to stock settings (4019). Double checking on my generic OBDII scanner, this produced the correct items reading as supported and the items being not relevant to the car reading as not supported.



It was also suggested that I change all of the items on the monitor pass/fail table to match the items on the monitor available/not available table. When I did this my scanner would come up with conflicting info that I was worried about the emission center catching. Example would be: heated cat would read not supported, not available and not complete with the two tables matching. (I was thinking it would be odd if a not available item read not complete.)

When I would change the pass/fail table to pass (1) for everything that same example for heated cat would read: not supported, not available and complete or n/a on my scanner. (It made more sense if it read n/a since the heated cat is indeed not applicable.)

When I compared the readings I would get for supported and not supported items on my wife's stock car, those settings matched exactly.

Attached is a screen shot of my settings that I passed with since its kind of confusing to describe.
Attached Thumbnails Patch: Force OBD Inspection Pass (acamus, mrfred)-emission-pass.png  
pk303 is offline  
Reply With Quote
The Following User Says Thank You to pk303 For This Useful Post:
butte (Jul 11, 2017)
Old Sep 6, 2017, 12:56 AM
  #495  
Newbie
 
Join Date: Jul 2017
Location: Cali
Posts: 34
Thanked 6 Times in 3 Posts
Originally Posted by jsmcpn View Post
Unfortunately I couldn't finish the updated patch before the testing stations shut down for the weekend. I'm out of town next week so I'll have to wait to re-test until next Saturday.

Last time I went, this ROM was not a problem with all the Availables set to 1, so their system must have gotten an upgrade. This time it was detecting that the Air Injection, Heated Catalyst and A/C Refrigerant monitors were "Available" even though they shouldn't be on an Evo! Air Injection is a diesel-specific OBDII monitor I presume.
Any updates did you pass with your new settings?
And also how do you get rid of the Air Injection available?
EV09AWD is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Patch: Force OBD Inspection Pass (acamus, mrfred)


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.