Notices
Evo Engine / Turbo / Drivetrain Everything from engine management to the best clutch and flywheel.

Looking for all EVO 8, 9 people with 6 speed still.

 
Old Mar 16, 2019, 10:14 AM
  #346  
Evolved Member
 
Join Date: Mar 2008
Location: Croatia
Posts: 1,430
Liked 92 Times in 80 Posts
Originally Posted by Pal215 View Post
After having my 5 speed for 110,000 miles I switched over to the JDM MR 6 speed. Just over 1,500 miles on it now. Only using the pump gas 91 map for now which makes a little over 450whp. Have done no testing with E85 map yet. Fluid is REDLINE 75w-90NS GL-5 recommended by TRE and it shifts like butter once it's warm. When cold it can be a little notchy. I wonder if switching to MOTUL GEAR 300 75W90 would fix this. Other than that, no issues whatsoever. I love the gear distribution and the sorely needed 6th gear.
I ran my 6 speed on motul and it was fine apart from the second gear which would be ok when shifting fast but a bit notchy when doing a slow shift.. However, that was always connected to a worn clutch... with new clutch it shifted nice.. so it is no just about the oil..
kikiturbo is offline  
Old Mar 16, 2019, 11:46 AM
  #347  
Evolving Member
iTrader: (1)
 
Join Date: Sep 2018
Location: SoCal
Posts: 433
Likes: 0
Liked 33 Times in 31 Posts
So it seems that the 6 speeds in general have a common issue of a notchy 2nd gear when cold? If so, that's good to know. I thought there was something wrong with mine. As far as I know, mines been on OEM fluid since day one.
Lumpy Sticks is offline  
Old Mar 16, 2019, 12:15 PM
  #348  
Evolved Member
 
Join Date: Mar 2008
Location: Croatia
Posts: 1,430
Liked 92 Times in 80 Posts
yeah, but when your clutch wears and starts dragging a bit then it gets real bad.. I used to go directly from first to third in the city, and that worked best for me..
kikiturbo is offline  
Old Mar 16, 2019, 01:04 PM
  #349  
Evolving Member
iTrader: (1)
 
Join Date: Sep 2018
Location: SoCal
Posts: 433
Likes: 0
Liked 33 Times in 31 Posts
I think my clutch is worn for sure. Chatters pretty bad when cold. It's the OEM one with 60k on it. I have noticed that if I push the clutch in, wait a second, then shift to 2nd, it's always smooth.
Lumpy Sticks is offline  
Old Mar 16, 2019, 02:50 PM
  #350  
Jp7
Evolved Member
iTrader: (6)
 
Jp7's Avatar
 
Join Date: Mar 2007
Location: on the interwebz
Posts: 1,096
Liked 13 Times in 13 Posts
Originally Posted by Lumpy Sticks View Post
So it seems that the 6 speeds in general have a common issue of a notchy 2nd gear when cold? If so, that's good to know. I thought there was something wrong with mine. As far as I know, mines been on OEM fluid since day one.
My 6 speed evo 9 had a notchy engagement into second the very first day I brought it home with only 4 miles on it. I had the trans upgraded by shep in september 2014 with the higher strength parts and I change the final drive (made it taller). After the rebuild 2nd is smooth like the other gears. My trans did not fail in any way, I just wanted it upgraded to handle more power (which I am now making on a built 2.3)

I have put about 1,500 miles on it since then and it still shifts good.
Jp7 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PeteyTurbo
Evo Engine / Turbo / Drivetrain
198
Oct 20, 2017 09:35 AM
manthny18
For Sale/WTB - Engine / Drivetrain / Power
8
Apr 4, 2017 03:09 PM
ChicagoEvo9
For Sale/WTB - Engine / Drivetrain / Power
14
Jun 29, 2016 04:26 PM
DanielM
Evo General
4
Mar 28, 2016 05:35 PM
Evo MR IX Fritz
For Sale/WTB - Engine / Drivetrain / Power
2
Mar 2, 2016 04:04 PM


Thread Tools
Search this Thread
Quick Reply: Looking for all EVO 8, 9 people with 6 speed still.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.