Evo 8 Wont Start No Clue... HELP! - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Evo General Discuss any generalized technical Evo related topics that may not fit into the other forums. Please do not post tech and rumor threads here.
Sponsored by: RavSpec - JDM Wheels Central

Evo 8 Wont Start No Clue... HELP!


Old Aug 12, 2017, 07:46 AM
Thread Starter
Join Date: Sep 2014
Location: NY
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Evo 8 Wont Start No Clue... HELP!

Hey guys,

I have an evo 8 I drove over to my friends a few days ago and after getting back in she just wouldn't start. No sound at all when I turn the key, all lights come on just like if she was running and I can pop the clutch to start her if needed.

Haven't had any mods done in at least 8 months but I did have the battery relocated to the trunk about 2 months ago (maybe something came lose?)

I originally thought it was the starter so I replaced that but still isn't turning over or making any noise.
Also car seams to wanna stall out when at a stop, have to keep on the gas the whole time.

any ideas would be greatly appreciated thanks!

Last edited by Tadt; Aug 12, 2017 at 07:59 AM.
Tadt is offline  
Reply With Quote
Old Aug 12, 2017, 09:47 AM
Evolved Member
iTrader: (68)
BluEVOIX's Avatar
Join Date: Mar 2007
Location: IL
Posts: 1,909
Thanks: 0
Thanked 16 Times in 14 Posts
If the lights come on, the battery is hooked up. Did you check the battery if its still good? Maybe it has enough power to light up the bulbs but not enough to crank ? Also check the fuses for the starter .

If its wanting to stall during a stop then check the throttle body, IAC and look at all the vacuum lines that may have popped off or developed cracks/leaks.

I would say start troubleshooting with the above and see if you find anything.
BluEVOIX is offline  
Reply With Quote
Old Aug 12, 2017, 05:20 PM
Evolved Member
Bhsj13's Avatar
Join Date: Oct 2013
Location: United States
Posts: 1,274
Thanks: 0
Thanked 19 Times in 19 Posts
Bhsj13 is offline  
Reply With Quote
Old Aug 12, 2017, 11:22 PM
Evolving Member
iTrader: (1)
tbaird58's Avatar
Join Date: Sep 2013
Location: chico california
Posts: 237
Thanked 11 Times in 10 Posts
its going to sound silly but try to push the key in a little farther then crank it, mine does this every now and then
tbaird58 is offline  
Reply With Quote
Old Aug 14, 2017, 03:03 AM
iTrader: (1)
Join Date: Jul 2009
Location: Idaho
Posts: 44
Thanked 1 Time in 1 Post
Check your starter fuse. It's a fuseable link that used to be on the battery terminal. You may have it wrapped up depending on how you relocated battery.
also while your at it check your other motor fuses
Acuality is offline  
Reply With Quote
Related Topics
Thread Starter
Last Post
09+ Ralliart Engine/Turbo/Drivetrain
Aug 3, 2017 04:39 PM
Lancer Troubleshooting
Aug 3, 2017 03:39 PM
Evo General
Oct 7, 2016 05:19 PM
EvoM Newbie / FAQs Forum
Jun 27, 2016 07:45 AM

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Your question will be posted in: