factory speaker problems - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Notices
Lancer Audio and Security (All models) Discuss new audio system upgrades or alarm configurations.

factory speaker problems

Old Apr 28, 2004, 08:38 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2004
Location: Abilene, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
factory speaker problems

I installed a new cd player and 3 12 inch subs in my 2002 lancer. Everything was going great and then one day all of my factory speakers went out. The subs play and the cd player turns on but my factory speakers wont come on. Everything was working great for about 3 weeks then they just went off. I have never touched my door speakers. All the wires seem to be attached. Somebody please help.
scooter16 is offline  
Old Apr 28, 2004, 09:05 AM
  #2  
Newbie
 
KarlsLancer's Avatar
 
Join Date: Apr 2004
Location: College Station, Texas
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
same thing happend to my girlfriends 90 MPV, the speakers are blown.
KarlsLancer is offline  
Old Apr 28, 2004, 10:56 AM
  #3  
Newbie
Thread Starter
 
Join Date: Apr 2004
Location: Abilene, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
all four of them
scooter16 is offline  
Old Apr 28, 2004, 11:00 AM
  #4  
Newbie
Thread Starter
 
Join Date: Apr 2004
Location: Abilene, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
I dont think all four of them would blow at the same time.
scooter16 is offline  
Old Apr 28, 2004, 11:00 AM
  #5  
Evolved Member
iTrader: (2)
 
siantjab's Avatar
 
Join Date: Mar 2004
Location: TPA
Posts: 664
Thanks: 0
Thanked 0 Times in 0 Posts
If the highs and mids are run by a seperate amp, there is your problem. If they are running off the stereo pre-amp; it very likely blew. This sounds more like the case, as I'm assuming you are running the highs and mids off the stereo pre-amp and the subs off a seperate amp. Thus the subs still working.

Just some thoughts, hope it helps!!
siantjab is offline  
Old Apr 29, 2004, 02:08 PM
  #6  
Account Disabled
 
kaput16's Avatar
 
Join Date: Jan 2004
Posts: 303
Thanks: 0
Thanked 0 Times in 0 Posts
that's what i was thinkin. your stock speakers couldn't handle the higher watts the new stereo was pushin out and they blew
kaput16 is offline  
Old Apr 29, 2004, 02:12 PM
  #7  
Evolving Member
 
jaymz916's Avatar
 
Join Date: Jan 2004
Location: Las Vegas, Nv.
Posts: 309
Thanks: 0
Thanked 0 Times in 0 Posts
typically, even if speakers are blown you still get some form of sound out of them, again, I say typically, not 100%.
jaymz916 is offline  
Old Apr 29, 2004, 07:58 PM
  #8  
Evolving Member
 
Lance Dogg's Avatar
 
Join Date: Sep 2002
Location: Millersville, PA
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by jaymz916
typically, even if speakers are blown you still get some form of sound out of them, again, I say typically, not 100%.
i was thinkin the same thing. maybe the radios internal amp fried?
Lance Dogg is offline  
Old Apr 30, 2004, 06:29 AM
  #9  
Newbie
 
KarlsLancer's Avatar
 
Join Date: Apr 2004
Location: College Station, Texas
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
I am blowing my stock speakers as we speak (buzz, buzz) maybe I should get some new ones, hehe
KarlsLancer is offline  
Old Apr 30, 2004, 11:19 AM
  #10  
Newbie
Thread Starter
 
Join Date: Apr 2004
Location: Abilene, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Is there a way that I can test to see if my speakers are blown and how do i check to see if my radios internal amp is fried
scooter16 is offline  
Old Apr 30, 2004, 07:38 PM
  #11  
Evolving Member
 
Lance Dogg's Avatar
 
Join Date: Sep 2002
Location: Millersville, PA
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
to test if the speakers are blown, you have 2 options.

1. buy a DMM (digital multimeter) at k-mart or pep boys for like 15-20 bucks and test the ohm loads on the speakers.

2. go to circuit city and they can probably do it for you. they'll prob do the rears no prob since they can reach them from inside the trunk. but, the fronts they prob won't do free since you gotta pop the door panels off unless you pull out the radio.
Lance Dogg is offline  
Old May 6, 2004, 12:10 AM
  #12  
Newbie
 
Join Date: Apr 2004
Location: Las Vegas
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
blew two of my speakers after putting in my pioneer deck..............guess 50 watts was too much?! LMAO - Lancers have ****ty *** speakers......oh well crutchfield shows Alpine SPS-170A and Pioneer TS-A1670R as fitting all around, either can be obtained for around $100 for all 4.

Anyone have any suggestions on other speakers that are $100-150 - also if you suggest 6.5's where do I get the mounting bracket?
evolarts is offline  
Old May 8, 2004, 09:55 AM
  #13  
Newbie
Thread Starter
 
Join Date: Apr 2004
Location: Abilene, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
I replaced the front speakers and they still dont work. Can anybody help me. It sucks driving without a radio.
scooter16 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ALT3REVO
Evo X How Tos / Installations
1
Feb 12, 2017 01:15 PM
wadadah
Lancer Audio and Security (All models)
2
Dec 14, 2011 06:40 AM
Slovak
Lancer Audio and Security (All models)
4
Aug 20, 2005 10:06 PM
xbird
Lancer Audio and Security (All models)
11
Dec 19, 2003 12:31 PM
on3ofak1nd
Lancer Audio and Security (All models)
10
Dec 17, 2002 06:48 AM


Thread Tools
Search this Thread
Quick Reply: factory speaker problems


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.