Temperature sensor not working - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Lancer Troubleshooting Get help with any troubleshooting problems you may have.

Temperature sensor not working

Reply
 
 
 
Thread Tools Search this Thread
Old Jan 12, 2018, 01:10 PM   #1
Newbie
Thread Starter
 
Victoria Soyka's Avatar
 
Join Date: Jan 2018
Location: Canada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2012 Lancer ES

Temperature sensor not working

Hello!
I'm new here. Just trying to use some of your guys knowledge to help myself and my dad out!

I got some front end work body and mechanical done on my 2012 Lancer ES in October after a front end collision. Since then, my ambient temperature sensor hasn't been working. I didn't say anything because my friends shop did the work for a great price, the body damage that was repaired looked better than before. I've just kind of sat on it until now.
Since I got my car back from the shop, there has just been a blank temperature reading. Now that winter is in full force in Canada, I've been having some glitches. The car is reading the outside temperature as -40C, so I get the "road may be icy" alert on my dash. However the temperature reading isn't constant, and it basically beeps at me every 15-60 seconds to warn me. INCREDIBLY annoying. It's only done this 2-3 days in the last few months, typically during a really windy/snowy storm. I commute to work and the beeping makes me want to drive into a logging truck. The rest of the time the sensor isn't picking up anything, which also annoys me.

My dad just unplugged the sensor, cleaned it and replugged it in, before we do anymore work to make sure my buddy had finished the job correctly.
Looks like that wasn't the issue and the actual sensor itself is damaged. The dealership has said they will order the part for around 70$, but I've had really bad luck dealing with them and my dad builds cars as a hobby. I know we can do it a lot cheaper.

Is there anything we could be missing before I replace the sensor? I'm also scared I'm going to order the wrong part, the ******* at the dealership wouldn't write it down for me.
Offline
 
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How-To: Super Fantastic JDM HVAC Swap llDemonll Evo How Tos / Installations 71 Jan 10, 2018 02:19 AM
2004 Ralliart will not start, cranks hard, no spark on plugs bjr990 04-06 Ralliart Engine/Drivetrain 8 Sep 27, 2017 03:14 PM
SD - Cold Startup Lean Spike acid7711 EcuFlash 4 Nov 4, 2016 06:26 PM
Strange Overheating Issue (hear me out, please) Tw3NTy0n3 04-06 Ralliart Engine/Drivetrain 13 Jun 29, 2016 12:09 PM
Questions on looking to buy a used evo sweimert02 Evo X General 8 May 9, 2016 06:49 PM


Tags
sensor, temperature

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 04:57 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: