Notices
Lancer Troubleshooting Get help with any troubleshooting problems you may have.

2003 OZ Rally burning up coil packs

 
Old May 25, 2018, 09:29 AM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2013
Location: Cypress TX
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
2003 OZ Rally burning up coil packs

Started it up the other day, to move it out of the driveway and she was running really rough. I popped the hood to check for vermin, or maybe an untied shoe lace that I might be able to fix, and the number 1 coil pack popped like a firecracker and white smoke started oozing out. So I killed the engine, let the coil pack cool down and pulled it off. The plug well had about half an inch of oil in it... Assuming I had found my problem I bought a valve cover gasket kit with plug seals, 2 new coil packs and 4 new NGK plugs. everything plugged back in and started her up. within a minute the new coil pack popped and smoked as well. I am at a loss. I can't see anywhere where the wiring harness has any damage (rodents are a thing out here) and it was running fine last week. Any ideas on what could be causing the coil packs to pop and burn?
Eleventy5 is offline  
Old May 28, 2018, 10:37 PM
  #2  
Evolved Member
iTrader: (2)
 
OZR_Lancer's Avatar
 
Join Date: Feb 2007
Location: San Diego - SDSU Area
Posts: 1,178
Received 5 Likes on 5 Posts
check plugs themselves ? did u drain/remove oil from tubes ?, did you check that you did install plug wires in right oorder ? had to ask
OZR_Lancer is offline  
Old May 29, 2018, 03:47 PM
  #3  
Newbie
Thread Starter
 
Join Date: Aug 2013
Location: Cypress TX
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by OZR_Lancer View Post
check plugs themselves ? did u drain/remove oil from tubes ?, did you check that you did install plug wires in right oorder ? had to ask
Replaced the plugs, removed the oil from the tubes before pulling the plugs, absolutely installed plug wires in the correct order also. And considering the original coil pack popped and smoked before I did any additional work, I am thinking it is not related to anything I have done. Thanks for the reply!
Eleventy5 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rossi_24
For Sale - Interior / Exterior / Sound / Styling
1
May 21, 2016 09:09 AM
Raceghost
Evo Engine / Turbo / Drivetrain
21
Nov 2, 2012 07:47 AM
ozracer4
Lancer Aftermarket Forced Induction Tech
5
Jul 26, 2004 05:16 PM
gb-motorsports
Evo Engine / Turbo / Drivetrain
4
Nov 3, 2003 11:38 AM
rhyzin
Lancer Troubleshooting
1
Jun 25, 2003 03:33 AM


Thread Tools
Search this Thread
Quick Reply: 2003 OZ Rally burning up coil packs


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.